Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 15. Dez 2018 4:20

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 26. Aug 2005 20:39 
Offline

Registriert: 26. Aug 2005 20:21
Beiträge: 43
Wohnort: Augsburg
Nachdem ich endlich eine Drucker treiber für Brother MFC210c gefunden und installiert habe und der Drucker dann sogar noch über CUPS schön druckte, wollte ich über http://localhost:631 den Drucke administrieren. Dabei wird nach einem LOGIN mit PASSWORT gefragt. Nicht einmal root kann sich da anmelden. Weiß vielleicht jemand welches LOGIN benötigt wird, oder ob man root entsprechende Rechte geben kann ???
Grazie im Vorraus, Tux.Martin


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 27. Aug 2005 9:35 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
root-login sollte funktionieren. Wenn nicht, überprüfe man die cupsd.conf, ob der localhost die entsprechenden Rechte hat.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 27. Aug 2005 19:19 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 20. Apr 2004 12:19
Beiträge: 601
Wohnort: AT
hi
schau mal in der
/etc/cups/cupsd.conf
nach was unter Location steht

zb:

<Location /admin>
AuthType Basic
AuthClass System
Order Deny,Allow
Deny From All
Allow From 127.0.0.1

#Encryption Required
</Location>

wichtig ist was bei AuthType und AuthClass steht.

wenn du bei AuthType none eineträgst brauchst du kein passwort (aber nur zu testzwecken verwenden)

mfg
arno

_________________
[root@host]# cd /pub
[root@host]# more beer


Nach oben
   
BeitragVerfasst: 30. Aug 2005 20:49 
Offline

Registriert: 26. Aug 2005 20:21
Beiträge: 43
Wohnort: Augsburg
Leider funktioniert das Administrieren immer noch nicht. Obwohl die cupsd.conf richtig ist hat anscheinen root keine Rechte. Wer ist eigentlich lp ? Die Gruppe lp verstehe ich ja noch, aber den Besitzer lp ?!?
irgendwie habe ich das Gefühl, als ob root nicht der Gruppe lp angehört. Aber wie komme ich an die Rechte von root ???
Bitte helft mir. Gruss Tux.Martin


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 30. Aug 2005 22:32 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 20. Apr 2004 12:19
Beiträge: 601
Wohnort: AT
hi
Zitat:
Obwohl die cupsd.conf richtig
anscheinend nicht!

aber poste mal deine cupsd.conf

mfg
arno

_________________
[root@host]# cd /pub
[root@host]# more beer


Nach oben
   
BeitragVerfasst: 01. Sep 2005 20:56 
Offline

Registriert: 26. Aug 2005 20:21
Beiträge: 43
Wohnort: Augsburg
Hallo
die cupsd.conf sieht im entsprechnden Abschnitt wie folgt aus:
<Location /admin>
#
# You definitely will want to limit access to the administration functions.
# The default configuration requires a local connection from a user who
# is a member of the system group to do any admin tasks. You can change
# the group name using the SystemGroup directive.
#

AuthType Basic
AuthClass System
AuthGroupName sys

## Restrict access to local domain
Order Deny,Allow
Deny From All
Allow From 127.0.0.1

#Encryption Required
</Location>

#
# End of "$Id: cupsd.conf.in,v 1.13 2003/04/10 20:14:04 mike Exp $".
#

Vielleicht gibt es noch einen anderen Abschnitt, den ich ändern muß.
Danke für die Mühe, Gruss Tux.Martin


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 01. Sep 2005 21:08 
Offline

Registriert: 01. Jun 2004 9:36
Beiträge: 225
Nutzt du (K/)Ubuntu?

Dann musst du den Benutzer "cupsys" in die Gruppe "shadow" (/etc/shadow) aufnehmen.
Siehe http://www.cetico.org/blog/2004/12/solu ... 0679007701

MfG


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 01. Sep 2005 21:41 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 20. Apr 2004 12:19
Beiträge: 601
Wohnort: AT
hi
dokummentier das
AuthGroupName sys
aus
so:
#AuthGroupName sys

cups neustarten
usw.

mfg
arno

_________________
[root@host]# cd /pub
[root@host]# more beer


Nach oben
   
BeitragVerfasst: 10. Sep 2005 11:50 
Offline

Registriert: 26. Aug 2005 20:21
Beiträge: 43
Wohnort: Augsburg
Hallo,
dank Euer aller Hilfe, jetzt habe ich die Lösung gefunden. Im Abschnitt Filter Options muß der User root eingetragen werden.
Siehe http://www.cetico.org/blog/2004/12/solu ... 0679007701

#
# User/Group: the user and group the server runs under. Normally this
# must be lp and lp, however you can configure things for another
# user or group as needed.
#
# Note: the server must be run initially as root to support the
# default IPP port of 631. It changes users whenever an external
# program is run, or if the RunAsUser directive is specified...
#

User lp
User root
Group lp
RunAsUser Yes

#

Vielen Dank allen, die mitgeholfen haben.
Gruss Tux.Martin


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de