Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
default gateway

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
wüstenfuchs
Gast





BeitragVerfasst am: 12. Sep 2005 17:42   Titel: default gateway

Grüß Gott,


ich habe seit einiger Zeit folgendes Problem:
meistens wenn ich Linux 2.4.25-1-386 boote, ist meine routingtabelle leer. Ich muss dann jedesmal das default-gateway per Hand einrichten (Das Dsl-Modem). Das Komische ist, dass es manchmal dennoch funktioniert - von wegen Determinismus!

Ich verwende Debian. Welches Init-Script setzt denn die Einträge der Routingtabelle? Vielleicht sollte ich einfach die Prioritäten der Skripte ändern - aber dazu muss ich natürlich erst mal wissen, welches Skript das richtige ist.

Welchen Log soll ich posten (bevor ich hier wild rumposte)?


Herzlichen Dank und herzlichen Gruß,
vom ewig flüchtigen Wüstenfuchs
 

pingu_



Anmeldungsdatum: 13.03.2004
Beiträge: 58

BeitragVerfasst am: 12. Sep 2005 19:52   Titel:

Hallo,

vielleicht hilft folgendes:

bei debian 3.1 (sarge ist der gateway in der datei: /etc/network/interface definiert)

Wobei für jeden Netzwerk- Adapter ein Eintrag vorhanden ist. Bei mir schaut das so aus...

iface eth0 inet static
name Ethernet LAN-Karte
address 192.168.1.100
netmask 255.255.255.0
broadcast 192.168.1.255
network 192.168.1.0
gateway 192.168.1.1
 
Benutzer-Profile anzeigen Private Nachricht senden

wüstenfuchs
Gast





BeitragVerfasst am: 13. Sep 2005 8:04   Titel:

@ pingu

Also Du hast ja ein festes gateway eingetragen. Aber mein default gw ist ja das, das mein ppp0 device von meinem isp zugewiesen bekommt, und diese IP ist ja dynamisch. Also kann ich ja auch keinen festen Wert in /etc/network/interfaces setzen.

Wie funktioniert das eigentlich? Irgendein sript muss doch die IP vom ppp0 device auslesen und dann explizit das gw darauf setzen. oder funktioniert das mit einer bestimmten Variablen?


Frische Grüße vom Wüstenfluch.
 

tom servo



Anmeldungsdatum: 01.06.2004
Beiträge: 225

BeitragVerfasst am: 13. Sep 2005 8:27   Titel:

@ wüstenfuchs
Sag uns doch bitte mal genau, wie dein Internetanschluss usw eingerichtet bzw aufgebaut ist ... Ich verstehe zumindest gar nichts.

Hast du einen Router, dann folgendes ->
http://www.debiananwenderhandbuch.de/tcpip.html
Hier muss die interne und somit feste IP deines Routers als Gateway herhalten. DNS-Einträge in die /etc/resolv.conf nicht vergessen! Wink

Hast du nur ein DSL-Modem, dann folgendes ->
http://www.debiananwenderhandbuch.de/internet.html#dsl
Wär mir übrigens neu, wenn man bei dieser Variante ein Gateway einrichten muss?? Ich lern aber gerne dazu. Wink

MfG
 
Benutzer-Profile anzeigen Private Nachricht senden

wüstenfuchs
Gast





BeitragVerfasst am: 13. Sep 2005 19:11   Titel:

Also ich habe ein DSL-Modem, das mein default-gw ist. Entschuldige, ich dachte, das wäre schon in meinem ersten Beitrag klar geworden.

Natürlich muss ich dann auch ein default-gw setzen. Woher soll denn ein firefox denn sonst wissen wohin er eine Anfrage senden soll?

Mich wundert nur, dass es manchmal dennoch geht. Und mich interessiert eigentlich hauptsächlich, wo im init-Prozess die routing-Tabelle gesetzt wird, bzw. mit welchem Skript bei Debian.

Weiß das jemand?


Vielen Dank und Gruß vom flinken Wüstenfluss!
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 14. Sep 2005 8:09   Titel:

Grüß dich

Findet eigentlich eine automatische Einwahl bei dir statt und hast du mal überprüft, ob die Netzwerkkarte ok - das heißt immer aktiviert ist.

Die default route wird gesetzt, wenn die Verbindung zum Provider steht. Findet keine Einwahl statt (aus welchem Grund auch immer), keine default route.

Auf deiner Suche nach der route würde ich mal die Netzwerkskripte ifup- und dergleichen durchgehen.

Wie lang ist die Liste, die du mit

Code:
grep -rl "route" /etc


bekommst?


Wie ist das Wetter um dich?
Lateralus
 
Benutzer-Profile anzeigen Private Nachricht senden

wüstenfuchs
Gast





BeitragVerfasst am: 14. Sep 2005 13:56   Titel:

Ich grüße zurück mein Lateralus!

Ich habe zwar die automatische Einwahl beim booten durch pppoeconf ausgeschalten aber "er" settet das ppp0 device trotzdem immer auf up.

Die Netzwerkkarte ist ok - hab für 7 Euros extra ne neue gekauft, weil ich dachte, die alte sei für den Arsch.

ein

grep "route" /etc/ -rl | wc -l

liefert 51.

>Die default route wird gesetzt, wenn die Verbindung zum Provider steht.
Naja, die Verbindung steht doch sowieso immer. Solange ich eben das Modem angeschalten habe. Wenn ich es ausschalte ist die Verbindung zum Provider unterbrochen. Wenn ich es einschalte wird es synchronisiert und eine Verbindung zum ISP wird hergestellt - unabhängig davon, ob der Rechner nun an oder aus ist.

Ich würde gerne den Vorgang verstehen, welcher das default-gw setzt. Welches ominöse Scriptlein macht das denn im Init-Vorgang?

Feuchte Grüße aus dem nass-kalten Wüstenwetter
wünscht Wüstenflux B. , der in der ersten Oktober-Woche in Berlin Obdach sucht.
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 15. Sep 2005 7:05   Titel:

Jetzt nochmal langsam für mich. Du meinst nicht Modem, sondern Router, oder?

So sieht's aus?:

Code:
[Rechner] --- [Kleine Kiste (womöglich mit WLAN?)] --- [Weiße Box] --- [Weiße Box 2] --- Internet]


Du benutzt also nicht pppoe, sondern wanderst einfach per LAN bis zum Router, der dann pppoe benutzt, richtig (also eth0, statt ppp)? (Und hier gleich noch: Hast du noch ein - richtiges - Modem im/am PC?) Der Router müsste doch eine feste IP haben, die du als default gateway angeben kannst. Ansonsten schau doch mal, was passiert, wenn du es über DHCP versuchst, aber so oder so ist die Frage, warum deine Netzwerkkarte nicht immer Verbindung zum Router hat.

Liegt's vielleicht am Router? Sprich: Wannimmer du nach dem Hochfahren ein ifconfig durchführst, läuft die Netzwerkkarte dann unter der richtigen IP? Gibt es vielleicht Konflikte zwischen dem ppp-Device und der Netzwerkkarte und was sagt ein "dmesg | grep eth", wenn's mal wieder nicht funktioniert?
 
Benutzer-Profile anzeigen Private Nachricht senden

wüstenfuchs
Gast





BeitragVerfasst am: 15. Sep 2005 13:43   Titel:

Hallo Latenross!


Also meine Ethernet Karte

eth0: RealTek RTL8139 at 0xd4b7af00, 00:50:fc:ab:79:32, IRQ 11
eth0: Identified 8139 chip type 'RTL-8100B/8139D'
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1

hängt direkt am DSL-Modem. Und mein DSL-Modem wird ja, sobald es angeschalten ist mit der Gegenseite (ISP) synchronisiert. Das heißt sobald das Gerät angeschalten ist, steht ne Verbindung und ich hab für 24 h ne IP (24h ist nur aufgerundet, in wirklichkeit sind es weniger, vielleicht 23:59:55). Ich habe gar kein Router. Deshalb benutz ich ja pppoe. hab mir aber jetzt ein eigenes skript gebastelt, das mir die default route jedesmal explizit setzt. Nämlich:

Code:

#!/bin/bash
dev_ip=`ifconfig | grep -A1 ppp0 | tail -1 | cut -d : -f 2 | cut -f 1 -d " "`
route add default gw $dev_ip


Trotzdem würds mich interessieren, wo das gw normalerweise im init-Prozess gesetzt wird. Ihr seid doch alle Linux-Menschen. Wieso weiß das keiner? (Jetzt ernte ich bestimmt schlimmen Spott)

(-:

Grüße vom witzigen Wüstenfloß
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 15. Sep 2005 19:48   Titel:

wüstenfuchs hat folgendes geschrieben::
Trotzdem würds mich interessieren, wo das gw normalerweise im init-Prozess gesetzt wird. Ihr seid doch alle Linux-Menschen. Wieso weiß das keiner?


Ja... und wir schreiben alle unsere Init-Skripts selber! Razz

Aber mal ernsthaft: Das Setzen der default-route müsste von dem Programm realisiert werden, dass die Einwahl (oder was immer bei pppoe passiert) übernimmt. Dann ist vielleicht in der ppp.log oder pppoe.log unter /var/log was zu finden?

Liebe Grüße in den Süden.
Lateralus
 
Benutzer-Profile anzeigen Private Nachricht senden

wüstenfuchs
Gast





BeitragVerfasst am: 16. Sep 2005 7:33   Titel:

Hallo!

Also gut, ich gebe auf - eigentlich besteht ja jetzt das Problem auch nicht mehr, aber es ist schon seltsam. Aber wenigstens ist am Sonntag Bundestagswahl.


Herzliche Warmwasser-Grüße vom
lustigen Westenwitz
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 16. Sep 2005 9:37   Titel:

Stehen geblieben! Was ist mit den Logs?
 
Benutzer-Profile anzeigen Private Nachricht senden

wüstenfuchs
Gast





BeitragVerfasst am: 17. Sep 2005 7:41   Titel:

Hallo und guten Morgen!

Zitat:

Sep 18 09:51:20 abraxas dnsmasq[739]: using nameserver 212.114.153.1#53
Sep 18 09:51:20 abraxas dnsmasq[739]: using nameserver 212.114.152.1#53
Sep 18 09:51:20 abraxas pppoe[731]: PADS: Service-Name: ''
Sep 18 09:51:20 abraxas pppoe[731]: PPP session is 5483
Sep 18 09:51:23 abraxas diald[771]: Unable to open options file /etc/diald/diald.options: No such file or directory
Sep 18 09:51:23 abraxas diald[771]: Unknown option 'reroute'
Sep 18 09:51:23 abraxas diald[772]: start tap0: SIOCSIFMETRIC: Operation not supported
Sep 18 09:51:24 abraxas pppd[730]: CHAP authentication succeeded
Sep 18 09:51:24 abraxas kernel: PPP BSD Compression module registered
Sep 18 09:51:24 abraxas kernel: PPP Deflate Compression module registered
Sep 18 09:51:24 abraxas pppd[730]: not replacing default route to tap0 [0.0.0.0]
Sep 18 09:51:24 abraxas pppd[730]: Cannot determine ethernet address for proxy ARP
Sep 18 09:51:24 abraxas pppd[730]: local IP address 83.171.147.172
Sep 18 09:51:24 abraxas pppd[730]: remote IP address 212.114.214.10
Sep 18 09:51:24 abraxas pppd[730]: primary DNS address 212.114.152.1
Sep 18 09:51:24 abraxas pppd[730]: secondary DNS address 212.114.153.1
[/code]

Das ist das einzig Auffällige was ich im syslog finden kann.
Aber das sagt mir zu wenig.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy