Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 16. Nov 2018 6:29

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 13. Sep 2005 11:57 
Offline

Registriert: 25. Mai 2005 10:01
Beiträge: 15
Hi @All.
Ich nutze SuSe Linux 9.0 und führe regelmäßig über Yast die Updates durch. Beim letzten Update wurde auch der Kernel, wie schon des öfteren passiert, mit geupdated. Wenn ich nun versuche ein SMB Device zu mounten sieht es wie folgt aus:

Eingabe:
mount -t smbfs -o username=miuser -o password=miys //SERVER/GTX /gtx-transfer

Meldung:
ERROR: smbfs filesystem not supported by the kernel
Please refer to the smbmnt(8) manual page
smbmnt failed: 255

Was kann ich nun machen? Und vor allen Dingen WIE?
Ich hoffe jemand weiss Rat.

MrBrain

_________________
Auf Dauer hilft nur Power - und LINUX.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13. Sep 2005 12:27 
hi MrBrain,

wenn du die richtigen sourcen zu deinem kernel hast (sonst kannst du sie sicherlich nachinstallieren, müsstest du sie unter /usr/src/ finden, also:
Code:
cd /usr/src/deine-passenden-kernel-sourcen
make menuconfig
ausführen, und dann:
File systems > Network File Systems > SMB file system support (to mount Windows shares etc.
du findest dort auch ein (help). ebenso eventuell noch (ich habs ohne noch nicht probiert)) unter
File systems > DOS/FAT/NT Filesystems
die entsprechenden "teile" als module oder fest mit in den kernel bauen . und ihn, nachdem du die neue konfuration gespeichert hast, neu kompilieren (ich gehe von einem 2.6'er aus).
Code:
make all
make modules_install
cp arch/i386/boot/bzImage /boot/vmlinuz-2.6.x
bei fragen, und sowieso ist es gut mal
Code:
make help
einzugeben und zu lesen. danach nicht vergessen den kernel in deine
Code:
/boot/grub/menu.lst
einzutragen. unter [1] wird das ganze vielleicht noch ausführlicher beschrieben.

was du jetzt ansonsten noch suse-spezifisch machen kannst, kann ich dir nicht sagen, zumal ich es nicht benutze, es sollte doch aber eigentlich ein kernel-image geben, wo das bereits hinen kompiliert wurde. dann könntest du dir obiges einsparen.
deinen alten kernel hast du ja offenbar nicht mehr, aber sicherlich kannst du auch den, zu deinem neuen dazu installieren.

[1]
http://www.thomashertweck.de/kernel26.html

machs gut und viel erfolg!
bis denn
chlor

edit:
bei dem ganzen gehe ich davon aus, das du von einem 2.6er auf einen neueren 2.6er geupdatet hast. und 'module-init-tools' installiert sind!
ansonsten zuerst 'module-init-tools' installieren und probieren ob es dann funktioniert.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13. Sep 2005 13:58 
Offline

Registriert: 25. Mai 2005 10:01
Beiträge: 15
Hallo Chlor,
vielen Dank für Deine ausführliche Antwort. Mensch, was Du mir geschrieben hast ist ja schon fast ein Crashkurs im Kernel compilieren.
Ok, ich habe von einer anderen Installation den Kernel kopiert und entsprechend eingetragen, nun funktioniert das Mounten auch wieder. Deine Antwort habe ich ausgedruckt und zu meinen Unterlagen genommen, kann ja mal wieder passieren und ich habe keine andere Installation parat.
Nochmals vielen Dank,

MrBrain

_________________
Auf Dauer hilft nur Power - und LINUX.


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de