Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 13. Dez 2018 13:47

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 4 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: cups startet nicht
BeitragVerfasst: 12. Okt 2005 13:14 
Hi,

mein Cups verließ mich nach einen Update (Ubuntu 5.04)

Beim Inet.d-Start kommt keine Meldung, ruft dam cupd direkt auf:
cupsd: Child exited with status 99!

Die Fehlerlogdatei sieht so folgendermassen aus:
D [12/Oct/2005:13:54:35 +0200] LoadDevices: Added device "usb:/dev/usb/lp15"...
D [12/Oct/2005:13:54:35 +0200] LoadDevices: Added device "http"...
D [12/Oct/2005:13:54:35 +0200] LoadDevices: Added device "smb"...
I [12/Oct/2005:13:54:35 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 2516 PPDs...
I [12/Oct/2005:13:54:35 +0200] LoadPPDs: No new or changed PPDs...
D [12/Oct/2005:13:54:36 +0200] LoadAllJobs: Scanning /var/spool/cups...
I [12/Oct/2005:13:54:36 +0200] Full reload complete.
D [12/Oct/2005:13:54:36 +0200] StartListening: NumListeners=1
D [12/Oct/2005:13:54:36 +0200] StartListening: address=7f000001 port=631
E [12/Oct/2005:13:54:36 +0200] StartListening: Unable to bind socket for address 7f000001:631 - Die angeforderte Adresse kann nicht zugewiesen werden.

Woraus geht die Adresse hervor?
In der /etc/cups/cupsd.con steht nur
Listen 127.0.0.1:631
als Einziges darin.

Grüsse
Toner


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 12. Okt 2005 13:28 
Mahlzeit,

was sagt ein
lsof -i tcp ?
scheint, als ob der port 631 (cups) schon belegt ist

cups mal stoppen und ein ps ax | grep cups und lsof -i tcp testen

Gruss


Nach oben
   
 Betreff des Beitrags: nö ..
BeitragVerfasst: 12. Okt 2005 13:52 
Jo Hallo,

ein cups-Prozess geht ja nicht zu starten und belegt sieht der Port auch nicht aus:

COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
pump 6045 root 0u IPv4 8992 TCP *:bootpc (LISTEN)
portmap 6099 daemon 4u IPv4 9114 TCP *:sunrpc (LISTEN)
twistd 6612 aptproxy 0u IPv4 9833 TCP *:9999 (LISTEN)
icecast 6817 icecast 0u IPv4 10441 TCP *:8000 (LISTEN)
partimage 6866 root 5u IPv4 10597 TCP *:4025 (LISTEN)
postmaste 7051 postgres 3u IPv6 10788 TCP *:postgresql (LISTEN)
postmaste 7051 postgres 4u IPv4 10789 TCP *:postgresql (LISTEN)
smbd 7251 root 20u IPv4 11106 TCP *:microsoft-ds (LISTEN)
smbd 7251 root 21u IPv4 11107 TCP *:netbios-ssn (LISTEN)
sshd 7269 root 3u IPv6 11117 TCP *:ssh (LISTEN)
miniserv. 7509 root 6u IPv4 11509 TCP *:10000 (LISTEN)
apache2 8079 root 4u IPv6 12806 TCP *:www (LISTEN)
apache2 8094 www-data 4u IPv6 12806 TCP *:www (LISTEN)
apache2 8097 www-data 4u IPv6 12806 TCP *:www (LISTEN)
apache2 8098 www-data 4u IPv6 12806 TCP *:www (LISTEN)
apache2 8099 www-data 4u IPv6 12806 TCP *:www (LISTEN)
apache2 8100 www-data 4u IPv6 12806 TCP *:www (LISTEN)


Grüße
Toner


Nach oben
   
 Betreff des Beitrags: tip
BeitragVerfasst: 12. Okt 2005 14:10 
Aber danke, der Tip liess dann doch ein paar Hirnzellen weiterschalten:

localhost lief nicht!
Also ifconfig lo 127.0.0.1 up - und cups war zufrieden ;-)
und ich auch

Grrrrrüße


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 4 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de