Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
56k/GSM Dial-In Server

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
BlackPanther



Anmeldungsdatum: 29.05.2001
Beiträge: 44
Wohnort: Bern/Schweiz

BeitragVerfasst am: 14. Okt 2005 8:05   Titel: 56k/GSM Dial-In Server

Hallo zusammen,

Ich versuche schon seit geraumer Zeit einen Dial-In Server mit einem 56k Modem (Microlink 56k Fun II von Develo) einzurichten, komme aber nicht mehr weiter:
Was ich bis jetzt gemacht habe:

OS (Debian GNU/Linux SID)
in /etc/mgetty/mgetty.conf steht
Code:
speed 57600
port-owner root
port-group dip
port-mode 0664
issue-file /etc/issue.mgetty

port ttyS1
speed 57600
data-only y
rings 1
init-chat "" AT&F OK "AT &C1 &D2 L1 M1 E1 Q0 V1 Y1 &W" OK
post-init-chat "" ATS0=0 OK
answer-chat "" ATA CONNECT \c \r
login-conf-file /etc/mgetty/login.config

in der /etc/inittab habe ich folgende Zeile eingefügt
Code:
S1:23:respawn:/sbin/mgetty -x4 -s 57600  ttyS1

Wenn ich nun von einem Windows2000 Rechner (Laptop mit internem Modem) aus einen Einwahlversuch starte, so nimmt mgetty den Anruf zwar entgegen, erwartet ein 'CONNECT', was allerdings nicht kommt sondern 'ERROR' und hängt auf und geht in den Wartemodus - siehe Log ausschnitt
Code:
--
10/14 08:37:54 yS1  mgetty: interim release 1.1.33-Apr10
10/14 08:37:54 yS1  check for lockfiles
10/14 08:37:54 yS1  locking the line
10/14 08:37:55 yS1  lowering DTR to reset Modem
10/14 08:37:55 yS1  send: AT&F[0d]
10/14 08:37:55 yS1  waiting for ``OK'' ** found **
10/14 08:37:55 yS1  send: AT &C1 &D2 L1 M1 E1 Q0 V1 Y1 &W[0d]
10/14 08:37:55 yS1  waiting for ``OK'' ** found **
10/14 08:37:56 yS1  send: ATS0=0[0d]
10/14 08:37:56 yS1  waiting for ``OK'' ** found **
10/14 08:37:56 yS1  waiting...

10/14 08:41:50 yS1  wfr: waiting for ``RING''
10/14 08:41:50 yS1  send: ATA[0d]
10/14 08:41:50 yS1  waiting for ``CONNECT''
10/14 08:41:59 yS1  found action string: ``ERROR''
10/14 08:41:59 ##### failed A_FAIL dev=ttyS1, pid=5268, caller='none', conn='', name=''

--
10/14 08:41:59 yS1  mgetty: interim release 1.1.33-Apr10
10/14 08:41:59 yS1  check for lockfiles
10/14 08:41:59 yS1  locking the line
10/14 08:42:00 yS1  lowering DTR to reset Modem
10/14 08:42:00 yS1  send: AT&F[0d]
10/14 08:42:00 yS1  waiting for ``OK'' ** found **
10/14 08:42:01 yS1  send: AT &C1 &D2 L1 M1 E1 Q0 V1 Y1 &W[0d]
10/14 08:42:01 yS1  waiting for ``OK'' ** found **
10/14 08:42:01 yS1  send: ATS0=0[0d]
10/14 08:42:01 yS1  waiting for ``OK'' ** found **
10/14 08:42:01 yS1  waiting...


Was mache ich falsch? Hat jemand einen Tip? Ich habe schon recht intensiv Google benutzt und habe verschiedne HowTo's gefunden, doch bin ich mit keinem erfolgreich gewesen.

Der Grund, warum ich in Zeiten von DSL und Cable eine Netzwerkverfindung über eine Analogleitung herstellen will ist, weil ich ein embedded (Linux) System im Feld stehen habe und gerne den Status (über GSM) abfragen will.

Ich bin für jegliche Hilfe und Hinweise sehr dankbar!
Mike
_________________
2 2x | ! 2 2x == 2 b | ! 2 b
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy