mdadm - raid definiert - nach neustart wieder weg

Antworten
Nachricht
Autor
Gast

mdadm - raid definiert - nach neustart wieder weg

#1 Beitrag von Gast » 22. Okt 2005 14:04

hallo

ich habe keinen plan warum mein raid device nicht mehr definiert ist nach dem neustart

debian 2.4.27

ich mach folgendes

mdadm --create /dev/md1 -l 5 -n 3 /dev/hdb2 /dev/hdc2 /dev/hdd2

mit cat /proc/mdstat zeigt er dann auch alles schön an
aber nach einem neustart ist es laut
cat /proc/mdstat nicht mehr da.

muss ich des irgendwo abspeichern oder erst wieder starten??
wo liegen denn da die configs?
die /etc/mdadm/mdadm.config wird ja auch nicht benutzt.

wenn ich sie bei der installation definiere läuft alles wunderbar. des geht aber in dem fall nicht.

vielen dank für die hilfe
mfg

Benutzeravatar
Hans Solo
prolinux-forum-admin
Beiträge: 601
Registriert: 20. Apr 2004 12:19
Wohnort: AT
Kontaktdaten:

#2 Beitrag von Hans Solo » 22. Okt 2005 14:10

hi

bei mir (fedora) wird die config in der
/etc/raidtab
abgespeichert

zb.
raiddev /dev/md1
raid-level 1
nr-raid-disks 2
nr-spare-disks 0
chunk-size 32
persistent-superblock 1
device /dev/hda1
raid-disk 0
device /dev/hdb1
raid-disk 1

raiddev /dev/md2
raid-level 5
nr-raid-disks 3
nr-spare-disks 0
persistent-superblock 1
parity-algorithm left-symmetric
device /dev/hda2
raid-disk 0
device /dev/hdb2
raid-disk 1
device /dev/hdc2
raid-disk 2
hoffe es hilft
mfg
arno
[root@host]# cd /pub
[root@host]# more beer

Benutzeravatar
Hans Solo
prolinux-forum-admin
Beiträge: 601
Registriert: 20. Apr 2004 12:19
Wohnort: AT
Kontaktdaten:

#3 Beitrag von Hans Solo » 22. Okt 2005 15:00

hast du die partitionen mit fdisk als linux raid autodedect makiert?

mfg
arno
[root@host]# cd /pub
[root@host]# more beer

Antworten