Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
ich kann das modul fcpci nicht finden, (FritzCard-spezifisch)

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
trauriger user
Gast





BeitragVerfasst am: 25. Okt 2005 15:16   Titel: ich kann das modul fcpci nicht finden, (FritzCard-spezifisch)

ich hab mein ganzes wissen aufgebraucht um diesen treiber für ein pci-dsl-modem zu installieren.
es handelt sich um die fritz!card dsl sl (pci)
nachdem ich den treiber eigentlich gut installiert hab und auch ne ganze menge tools aud dem capi-zeugs-ordner komm ich doch noch nicht ins internet, ein capiinit liefert nämlich folgendes:
Code:

capiinit: FATAL: Module fcpci not found.
...

./drdsl sagt mir das der capi-treiber noch nicht instlliert/ zugänglich ist
und der versuch die firmware zu laden die komischweise unter /lib/firmware als "isdn" gespeichert wurde sagt das /dev/capi20 nicht existiert, obwohl ich das device erstellt habe?
manchmal meckert er aber nur über einen speichzugriffsfehler...

ich denke die sache hängt nur von dem fehlenden fcpci modul ab, der treiber hat anstandslos kompilliert aber das modul existiert einfach nicht auf meinen rechner???
 

brum
Gast





BeitragVerfasst am: 25. Okt 2005 15:34   Titel:

Der Befehl zum Laden von Module ist modprobe <Module ohne Endung)>, also z.B.

# modprobe fcpci

der Name muss aber genau richtig geschrieben sein.

Ansonsten nach Vorhandensein oder Schreibweise suchen
/lib/modules/<kernel-Version>/

weiter kernel, extras ,...

- have a lot of fun -
 

trauriger user
Gast





BeitragVerfasst am: 25. Okt 2005 16:25   Titel:

mmh, ja aber modprobe findet dieses verdammte modul auch nicht! und ehrlich gesagt versteh ich nicht warum avm einen linuxtreiber veröffentlicht, der kein fcpci modul bereitstellt, obwohl er es braucht?!
 

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 25. Okt 2005 17:52   Titel:

"modprobe" sucht nur unter /lib/modules/${KERNELRELEASE}/ (wenn du nicht am Kernel-Makefile geschraubt und neu gebaut hast). Was steht denn in der Treiberpaket-Doku wo das fertige Binäry hin soll?

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

trauriger user
Gast





BeitragVerfasst am: 25. Okt 2005 18:03   Titel:

das ist ja auch ein problem, avm hat im treiber keinerlei doku über die module, es werden halt einfach welche benötigt Twisted Evil
aber ich dachte das halt in diesem forum irgendwo leute zu finden sind, die hier auch so eine fritzcard benutzen.
 

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 25. Okt 2005 19:51   Titel:

Code:
user@host# locate fcpci
/usr/src/linux-2.6.13/drivers/isdn/hisax/hisax_fcpcipnp.c
/usr/src/linux-2.6.13/drivers/isdn/hisax/hisax_fcpcipnp.h


HTH, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 25. Okt 2005 22:34   Titel:

Zwei Ideen dazu:

Versuch evtl. mal "depmod -a", evtl. macht das der Fritz-Treiber nicht (eher unwahrscheinlich).

Wenn ich mich erinnere gibt's doch auch irgendwie nen fcpci2-Model (kommt auf die Hardware an denke ich). Versuch doch mal diesen Treiber zu laden (also modprobe fcpci2). Ist schon lange her, bin daher nicht sicher.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy