Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Debian-Installation misslingt auf Compaq ProLiant (mit SMART/2 Array Controller)

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
hauneboo



Anmeldungsdatum: 16.11.2005
Beiträge: 2

BeitragVerfasst am: 16. Nov 2005 22:57   Titel: Debian-Installation misslingt auf Compaq ProLiant (mit SMART/2 Array Controller)

Hallo Community,

Google schon seit Tagen und versuche wie verflixt, auf meinem Compaq ProLiant 2500 (Restware aus einem Rechenzentrum) Linux aufzusetzen - genauer Debian.
Windows 2003 Server zu installieren war bereits ein Problem (Netzwerkkartentreiber), aber mit Debian bin ich am Ende meines Ideenreichtums.

Egal, ob ich mit 2.4er- oder 2.6er Kernel boote - es hängt sich jedes Mal auf.

Das sieht dann so aus (letzten Zeilen bevor halt):

Code:

RAMDISK: Compressed image found at block 0
Freeing initrd memory: 2911k freed
VFS: Mounted root (ext2 filesystem).
Mounted devfs on /dev
VFS: Mounted root (ext2 filesystem).
Trying to move old root to /initrd ... okay
Mounted devfs on /dev
Freeing unused kernel memory: 96k freed
Setting up filesystem, please wait ...
__alloc_pages: 0-order allocation failed (gfp=0x1d2/0)
__alloc_pages: 0-order allocation failed (gfp=0x1d2/0)
__alloc_pages: 0-order allocation failed (gfp=0x1d2/0)
VM: killing process cp


Ich vermute es liegt am verwendeten SCSI-Controller SMART/2P Array Controller.
Hierzu habe ich hier im Forum schon was gefunden: http://dose.pro-linux.de/forum/viewtopic.php?t=1001905&highlight=0order+proliant

Dort schreibt Jochen (23.05. 14:46), man müsse beim Bootprompt einfach den Parameter
Code:
smart2=0x1000
oder bzw. falls nicht im Kernel implementiert den Parameter
Code:
insmod cpqarray.o eisa=0x1000
angeben. Beides habe ich ausprobiert; es funktioniert trotzdem nicht. Es kommt zwar dann nicht die "__alloc_pages"-Meldung, dafür aber kernel-panic (glaube es war cannot mount root fs).

Hat irgend jemand eine Idee? Ihr würdet einem Linux-Einsteiger einen sehr großen Gefallen tun.... Smile
Oder sollte ich eine andere Distribution ausprobieren, bei der ich die Problematik evtl. nicht habe? Natürlich wäre es ein ganzes Stück professioneller, erstmal diesen Fehler in Angriff zu nehmen ehe ich den Weg eines geringeren Widerstandes gehe... Oder ratet jemand generell von Debian als Server-System (vorerst mal Web- u. FTP-Server und später evtl. Routing-Aufgaben und VPN) ab?


Gruß
Andreas
 
Benutzer-Profile anzeigen Private Nachricht senden

hauneboo



Anmeldungsdatum: 16.11.2005
Beiträge: 2

BeitragVerfasst am: 23. Nov 2005 19:49   Titel:

Info: Habe inzwischen den SuSE memtest ein paar Tage in Dauerschleife laufen lassen - keine Fehler.

Wo ist der Fehler nun zu suchen - was sagen die Experten unter euch?
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy