Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 17. Nov 2018 6:09

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 14 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: usb-storage Probleme
BeitragVerfasst: 01. Nov 2005 10:58 
Offline
Benutzeravatar

Registriert: 16. Apr 2004 16:51
Beiträge: 155
im aktuellem 2.6.14er geht USB nur mit 8-16 kb/s (USB1.1). und wenn die Dateien dann endlich auf dem Stick sind, sind sie beschädigt.
Mit nem altem .10er gehts noch. Aber interessanterweise lässt dieser sich nicht mehr bauen.(Assemblerfehler bei MOV anweisungen, leider kein kompletter paste da).

Woran könnte das liegen, und wie bekomme ich das gefixed?

_________________
I came, I saw, I deleted all your files.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 05. Nov 2005 21:13 
Offline
prolinux-forum-admin

Registriert: 26. Jun 2004 21:18
Beiträge: 1444
Hallo Allo!

Neuen Kernelreleases in der 2.6er-Serie bringen laufend frisch-zerschossene Subsysteme mit sich. Die rc's des 2.6.14 hatten schon einige Sorgen mit usb (ua. eine lokale Lücke). Mein wenig weltbewegender Vorschlag: fahr 2.4 oder bleib bei einem Release unter 2.6 das funzt.
Mit etwas Glück liegts am Treiber. Dann sollte es helfen den usb_bulk_bla_oderwiederneuederniegehtheißt gegen den "alten" usb-storage zu tauschen. In einigen mir bekannten Fällen von USB-Probs mit Massespeichern hats geholfen. Sonst, Archiv-LKM. Da gibt es einige Threads zu usb unter 2.6.14rc-sonstwie. Vielleicht kommst du da weiter.

MfG, Klopskuchen

_________________
When all else fails, read the instructions .


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 05. Nov 2005 22:48 
Offline
Benutzeravatar

Registriert: 16. Apr 2004 16:51
Beiträge: 155
naja, der funktionierende der kompiliert ja nicht mehr, warum auch immer...

_________________
I came, I saw, I deleted all your files.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 10. Nov 2005 22:16 
Offline
Benutzeravatar

Registriert: 16. Apr 2003 5:05
Beiträge: 137
Wohnort: Buchholz idN
Welche mount Optionen verwendest du denn? Ich hatte mit "sync" ähnliche Proble, langsame Übertragung, aber meine Files waren Ok.....

_________________
soulfly@jabber.ccc.de


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 11. Nov 2005 10:37 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 14. Jan 2000 15:37
Beiträge: 699
Wohnort: Jülich
Ich sekundiere soulfly. Mit "sync"-Option übelste Übertragungsrate (wenige KB/s über USB 2.9), ohne hinreichend schnell.

Jochen

_________________
Die grösste Lüge der EDV? "Mal eben..."


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13. Nov 2005 0:01 
moin,
ich habe das gleiche prob wie Allo, suse 10 kernel 2.6.14, lesen also von stick auf hd geht mit 800kb/s aber drauf schreiben erst mit 100kb/s in einer minute dann runter auf satte 4kb/s. nun bin ich ganz neu bei linux und habe die antworten die ihr Allo gegeben habt nicht wirklich verstanden.
ich wäre für hilfe sehr dankbar :)


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13. Nov 2005 12:21 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 14. Jan 2000 15:37
Beiträge: 699
Wohnort: Jülich
Hi,

wenn Du Deinem Linux-System sagst "Schreib die Daten auf den Datenträger", dann nickt es erst mal recht freundlich und meint "Schon passiert!". In Wirklichkeit aber buffert es die zu schreibenden Daten im RAM und schreibt alles in einem Rutsch weg, wenn noch ein paar Daten mehr dazu gekommen sind oder eine bestimmte Wartezeit abgelaufen ist. Das macht das ganze System wesentlich performanter.

Problem an der Sache: Wenn der Strom ausfällt, sind die geschrieben geglaubten Daten trotzdem weg. Daher ein Linux-System nie einfach ausschalten, ohne es vorher heruntergefahren zu haben! (Zumindest, solange es irgendwie geht.)

Bei fest eingebauten Platten ist das nicht ganz so wild, da der Strom nicht so häufig ausfällt (und die Reparatur-Programme meist einen guten Job verrichten). Bei einem USB-Stick aber, der schon mal ganz beiläufig abgezogen wird, ist das nicht so prickelnd...

Wenn man ein Dateisystem in Betrieb nimmt, ist das o.a. Verhalten der Default. Man kann aber beim Mounten des Dateisystems auch mittels einer Option sagen, dass das System sich erst dann zurückmeldet, wenn es die Daten tatsächlich auf den Datenträger geschrieben hat. Das ist wesentlich weniger performant, aber bei solchen Datenträgern wie USB-Sticks eigentlich günstiger, weil die Chance für Datenverlust geringer wird.

Setzen kann man diese Option in der Datei "/etc/fstab". Leider kenne ich mich mit der SuSE nicht so gut aus - die arbeitet mit subfs, oder? Wenn Du die hier mal postest, könnte ich Dir sagen, wo diese Option steht (oder zu stehen hat).

Soweit die Theorie. Nur ist mit gesetzter sync-Option die Performance beim Schreiben auf den Stick so mies, dass es schon lächerlich wirkt. Daher lasse ich es eben und passe ein bisschen auf, dass ich den USB-Stick auch immer schön unmounte...

Alles klar soweit?

Jochen

_________________
Die grösste Lüge der EDV? "Mal eben..."


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13. Nov 2005 14:23 
Danke Jochen,

was du schreibst ist mir klar, sprich ich habs verstanden. is ja bei windoof auch nicht anders. nun scheint es mir so als würde es nicht zwischengespeichert oder so schnell das ich es nicht bemerke naja jedenfalls behauptet suse bzw. kde nicht es sei fertig sondern schreibt gleich auf den stick (der hat eine led wo man sehen kann das was rauf oder runter geht) nur eben sehr langsam.
wie kann ich denn die sync-option setzen oder abschalten und unmounten?!

aber sonst is alles klar auf der andrea doria und wenn der dampfer unter geht is auch egal u-boot fahren wollt ich schon immer mal :D

gruß Holzi


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13. Nov 2005 18:59 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 14. Jan 2000 15:37
Beiträge: 699
Wohnort: Jülich
Zitat:
Setzen kann man diese Option in der Datei "/etc/fstab". Leider kenne ich mich mit der SuSE nicht so gut aus - die arbeitet mit subfs, oder? Wenn Du die hier mal postest, könnte ich Dir sagen, wo diese Option steht (oder zu stehen hat).
:-) Natürlich kannst Du auch gerne mal ein "man fstab" und ein "man mount" machen und darin stöbern...

Jochen

_________________
Die grösste Lüge der EDV? "Mal eben..."


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13. Nov 2005 23:10 
ok Jochen, dann geh ich mal stöbern, ich denke "man fstab" und "man mount" muß ich in irgend ein terminal (dosfenster bei win) eingeben? und die datei"fstab" find ich im ordner etc? Oder!?

Gruß Holzi


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 13. Nov 2005 23:57 
Offline
Benutzeravatar

Registriert: 16. Apr 2003 5:05
Beiträge: 137
Wohnort: Buchholz idN
Jep, Konsole auf....

Und die fstab ist auch im Verzeichnis /etc

*G*

_________________
soulfly@jabber.ccc.de


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 15. Nov 2005 12:44 
moin Jochen und die anderen auch,

ich habe gestöbert und auch in anderen forn gelesen und wieder gestöbert, nun ja anscheinend is mein suse 10 anders als andere, ich komme jedenfalls nicht weiter. ich möchte doch nur auch bei linux meine mp3s auf den player bekommen muß ich denn nur deswegen wieder auf windoof umsteigen?

hier mal was in meiner /etc/fstab steht:

/dev/hda3 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/hda2 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/dvdrecorder /media/dvdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
none /subdomain subdomainfs noauto 0 0

usbfs hab ich auch dursucht, nix drinn was bekannt vorkommt. vieleicht fallt euch noch was ein

Gruß Holzi


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 16. Nov 2005 14:08 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 14. Jan 2000 15:37
Beiträge: 699
Wohnort: Jülich
Hi,

leider kann ich Dir da nicht weiterhelfen. Weder mit subfs noch subdomainfs (?) kenne ich mich aus. EiIgentlich hätte ich dort in der 4. Spalte (noauto,...) das Stichwort "sync" erwartet. Da das aber nicht der Fall ist, weiss ich nicht genau, wie die SuSE beim Mounten von USB-Sticks vorgeht und wo man dann dran drehen kann. Vielleicht findest Du unter /etc/sysconfig/* eine Datei mit passenden Vorgaben...?

Sorry, aber vielleicht kann Dir ja noch jemand weiterhelfen, der SuSE 10 auf der Platte hat und es mal selbst ausprobieren kann.

EDIT: Heh, zu früh gejammert! Erstens, meine Vermutung scheint korrekt zu sein, zweitens ist die Lösung hier: http://www.unixboard.de/vb3/showthread.php?t=15559
Und zwar auf der 2. Seite des Threads.

Viel Erfolg beim Basteln! :)

Jochen

_________________
Die grösste Lüge der EDV? "Mal eben..."


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 17. Nov 2005 15:55 
Vielen Dank Jochen,

es hat geholfen, nun funzt es recht ordenlich :)

Gruß Holzi


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 14 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de