Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 14. Dez 2018 1:19

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 8 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 24. Nov 2005 12:30 
Offline

Registriert: 23. Nov 2005 13:04
Beiträge: 4
Moin, liebe Leute.

Mein neuer Speicherstick (Samsung 512 MB USB2) wird nicht richtig erkannt. Hier verschiedene Informationen:

Von "lsusb", das heißt, das Ding an sich wird erkannt:
Code:
Bus 001 Device 002: ID 04e8:1623 Samsung Electronics Co., Ltd
Aus "/var/log/messages", hier fehlt im Vergleich mit meinem alten Stick der Teil, der das Pseudodevice näher beschreibt:
Code:
Nov 14 12:37:27 aldebaran kernel: hub.c: new USB device 00:07.3-1, assigned address 3
Nov 14 12:37:27 aldebaran kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Beim alten Stick sieht das so aus:
Code:
Nov 14 12:30:16 aldebaran kernel: hub.c: new USB device 00:07.3-1, assigned address 2
Nov 14 12:30:16 aldebaran kernel: scsi2 : SCSI emulation for USB Mass Storage devices
Nov 14 12:30:16 aldebaran kernel:   Vendor: Verbatim  Model: USB Drive         Rev: 2.00
Nov 14 12:30:16 aldebaran kernel:   Type:   Direct-Access                      ANSI SCSI revision: 02
Nov 14 12:30:16 aldebaran kernel: Attached scsi removable disk sde at scsi2, channel 0, id 0, lun 0
Nov 14 12:30:16 aldebaran kernel: SCSI device sde: 128000 512-byte hdwr sectors (66 MB)
Nov 14 12:30:16 aldebaran kernel: sde: Write Protect is off
Nov 14 12:30:16 aldebaran kernel:  sde: sde1 sde2 sde3 sde4
Nov 14 12:30:16 aldebaran kernel: WARNING: USB Mass Storage data integrity not assured
Nov 14 12:30:16 aldebaran kernel: USB Mass Storage device found at 2
In "/proc/scsi/scsi" steht dieses drin, hier ist interessant, dass alle Einträge leer sind:
Code:
Host: scsi3 Channel: 00 Id: 00 Lun: 00
  Vendor:          Model:                  Rev:     
  Type&#58;   <NULL>                ANSI SCSI revision&#58; ffffffff
Zu guter Letzt der relevante Teil von "/proc/bus/usb/devices", die Ausgabe war auch verzögert, offensichtlich liefen Tiemouts ab:
Code:
T&#58;  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D&#58;  Ver= 2.00 Cls=00&#40;>ifc &#41; Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P&#58;  Vendor=04e8 ProdID=1623 Rev= 1.00
C&#58;* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=200mA
I&#58;  If#= 0 Alt= 0 #EPs= 3 Cls=08&#40;stor.&#41; Sub=06 Prot=50 Driver=&#40;none&#41;
E&#58;  Ad=81&#40;I&#41; Atr=02&#40;Bulk&#41; MxPS=  64 Ivl=0ms
E&#58;  Ad=02&#40;O&#41; Atr=02&#40;Bulk&#41; MxPS=  64 Ivl=0ms
E&#58;  Ad=83&#40;I&#41; Atr=03&#40;Int.&#41; MxPS=  64 Ivl=1ms
Was läuft hier schief? Wie bekomme ich den "usb-storage" dazu, für den Stick tätig zu werden?

Schon 'mal vielen Dank!
Bodo


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 25. Nov 2005 12:25 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 05. Mai 2004 7:35
Beiträge: 1238
Falls Partitionen auf dem USB-Stick vorhanden sind und erkannt werden, müsstest du sie unter /dev/sdxy finden, wobei x=a,b,c,d,e,f,... und y=1,2,3,4,... ist.

Also zunächst ein
Code:
ls /dev/sd??
durchführen und dann je nach Ausgabe einhängen. Es kommt auch vor, dass die Partitionstabelle ein wenig komisch aussieht, dann lässt sich manchmal auch einfach nur /dev/sd? einhängen. (Wahrscheinlich seltsam formatiert.)

Beispiel für den Mount-Befehl (als root, wenn /media/usb-stick vorhanden):
Code:
mount /dev/sda1 /media/usb-stick
&#91;oder explizit das Dateisystem angeben&#58;&#93;
mount -t vfat /dev/sda1 /media/usb-stick
oder wie gesagt vielleicht auch
Code:
mount /dev/sda /media/usb-stick
&#91;oder explizit das Dateisystem angeben&#58;&#93;
mount -t vfat /dev/sda /media/usb-stick
Ich habe noch nicht davon gehört, dass man für verschiedene Sticks andere Treiber braucht - es sollte also machbar sein (oder ich habe dazuzulernen).


Nach oben
   
 Betreff des Beitrags: schon klar...
BeitragVerfasst: 25. Nov 2005 12:31 
Offline

Registriert: 23. Nov 2005 13:04
Beiträge: 4
Wie ich dann mounte, ist mir schon klar. Der mount geht aber schief, weil der USB-Treiber gar nicht mit dem Stick zusammenkommt.

Der Port ist dann übrigens ganz abgehängt: wenn ich den Samsung-Stick ziehe und meinen alten anstöpsele, passiert dort auch nichts mehr. Ein Neustart des Rechners ist erforderlich...


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 25. Nov 2005 13:00 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 05. Mai 2004 7:35
Beiträge: 1238
Existiert denn überhaupt eine solche Geräte-Datei in /dev?


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Nov 2005 11:48 
Offline
prolinux-forum-admin
Benutzeravatar

Registriert: 14. Jan 2000 15:37
Beiträge: 699
Wohnort: Jülich
Hi,

SuSE 8.2 ist vergleichsweise alt. Ich würde mal vorschlagen, dass Du einfach mal eine möglichst aktuelle LiveCD bootest (KNOPPIX 4.02?) und dann schaust, ob der neue Kernel mit dem Stick zurande kommt.

Falls ja, solltest Du über kurz oder lang mal updaten. Falls nein, scheint sich die Hardware nicht miteinander zu vertragen. Ich habe beispielsweise mit einem Samsung MP3-Stick (USB2, Flash) an einem alten AMD-Board schlechte Erfahrungen gemacht. Stick OK, Board OK, aber die Kombination haut einfach nicht hin.

Jochen

_________________
Die grösste Lüge der EDV? "Mal eben..."


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 28. Nov 2005 12:50 
Offline

Registriert: 23. Nov 2005 13:04
Beiträge: 4
@Lateralus: Klar, Devices gibt's jede Menge...

@Jochen: Gute Idee, daher habe ich mir eben 'ne Ubuntu ausgeliehen. Die werde ich dann ausprobieren...


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 02. Dez 2005 13:01 
Offline

Registriert: 23. Nov 2005 13:04
Beiträge: 4
OK, die Ubuntu mag den Stick; es liegt wohl am Treiber, wie vermutet.

Weil aber alles andere läuft, werde ich mein System in absehbarer Zeit nicht updaten. Die letzten beiden Male gab es immer wieder kleinere Probleme mit eingerichteter Software, und so wie er ist, läuft der Rechner für meine Zwecke (Palm-OS-Software entwickeln). Nur für so'n "zu modernen" Stick binde ich mir die Zeit nicht ans Bein.

Sollte noch jemandem etwas einfallen, wie "usb-storage" dazu überredet werden kann, als Treiber für den Stick tätig zu werden, nur her damit!

Vielen Dank an alle, die mir bis hierher geholfen haben :-)


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 02. Dez 2005 13:29 
Hi,
Zitat:
Sollte noch jemandem etwas einfallen, wie "usb-storage" dazu überredet werden kann, als Treiber für den Stick tätig zu werden, nur her damit!
Du musst eigentlich nicht dein System updaten, sondern nur deinen Kernel. Wenn SuSE 8.2 bereits den Kernel 2.6 unterstuetzt, dann ist das ueberhaupt kein Problem. Baut 8.2 noch auf dem 2.4er auf, dann muessen zumindest noch die modutils aktualisiert werden - das koennte schon problematischer werden.

Gruss,
Alex


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 8 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de