Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Wie bekomme ich meine WLAN Karte unter Suse zum Laufen?
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
homers530d



Anmeldungsdatum: 18.11.2005
Beiträge: 18

BeitragVerfasst am: 04. Dez 2005 11:36   Titel: Wie bekomme ich meine WLAN Karte unter Suse zum Laufen?

Hi!
Habe es nach Wochen geschafft mit einer Speichererweiterung Suse Linux 9.1 auf mein Notebook zu bekommen. Jetzt hänge ich am Problem des Internetzugangs.
Meine PCMCIA WLan-Karte Sinus 154 dsl card wird scheinbar in Yast als "Accton D-Links DWL-g650 A1" erkannt, aber weder leuchten die Lämpchen an der Karte, noch komm ich ins I-Net.
Könnt ihr mir helfen?
Thx im Vorraus!
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

homers530d



Anmeldungsdatum: 18.11.2005
Beiträge: 18

BeitragVerfasst am: 08. Dez 2005 0:17   Titel:

Kann mir denn keiner helfen? Crying or Very sad
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 08. Dez 2005 8:46   Titel:

Führe als root mal "lspci -vv" aus und poste das Ergebnis hier. Zudem versuch mal mit Hilfe von Google rauszufinden, welchen Chipsatz die Karte hat.
 
Benutzer-Profile anzeigen Private Nachricht senden

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 08. Dez 2005 12:16   Titel:

SuSE 9.1 ist ja nicht gerade aktuell.
Spricht was gegen ein Update?
 
Benutzer-Profile anzeigen Private Nachricht senden

homers530d



Anmeldungsdatum: 18.11.2005
Beiträge: 18

BeitragVerfasst am: 09. Dez 2005 12:31   Titel:

Hi!
Also die WLAN-Karte scheint von Yast erkannt zu sein.
Hab zumindest folgenden Eintrag drin:

Accton D-Links DWL-g650 A1 mit DHCP konfiguriert

Die Lämpchen an der Karte leuchten nicht, daher komm ich auch nicht ins Netz.
Vielleicht hilft das euch weiter
Grüßle
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 09. Dez 2005 12:50   Titel:

Das hilft nicht viel weiter. Was Du angibst, ist der Hersteller und die Typenbezeichnung der Karte . Was wichtig ist, um einen Treiber zu wählen, ist der Chipsatz.

Um es mal zu verdeutlichen: Ich habe als Mainboard ein Biostar NF4UL-A9. Soweit so gut. Was wichtig ist, ist dass dieses einen NForce4 Ultra Chipsatz hat.

Mit etwas Glück findest Du das mit dem lspci-Kommando heraus. Wenn nicht, dürfte Google weiterhelfen. Wobei das bei diesen Sinus-Karten der Telekom zugegeben schwer sein könnte. Ich kann mir vorstellen, daß verschiedene Karten (=verschiedene Chipsätze) unter diesem Namen verkauft werden. Aber das "lspci -vv" könnte uns schon weiterhelfen ...
 
Benutzer-Profile anzeigen Private Nachricht senden

homers530d



Anmeldungsdatum: 18.11.2005
Beiträge: 18

BeitragVerfasst am: 16. Dez 2005 10:55   Titel:

Thx für die Antwort!
Blöde Frage, wie genau kann ich den ispci-w befehl eingeben?
Übers Terminal?? Bin in der Hinsicht noch total grün hinter den Ohren...
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 16. Dez 2005 21:28   Titel:

3 Fehler in einem Befehl.
lspci -vv

l=Linux
Ein Leerzeichen vor dem -
und statt w 2 V
ach ja, Konsole öffnen und dort eingeben.
 
Benutzer-Profile anzeigen Private Nachricht senden

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 16. Dez 2005 21:37   Titel:

Zudem als root ausführen. Also:

- Konsole auf
- su
- Passwort, Enter
- lspci -vv

alternativ: lspci -vv > lspci.txt

Dann hast Du's gleich in einer Textdatei und kannst es hier posten.
 
Benutzer-Profile anzeigen Private Nachricht senden

homers530d



Anmeldungsdatum: 18.11.2005
Beiträge: 18

BeitragVerfasst am: 18. Dez 2005 14:00   Titel:

Thx! Smile
Jetzt konnt ichs ausführen. Hier das Ergebnis für den Network-Controller:

0000:05:00.0 Network controller: Harris Semiconductor D-Links DWL-g650 A1 (rev 01)
Subsystem: Accton Technology Corporation: Unknown device 8301
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 80 (2500ns min, 7000ns max)
Interrupt: pin A routed to IRQ 11
Region 0: Memory at 11000000 (32-bit, non-prefetchable)
Capabilities: [dc] Power Management version 1
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Könnt ihr damit was anfangen?
PS: find ich klasse, dass ihr mir helft!
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 19. Dez 2005 10:26   Titel:

Ich glaube ein paar Informationen mehr wären hilfreich. Wie sieht es mit den Ausgaben folgender Befehle aus:

Code:
lsmod
ifconfig -a
iwconfig


"lsmod" zeigt an, welche Kernel-Module geladen sind. Das könnte einen Hinweis geben, ob ein Treiber für die Karte geladen wurde / existiert.

"ifconfig" zeigt an, welche Netzwerk-Interfaces existieren (bzw. erkannt wurden)

"iwconfig" zeigt an, welche WLAN-Netzwerk-Interfaces existieren.
 
Benutzer-Profile anzeigen Private Nachricht senden

homers530d



Anmeldungsdatum: 18.11.2005
Beiträge: 18

BeitragVerfasst am: 22. Dez 2005 10:05   Titel:

HI!
Ich hab die Befehle mal ausgeführt, hier die Ergebnisse. Ihr habt scheinbar Recht, Treiber werden nicht erkannt... (Hab die Befehle mit eingesteckter WLAN-Karte ausgeführt) Ich denk der letzte Eintrag spricht Bände...
wie gehts jetzt weiter?


lsmod:
Module Size Used by
edd 9240 0
joydev 10176 0
st 38940 0
sd_mod 19840 0
sr_mod 15652 0
scsi_mod 107980 3 st,sd_mod,sr_mod
ide_cd 36484 0
cdrom 36508 2 sr_mod,ide_cd
nvram 8328 0
usbserial 28912 0
parport_pc 35264 1
lp 10916 0
parport 37704 2 parport_pc,lp
snd_seq_oss 30976 0
snd_pcm_oss 56868 0
snd_mixer_oss 18688 1 snd_pcm_oss
snd_seq_midi 8864 0
snd_seq_midi_event 7680 2 snd_seq_oss,snd_seq_midi
snd_seq 54672 6 snd_seq_oss,snd_seq_midi,snd_seq_midi_event
ipv6 244100 13
processor 16040 0
speedstep_lib 3712 0
snd_es1968 27008 4
snd_ac97_codec 60676 1 snd_es1968
snd_pcm 96776 2 snd_pcm_oss,snd_es1968
snd_page_alloc 11012 2 snd_es1968,snd_pcm
freq_table 4612 0
snd_timer 25476 2 snd_seq,snd_pcm
gameport 4736 1 snd_es1968
snd_mpu401_uart 7808 1 snd_es1968
snd_rawmidi 24992 2 snd_seq_midi,snd_mpu401_uart
snd_seq_device 8328 4 snd_seq_oss,snd_seq_midi,snd_seq,snd_rawmidi
snd 59524 22 snd_seq_oss,snd_pcm_oss,snd_mixer_oss,snd_seq_midi,snd_seq_midi_event,snd_seq,snd_es1968,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 8800 1 snd
af_packet 20360 0
hid 40640 0
intel_agp 17052 0
agpgart 28712 1 intel_agp
uhci_hcd 29584 0
prism54 45336 0
firmware_class 9344 1 prism54
ds 17284 4
yenta_socket 15744 1
pcmcia_core 61636 2 ds,yenta_socket
usbcore 96988 5 usbserial,hid,uhci_hcd
evdev 9600 0
subfs 7296 2
nls_utf8 2176 2
nls_cp437 5888 2
vfat 14080 2
fat 43328 1 vfat
dm_mod 50044 0
reiserfs 233808 1


ifconfig -a:
eth0 Protokoll:Ethernet Hardware Adresse 00:00:00:00:00:00
BROADCAST NOTRAILERS MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenl?nge:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 G?ltigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:161 errors:0 dropped:0 overruns:0 frame:0
TX packets:161 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenl?nge:0
RX bytes:10521 (10.2 Kb) TX bytes:10521 (10.2 Kb)

sit0 Protokoll:IPv6-nach-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenl?nge:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)


iwconfig:
lo no wireless extensions.

eth0 NOT READY! ESSID:off/any Nickname:"linux"
Mode:Managed Channel:6 Access Point: 00:00:00:00:00:00
Tx-Power=31 dBm Sensitivity=0/200
Retry min limit:0 RTS thr=0 B Fragment thr=0 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 23. Dez 2005 11:39   Titel:

Also schon allein die Tatsache, dass die Karte bei iwconfig angezeigt wird, ist positiv.

Versuche etwas in der Art

Code:
iwconfig eth0 essid DEINE_ESSID channel auto mode Managed ap any


(Mehr dazu in "man iwconfig".)

Und starte das Interface danach mit irgendwas in der Art:
Code:
ifconfig eth0 192.168.111.111 up


Falls es dann noch immer nicht geht, bitte eventuelle Fehlermeldungen bei diesen Befehlen, sowie widerum die Ausgaben von

Code:
iwconfig
ifconfig -a


posten.


Und denke drüber nach, ob du nicht die code-TAGs verwenden möchtest...
 
Benutzer-Profile anzeigen Private Nachricht senden

homers530d



Anmeldungsdatum: 18.11.2005
Beiträge: 18

BeitragVerfasst am: 29. Dez 2005 11:17   Titel:

Sorry, wenn ich so blöd frag, aber was ist essid und wie krieg ich das raus?
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 29. Dez 2005 12:07   Titel:

Die ESSID ist der Name deines WLANs.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy