Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Linux und Nvidia ??

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Metatron



Anmeldungsdatum: 13.12.2005
Beiträge: 4
Wohnort: WB

BeitragVerfasst am: 13. Dez 2005 19:48   Titel: Linux und Nvidia ??

Hallo Leute,
ich könnte mal ein wenig Unterstützung gebrauchen. Ich habe folgendes Problem:

Wenn ich mein Linux(9.3 oder 10.0) installiere ist alles in Ordnung und wenn der Nvidia-Treiber installiert wird mit YOU ist nach dem Hochfahren nur noch ein dunkler Bildschirm. Also er hängt sich richtig auf bevor er in die grafische Oberfläche starten kann. Ein Blick in die XORG zeigt, das der Treiber nvidia eingetragen ist. Im Textmodus ist ein starten kein Problem. Dann starten vom X-Server mit Init5 und er hängt sich wieder auf. Also Neuinstallation und YOU ohne Nvidia -Treiber klappt auch ohne Probleme. Dann den Treiber von Hand installieren im Textmodus mit SH-Befehl ---> Init5 und in der XORG steht Treiber nv.
Das heißt ,das der trieber nicht bei der installation von Nvida umgeschrieben wurde. Starte ich so den Rechner läuft er ohne Probleme aber ohne 3D und ändere ich das "nv" in "nvidia" und starte dann den Rechner neu geht das wieder nicht.

Meine Hardware:

K7N2Delta
Geforce fx 5600
1 GB Kingsten*400
Athlon XP 2400+
2* DVD Laufwerke


Unter win oder Linux ohne 3D werden keine Hardwareprobleme angezeigt.
Ich hoffe es kann mir jemand weiterhelfen.

MfG Metatron
 
Benutzer-Profile anzeigen Private Nachricht senden AIM-Name Yahoo Messenger MSN Messenger

grantlbart



Anmeldungsdatum: 19.03.2003
Beiträge: 112
Wohnort: München

BeitragVerfasst am: 14. Dez 2005 9:54   Titel:

Hallo metatron,

wie hast Du den Treiber installiert? Ich hab`s so gemacht und es hat geklappt:

Als root:

init 3
cd /usr/src/linux
make cloneconfig
make prepare

Wechseln in das Verzeichnis in dem der Treiber gespeichert ist.
Bei mir.
cd /home/wolfgang/Download
sh NVIDIA-Linux-x86-1.0.8174-pkg1.run
(8174 ggf durch deine Treiberversion ersetzen).
sax2 -m 0=nvidia
init 5

Müsste eigentlich funzen

cu grantlbart
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Metatron



Anmeldungsdatum: 13.12.2005
Beiträge: 4
Wohnort: WB

BeitragVerfasst am: 14. Dez 2005 22:04   Titel:

werde es probieren muß aber erst noch mal Suse Linux neu installieren da ich nicht weiß wie man im Textmodus eine Datei editieren kann.
Melde michdann morgen wieder.
Und erstmal vielen Dank

EDIT:Also habe deine Anweisung aufs genauste befolgt und habe das gleiche Resultat.Nach dem sax-Befehl konnte ich nicht mal mehr Init 5 eingeben. Der Bildschirm wurde schwarz und die Kotrolllampe am LCD zeigt <kein Signal>. Hatte heute aber auch nicht die Zeit um es noch mit Suse 9.3 zu testen , aber ich denke mal das es da auch so sein wird. Wenn ich eins gelernt habe in den letzten 2 Monaten dann ist es das Installieren von Linux*g* Aber es ist auch ÄRGERLICH wenn es nie klapt. sogar mit SLinux 8.2(original) habe ich es schon versucht aber auch genau das selbe. Eventuel würde es ja was bringen, wenn mir jemand sagt wo ich die Startprotokolle im Textmod finde und dann noch jemanden finde der damit was anfangen kann. Laughing Ich habe ja sogar schon überlegt ne neue Graka zu kaufen aber erstens ist das sehr teuer und zweitens ist dann immer noch die Gefahr, das es nicht funktioniert. Es könnte ja auch das MB sein oder sonnst irgendwas.

Ich hoffe du oder jemand anderes kann mir jetzt noch weiterhelfen.


MfG Metatron
 
Benutzer-Profile anzeigen Private Nachricht senden AIM-Name Yahoo Messenger MSN Messenger

grantlbart



Anmeldungsdatum: 19.03.2003
Beiträge: 112
Wohnort: München

BeitragVerfasst am: 15. Dez 2005 9:28   Titel:

Nur zur Sicherheit, bei dem Befehl

sax2 -m 0=nvidia

ist "0" eine Zahl, kein Buchstabe.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Metatron



Anmeldungsdatum: 13.12.2005
Beiträge: 4
Wohnort: WB

BeitragVerfasst am: 15. Dez 2005 17:18   Titel:

Ja natürlich habe ich eine Null eingegeben und nicht O Embarassed
Gibt es nicht noch eine andere Methode (RPM oder so) die ich nutzen kann ???


MfG Metatron
 
Benutzer-Profile anzeigen Private Nachricht senden AIM-Name Yahoo Messenger MSN Messenger

grantlbart



Anmeldungsdatum: 19.03.2003
Beiträge: 112
Wohnort: München

BeitragVerfasst am: 15. Dez 2005 20:15   Titel:

Rpm gibt`s nicht. Da die Karte unter Win läuft, ist sie ja okay.

Mir fällt momentan nur folgendes ein:

Gib mal vor dem sax Befehl

modprobe nvidia

ein, und mach weiter wie beschrieben.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Metatron



Anmeldungsdatum: 13.12.2005
Beiträge: 4
Wohnort: WB

BeitragVerfasst am: 15. Dez 2005 23:51   Titel:

Hallo grantelbart

ok mache ich. Melde mich dann noch mal. Und irgendwie an das Startprotokol rankommen um nachzusehen was da schief läuft geht auch nicht?

Ach so noch etwas war diesmal anderst als sonst.:
Der Rechner startet ja nicht den X-Server und es bleib alles schwarz aber wenn ich jetzt zu F1-F6 und F8-F12 wechsle ist dort nichts mehr schwarz sondernder LCD ist komplet violett und bei manchen Benutzerdingsda ist er nach unten gestreift mit hell bzw dunkel Streifen.
Also das ist auch neu. Vorher konte ich ja noch bei F1 im textmodus in die Xorg schauen und jetzt gehts nur noch wenn ich als bootoption runlevel 3 eingebe.
Eventuel hilf das ja weiter.
 
Benutzer-Profile anzeigen Private Nachricht senden AIM-Name Yahoo Messenger MSN Messenger

Onkel Karl
Gast





BeitragVerfasst am: 16. Dez 2005 8:14   Titel:

Hi,

mein Tipp für den Textmodus: mc - Midnight Commander - Filemanager und Editor

Logdateien sind in /var/log/

GrusKarl
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 16. Dez 2005 21:50   Titel:

Evtl. ist es ja ein Problem mit dem BIOS, ACPI, APIC oder mit Interrupts. Versuche doch mal:

- ACPI abzuschalten mit "acpi=off pci=noacpi" als Kernelparameter
- Den APIC abzuschalten per "noapic" als Kernelparameter.
- Ich nehme an, es ist eine AGP-Grafikkarte. Es gibt die Option "NvAGP" in der xorg.conf. Damit läßt sich einstellen, ob das agpgart-Modul benutzt wird für den AGP-Port, oder der nVidia-eigene Treiber. Weiteres in /usr/share/doc/NVDIA-irgendwas (sorry hab's grad nicht genauer sitze am Laptop ohne nVidia-Grafikkarte Smile ).
- Es hinzubekommen, daß die Grafikkarte einen Interrupt exklusiv bekommt. cat /proc/interrupts gibt Auskunft, durch umstecken von PCI-Karten bzw. abschalten von Geräten im BIOS läßt sich darauf Einfluß nehmen.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy