Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 21. Nov 2018 20:47

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: tftpd server einrichten
BeitragVerfasst: 21. Dez 2005 15:40 
Offline

Registriert: 18. Apr 2003 18:04
Beiträge: 191
hallo

möchte auf meiner debian sarge stable maschine ein tftpd server installieren und einrichten,
damit ich die config files von den dell switches transferieren (backupen) kann.

habe folgendes gemacht:

1.) # apt-get install tftpd

2.) in /etc/inetd.conf habe ich folgenden eintrag:

tftp dgram udp wait nobody /usr/sbin/tcpd /usr/sbin/in.tftpd /tftp

3.) # mkdir tftp

4.) schribrechte für die anderen user für tftp vergeben

5.) # /etc/init.d/xinetd restart
Stopping internet superserver: xinetd.
Starting internet superserver: xinetd.


es geht aber immer noch nicht.

weiss jemand woran es liegt ?


Nach oben
   
 Betreff des Beitrags: Re: tftpd server einrichten
BeitragVerfasst: 21. Dez 2005 16:50 
Offline
Benutzeravatar

Registriert: 22. Sep 1999 9:28
Beiträge: 180
Wohnort: Lennestadt
Zitat:
hallo

möchte auf meiner debian sarge stable maschine ein tftpd server installieren und einrichten,
damit ich die config files von den dell switches transferieren (backupen) kann.

habe folgendes gemacht:

1.) # apt-get install tftpd

2.) in /etc/inetd.conf habe ich folgenden eintrag:

tftp dgram udp wait nobody /usr/sbin/tcpd /usr/sbin/in.tftpd /tftp

3.) # mkdir tftp

4.) schribrechte für die anderen user für tftp vergeben

5.) # /etc/init.d/xinetd restart
Stopping internet superserver: xinetd.
Starting internet superserver: xinetd.


es geht aber immer noch nicht.

weiss jemand woran es liegt ?
Die /etc/inetd.conf hat nichts mit dem xinetd zu tun.
Schau mal im Verzeichnis /etc/xinet.d (so oder so ähnlich!) ob eine Datei tftpd existiert und in dieser Datei nach der Zeile "disabled".
Sorry für die ungenauen Angaben, habe zur Zeit kein Linux-System im Zugriff.

_________________
Gruß
Eddie


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 21. Dez 2005 17:10 
Offline

Registriert: 18. Apr 2003 18:04
Beiträge: 191
verstehe selber nicht aber bei meinem debian sarge stable liest xinetd die datei /etc/inetd.conf und nicht /etc/xinetd.conf

es ist so !

anyway habe dieses problem folgendermassen gelöst:

1.) # apt-get install tftpd-hpa

2.) in /etc/xinetd.d ein file tftp mit dem folgendem inhalt kreiert:
Code:
service tftp
{
	socket_type	= dgram
	protocol	= udp
	wait		= yes
	user		= root
	server		= /usr/sbin/in.tftpd
	server_args	= -c -s /tftpboot
	disable		= no
	per_source	= 11
	cps		= 100 2
}
3.) # /etc/init.d/xinetd restart
Stopping internet superserver: xinetd.
Starting internet superserver: xinetd.

und jetzt funktioniert !


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de