Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
problem?
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
2heavy4me



Anmeldungsdatum: 02.01.2006
Beiträge: 12

BeitragVerfasst am: 02. Jan 2006 13:25   Titel: problem?

Hab nen linux Servermit suse9.3 neu aufgesetzt. Die alte smbconfig (suse 8.0) und smbpasswd hab ich übernommen. bei den im netz befindlichen Workstations (win98) ist das einloggen mit passwort kein problem. Allerdings bei den Rechnern mit winxp. Hier allerdings auch nur bei jenen Usern, die ich über Yast nach dem aufsetzen neu angelegt habe!
Bin ein Laie und hab das netzwerk "freiwillig" übernehmen dürfen!
Kann mir da jemand weiterhelfen?
 
Benutzer-Profile anzeigen Private Nachricht senden

cxb



Anmeldungsdatum: 03.09.2002
Beiträge: 46

BeitragVerfasst am: 03. Jan 2006 15:59   Titel:

Hallo,

ich habe selbst kein SuSE, aber wenn du einen User mit Yast anlegst, wird dann auch ein SMB Account angelegt? Falls nein, dann must du diesen mit smbpasswd selbst anlegen.

Code:
smbpasswd -h
When run by root:
    smbpasswd [options] [username]
otherwise:
    smbpasswd [options]

options:
  -L                   local mode (must be first option)
  -h                   print this usage message
  -s                   use stdin for password prompt
  -c smb.conf file     Use the given path to the smb.conf file
  -D LEVEL             debug level
  -r MACHINE           remote machine
  -U USER              remote username
extra options when run by root or in local mode:
  -a                   add user
  -d                   disable user
  -e                   enable user
  -i                   interdomain trust account
  -m                   machine trust account
  -n                   set no password
  -w PASSWORD          ldap admin password
  -x                   delete user
  -R ORDER             name resolve order


Also im einfachsten Fall:
Code:
smbpasswd -a IamAnewUser
New SMB password: ....
Retype new SMB password:  ....


Samba neustarten und dann sollte es eigentlich funktionieren.

Bye,
Stefan
 
Benutzer-Profile anzeigen Private Nachricht senden

2heavy4me



Anmeldungsdatum: 02.01.2006
Beiträge: 12

BeitragVerfasst am: 03. Jan 2006 18:26   Titel:

Hallo!

hab im Yast User angelegt und über die Konsole smbpasswd eingegeben. Funkt trotzdem nicht. Die angelegten User können auf win98 arbeiten, winXP geräte bieten keinen zugang

lg
2h4m
 
Benutzer-Profile anzeigen Private Nachricht senden

cxb



Anmeldungsdatum: 03.09.2002
Beiträge: 46

BeitragVerfasst am: 03. Jan 2006 18:43   Titel:

Achso... sorry. Hab' vorhin nicht ganz mitbekommen dass es unter Win98 grundsätzlich geht.
Hm.. seltsam seltsam.
Wie sehen denn die Passwörter aus? Sind das Passwörter die nur aus Buchstaben und den 10 Zahlen bestehen oder enthalten die Sonderzeichen?
Kannst du von dem Win98 Client auf den WinXP Client direkt zugreifen? Und andersrum? (Vorher bitte die Verbindungen auf den Clients mit "net use /d \\[anderer Windows Client]\[Freigabe]" (ohne "") trennen oder die Windows PCs neustarten).
Falls der Verbindungsaufbau geht, was gibt der Befehl "net use" (auf den Clients) und wenn du versuchst die Clients mit dem Server zu verbinden, was gibt dann der Befehlt "smbstatus" (auf dem Linux Server) aus?

Bye,
Stefan
 
Benutzer-Profile anzeigen Private Nachricht senden

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 05. Jan 2006 10:40   Titel:

hi

Xp hat die Sicherheitsrichtlinien geändert die muss man ändern.

http://www.adsl4linux.de/howtos/lan/chapter8.php
Kapitel 8.6

ausserdem gehen Domänenanmeldungen bei der Home Edition nicht.

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

2heavy4me



Anmeldungsdatum: 02.01.2006
Beiträge: 12

BeitragVerfasst am: 05. Jan 2006 22:24   Titel:

Danke arno!
Das klingt vielversprechend,werds demnächst umstellen, hab übrigens eh winXP prof

mfg
2h4m
 
Benutzer-Profile anzeigen Private Nachricht senden

2heavy4me



Anmeldungsdatum: 02.01.2006
Beiträge: 12

BeitragVerfasst am: 05. Jan 2006 23:54   Titel:

ist ja so: nur manche benutzer (die mit dem über yast angelegt wurden -- komischerweise) funken nicht, das ist das komische an dem ganzen zeugs
zum verzweifeln

lg
2h4m
 
Benutzer-Profile anzeigen Private Nachricht senden

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 06. Jan 2006 0:00   Titel:

hm ist mir in deinen posting auch aufgefallen

wie schaut den deine smb.conf (ohne relevanten daten)
aus?

versuche mal einen user mit
smbpasswd -a <user>
anzulegen.


mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

2heavy4me



Anmeldungsdatum: 02.01.2006
Beiträge: 12

BeitragVerfasst am: 06. Jan 2006 12:17   Titel:

Hab nen User angelegt, passw vergeben, wieder gelöscht, mehrmals versucht. auf den win98 Pc´s funkt das login, WinXP nach wievor nicht die Bohne!

mfg
2h4m
 
Benutzer-Profile anzeigen Private Nachricht senden

2heavy4me



Anmeldungsdatum: 02.01.2006
Beiträge: 12

BeitragVerfasst am: 06. Jan 2006 12:20   Titel:

Hier mal meine smb.conf

[global]
workgroup = CHANGED
keep alive = 30
kernel oplocks = No
log file = /var/log/samba/%m.log
log level = 2
debug timestamp = yes
max log size = 500
time server = yes
security = user
netbios name = server
server string = Server
update encrypted = no
guest account = nobody
map to guest = Bad User
obey pam restrictions = no
passwd program = /usr/bin/passwd %u
passdb backend = smbpasswd
wins support = yes
dns proxy = no
getwd cache = yes
os level = 65
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
unix password sync = yes
passwd chat = *new*password* %n\n *new*password* %n\n *changed*
passwd chat debug = yes
printing = LPRNG
printcap name = /etc/printcap
load printers = Yes
socket options = IPTOS_LOWDELAY TCP_NODELAY

interfaces = 192.168.1.1/27 192.168.1.33/27
bind interfaces only = Yes
hosts allow = 192.168.1.

veto files = /*.eml/*.nws/riched20.dll/*.{*}/

domain master = Yes
pam password change = yes
local master = Yes
preferred master = Yes
domain logons = Yes
logon script = %G.bat
logon home = \\server\%U

; Where to store the logon scripts.
[netlogon]
comment = Network Logon Service
path = /home/netlogon
writeable = no
browseable = no
public = no
guest ok = no
read only = Yes
write list = root

; Extra share for profiles. Default is the home of the user.
[profiles]
create mode = 0600
directory mode = 0700
comment = Network Profiles Service
path = /var/lib/samba/profiles
read only = No
writeable = yes
browseable = No
create mask = 0600
directory mask = 0700

[homes]
comment = Heimatverzeichnis
path = /home/%G/%U
writeable = Yes
create mask = 0777
directory mask = 0777
locking = No
read only = No

[apps]
comment = Programme
path = /usr/apps
writeable = Yes
read only = No

[sdir]
comment = Userverzeichnis
path = /home/users
valid users = @managers
writeable = Yes
create mask = 0777
read only = No

[data]
comment = Datenverzeichnis
path = /home/data
writeable = Yes
force create mode = 0777
force directory mode = 0777
locking = No
read only = No

[printers]
comment = Alle Drucker
path = /var/tmp
create mask = 0700
printable = Yes
browseable = No
 
Benutzer-Profile anzeigen Private Nachricht senden

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 06. Jan 2006 12:46   Titel:

hi

was für fehlermeldung kommt den bei xp?
sind die xp schon vorher gelaufen bei der suse 8?
hast du für die rechner auch ein maschinen konto angelegt?

was sagen die samba logfiles (/var/log/samba/) wenn du versuchst dich mit xp einzuloggen?

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

2heavy4me



Anmeldungsdatum: 02.01.2006
Beiträge: 12

BeitragVerfasst am: 06. Jan 2006 13:32   Titel:

die Fehlermeldung am XP: domain server nicht verügbar oder username, password falsch...
bei suse 8 hat xp gefunkt...
konto müsste sein, weil sich ja einige auf xp user einloggen können, die alle schon unter suse8 angelegt wurden

mfg
2h4m
 
Benutzer-Profile anzeigen Private Nachricht senden

2heavy4me



Anmeldungsdatum: 02.01.2006
Beiträge: 12

BeitragVerfasst am: 06. Jan 2006 13:44   Titel:

Die Log files sehen so aus:
(lei ist ein user der sich nicht einloggen kann ...)
[2006/01/05 17:41:29, 2] lib/access.c:check_access(324)
Allowed connection from (192.168.1.200)
[2006/01/05 17:41:29, 2] lib/access.c:check_access(324)
Allowed connection from (192.168.1.200)
[2006/01/05 17:41:52, 2] auth/auth.c:check_ntlm_password(305)
check_ntlm_password: authentication for user [lei] -> [lei] -> [lei]
succeeded

(bla kann sich einloggen)
[2006/01/05 17:42:19, 2] auth/auth.c:check_ntlm_password(305)
check_ntlm_password: authentication for user [bla] -> [bla] -> [bla]
succeeded
[2006/01/05 17:42:21, 2] rpc_server/srv_samr_nt.c:_samr_lookup_domain(2580)
Returning domain sid for domain HSTR ->
S-1-5-21-96388720-2091749454-890545721
[2006/01/05 17:42:23, 2] auth/auth.c:check_ntlm_password(305)
check_ntlm_password: authentication for user [bla] -> [bla] -> [bla]
succeeded
[2006/01/05 17:42:23, 2] lib/access.c:check_access(324)
Allowed connection from (192.168.1.200)
[2006/01/05 17:42:23, 1] smbd/service.c:make_connection_snum(642)
wsk (192.168.1.200) connect to service bla initially as user bla
(uid=521, gid=501) (pid 14529)
[2006/01/05 17:42:23, 2] lib/access.c:check_access(324)
Allowed connection from (192.168.1.200)
[2006/01/05 17:42:23, 1] smbd/service.c:make_connection_snum(642)
wsk (192.168.1.200) connect to service netlogon initially as user bla
(uid=521, gid=501) (pid 14529)
[2006/01/05 17:42:23, 2] smbd/open.c:open_file(245)
bla opened file manager.bat read=Yes write=No (numopen=1)
[2006/01/05 17:42:23, 2] smbd/close.c:close_normal_file(272)
bla closed file manager.bat (numopen=0)
und so weiter...

Mit smbstatus nach dem login versuch kommt die folgende zeile hinzu:
14529 bla manager wsk (192.168.1.200)

Bei lei passiert nichts!

leider!

mfg
2h4m
 
Benutzer-Profile anzeigen Private Nachricht senden

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 06. Jan 2006 13:48   Titel:

mh
eigenartig.

leg den user mal in der console an

Zitat:

[root@arno ~]# useradd tester
[root@arno ~]# smbpasswd -a tester
New SMB password:
Retype new SMB password:


mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

2heavy4me



Anmeldungsdatum: 02.01.2006
Beiträge: 12

BeitragVerfasst am: 06. Jan 2006 13:56   Titel:

das hab ich eh auch schon durchprobiert, mit dem selben ergebnis
FRUST!

mfg
2h4m
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy