Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
keine Bootlog Meldungen nach dem Kernel update bei Debian Sarge

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
cc



Anmeldungsdatum: 18.04.2003
Beiträge: 191

BeitragVerfasst am: 09. Jan 2006 21:52   Titel: keine Bootlog Meldungen nach dem Kernel update bei Debian Sarge

hallo

habe bei meinem Debian Sarge Stable ein Kernel update gemacht:
Code:

# apt-get install kernel-image-2.6.8-2-686

jetzt aber wenn ich von dem neuen Kernel boote,
dann bekome ich keine Bootlog Meldungen in /var/log/boot,
obwohl ich bootlogd in /etc/default/bootlogd
Code:

BOOTLOGD_ENABLE=Yes
aktiviert habe

es scheint ein BUG zu sein:

# sudo sh -x /etc/init.d/bootlogd start
+ PATH=/sbin:/bin:/usr/sbin:/usr/bin
+ DAEMON=/sbin/bootlogd
+ NAME=bootlogd
+ DESC=Bootlog daemon
+ test -f /sbin/bootlogd
+ '[' -r /etc/default/bootlogd ']'
+ . /etc/default/bootlogd
++ BOOTLOGD_ENABLE=Yes
+ STOPPER=
+ ACTION=start
+ echo -n 'Starting Bootlog daemon: '
Starting Bootlog daemon: + '[' -d /proc/1/. ']'
+ umask 027
+ start-stop-daemon --start --quiet --exec /sbin/bootlogd -- -r
bootlogd: cannot find console device 136:0 in /dev

+ echo bootlogd.
bootlogd.
+ exit 0

gruss
cc
 
Benutzer-Profile anzeigen Private Nachricht senden

killerhippy



Anmeldungsdatum: 19.05.2000
Beiträge: 529

BeitragVerfasst am: 11. Jan 2006 21:07   Titel:

Bei dem upgrade Vorgang ist vermutlich udev installiert worden, right?

Da musst du dann udev beibringen, /dev/console mit anzulegen, schätze ich mal.
_________________
Es gibt keine dumme Fragen!

Killerhippy
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

cc



Anmeldungsdatum: 18.04.2003
Beiträge: 191

BeitragVerfasst am: 12. Jan 2006 0:15   Titel:

ja du hast vermutlich recht !
Code:

linux:~# dpkg -l | grep udev
ii  udev           0.056-3        /dev/ management daemon

linux:~# whereis udev
udev: /sbin/udev /etc/udev /usr/share/man/man8/udev.8.gz

linux:~# cat /boot/config-2.6.8-2-686 | grep udev

linux:~# ps -ef | grep udev
root       337     1  0 13:40 ?        00:00:00 udevd


aber wie bringe ich dem udev bei /dev/console mit anzulegen ?
Code:


linux:~# cat /etc/udev/udev.conf
# udev.conf
# The main config file for udev
#
# This file can be used to override some of udev's default values
# for where it looks for files, and where it places device nodes.


# udev_root - where in the filesystem to place the device nodes
udev_root="/dev"

# udev_db - The name and location of the udev database.
udev_db="/dev/.udevdb"

# udev_rules - The name and location of the udev rules file
udev_rules="/etc/udev/rules.d"

# udev_log - set to "yes" if you want logging, else "no"
udev_log="yes"

# maximum size of the /dev tmpfs
tmpfs_size="10M"
 
Benutzer-Profile anzeigen Private Nachricht senden

killerhippy



Anmeldungsdatum: 19.05.2000
Beiträge: 529

BeitragVerfasst am: 13. Jan 2006 0:58   Titel:

Code:
# grep -rli console /etc/udev/rules.d

_________________
Es gibt keine dumme Fragen!

Killerhippy
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

cc



Anmeldungsdatum: 18.04.2003
Beiträge: 191

BeitragVerfasst am: 13. Jan 2006 1:23   Titel:

Code:

# grep -rli console /etc/udev/rules.d
/etc/udev/rules.d/020_permissions.rules
 
Benutzer-Profile anzeigen Private Nachricht senden

killerhippy



Anmeldungsdatum: 19.05.2000
Beiträge: 529

BeitragVerfasst am: 13. Jan 2006 17:20   Titel:

Na fein, dann schau dir doch mal die Datei mit less oder deinem Lieblingseditor an, ob da das Erzeugen von /dev/console eingerichtet ist.
_________________
Es gibt keine dumme Fragen!

Killerhippy
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

cc



Anmeldungsdatum: 18.04.2003
Beiträge: 191

BeitragVerfasst am: 14. Jan 2006 0:15   Titel:

danke, aber ich bin mir nicht sicher was ich da anpassen muss:
Code:

# cat udev.rules
# There are a number of modifiers that are allowed to be used in some
# of the different fields. They provide the following subsitutions:
#
# %n the "kernel number" of the device.
#    For example, 'sda3' has a "kernel number" of '3'
# %e the smallest number for that name which does not matches an existing node
# %k the kernel name for the device.
# %M the kernel major number for the device
# %m the kernel minor number for the device
# %b the bus id for the device
# %c the string returned by the PROGRAM
# %s{filename} the content of a sysfs attribute.
# %% the '%' char itself.
#

# workaround for devices which do not report media changes
BUS="ide", KERNEL="hd[a-z]", SYSFS{removable}="1", \
  PROGRAM="/etc/udev/scripts/ide-model.sh %k", RESULT="IOMEGA ZIP *", \
  OPTIONS="all_partitions", NAME="%k"

# SCSI devices
BUS="scsi", KERNEL="sr[0-9]*",  NAME="scd%n", SYMLINK="sr%n"

# USB devices
BUS="usb", KERNEL="hiddev*",    NAME="usb/%k"
BUS="usb", KERNEL="auer[0-9]*", NAME="usb/%k"
BUS="usb", KERNEL="legousbtower*", NAME="usb/%k"
BUS="usb", KERNEL="dabusb*",    NAME="usb/%k"
BUS="usb", KERNEL="cpad[0-9]*", NAME="usb/%k"
BUS="usb", KERNEL="lp[0-9]*",   NAME="usb/%k"
BUS="usb", KERNEL="ttyUSB*", SYSFS{product}="Palm Handheld*", SYMLINK="pilot"

# serial devices
KERNEL="capi",          NAME="capi20", SYMLINK="isdn/capi20"
KERNEL="capi[0-9]*",    NAME="capi/%n"

# video devices
KERNEL="dvb*",          PROGRAM="/etc/udev/scripts/dvb.sh %k", NAME="%c"
KERNEL="card[0-9]*",    NAME="dri/%k"

# misc devices
KERNEL="hw_random",     NAME="hwrng"

KERNEL="cdemu[0-9]*",   NAME="cdemu/%n"
KERNEL="pktcdvd[0-9]*", NAME="pktcdvd/%n"
KERNEL="pktcdvd",       NAME="pktcdvd/control"

KERNEL="cpu[0-9]*",     NAME="cpu/%n/cpuid"
KERNEL="msr[0-9]*",     NAME="cpu/%n/msr"
KERNEL="microcode",     NAME="cpu/microcode"

KERNEL="umad*",         NAME="infiniband/%k"
KERNEL="issm*",         NAME="infiniband/%k"

KERNEL="tap[0-9]*",     NAME="net/%k"
KERNEL="tun",           NAME="net/%k"

# ALSA devices
KERNEL="controlC[0-9]*", NAME="snd/%k"
KERNEL="hwC[D0-9]*",    NAME="snd/%k"
KERNEL="pcmC[D0-9cp]*", NAME="snd/%k"
KERNEL="midiC[D0-9]*",  NAME="snd/%k"
KERNEL="timer",         NAME="snd/%k"
KERNEL="seq",           NAME="snd/%k"

# input devices
KERNEL="mice",          NAME="input/%k"
KERNEL="mouse[0-9]*",   NAME="input/%k"
KERNEL="event[0-9]*",   NAME="input/%k"
KERNEL="js[0-9]*",      NAME="input/%k"
KERNEL="ts[0-9]*",      NAME="input/%k"
KERNEL="uinput",        NAME="input/%k"

# Zaptel
KERNEL="zapctl",        NAME="zap/ctl"
KERNEL="zaptimer",      NAME="zap/timer"
KERNEL="zapchannel",    NAME="zap/channel"
KERNEL="zappseudo",     NAME="zap/pseudo"
KERNEL="zap[0-9]*",     NAME="zap/%n"

# AOE character devices
SUBSYSTEM="aoe", KERNEL="discover",     NAME="etherd/%k"
SUBSYSTEM="aoe", KERNEL="err",          NAME="etherd/%k"
SUBSYSTEM="aoe", KERNEL="interfaces",   NAME="etherd/%k"

# device mapper creates its own device nodes, so ignore these
KERNEL="dm-[0-9]*",     OPTIONS="ignore_device"
KERNEL="device-mapper", NAME="mapper/control"


Code:

# cat 020_permissions.rules
# default permissions for block devices
SUBSYSTEM="block",                      GROUP="disk"
SUBSYSTEM="block", SYSFS{removable}="1", GROUP="floppy"

# IDE devices
BUS="ide", KERNEL="hd[a-z]", SYSFS{removable}="1", \
  PROGRAM="/bin/cat /proc/ide/%k/media", RESULT="cdrom*", GROUP="cdrom"
BUS="ide", KERNEL="ht[0-9]*",   GROUP="tape"
BUS="ide", KERNEL="nht[0-9]*",  GROUP="tape"

# SCSI devices
BUS="scsi", SYSFS{type}="1",    GROUP="tape"
BUS="scsi", SYSFS{type}="5",    GROUP="cdrom"
BUS="scsi", SYSFS{type}="6",    GROUP="scanner"

# USB devices
BUS="usb", KERNEL="legousbtower*", MODE="0666"
BUS="usb", KERNEL="lp[0-9]*",   GROUP="lp"

# serial devices
SUBSYSTEM="tty",        GROUP="dialout"
SUBSYSTEM="capi",       GROUP="dialout"
SUBSYSTEM="slamr",      GROUP="dialout"

# vc devices (all members of the tty subsystem)
KERNEL="ptmx",          MODE="0666", GROUP="root"
KERNEL="console",       MODE="0600", GROUP="root"
KERNEL="tty",           MODE="0666", GROUP="root"
KERNEL="tty[0-9]*",     GROUP="root"

# video devices
SUBSYSTEM="video4linux", GROUP="video"
SUBSYSTEM="dvb",        GROUP="video"
SUBSYSTEM="graphics",   GROUP="video"
SUBSYSTEM="nvidia",     GROUP="video"
SUBSYSTEM="drm",        GROUP="video"

# misc devices
KERNEL="random",        MODE="0666"
KERNEL="urandom",       MODE="0444"
KERNEL="mem",           MODE="0640", GROUP="kmem"
KERNEL="kmem",          MODE="0640", GROUP="kmem"
KERNEL="port",          MODE="0640", GROUP="kmem"
KERNEL="full",          MODE="0666"
KERNEL="null",          MODE="0666"
KERNEL="zero",          MODE="0666"
KERNEL="inotify",       MODE="0666"
KERNEL="sgi_fetchop",   MODE="0666"
KERNEL="sonypi",        MODE="0666"
KERNEL="agpgart",       GROUP="video"
KERNEL="nvram",         GROUP="nvram"
KERNEL="rtc",           MODE="0660", GROUP="audio"

KERNEL="cdemu[0-9]*",   GROUP="cdrom"
KERNEL="pktcdvd[0-9]*", GROUP="cdrom"
KERNEL="pktcdvd",       MODE="0644"

# printers and parallel devices
SUBSYSTEM="printer",    GROUP="lp"
SUBSYSTEM="ppdev",      GROUP="lp"
KERNEL="pt[0-9]*",      GROUP="tape"
KERNEL="pht[0-9]*",     GROUP="tape"

# sound devices
SUBSYSTEM="sound",      GROUP="audio"

# input devices
KERNEL="event[0-9]*",   PROGRAM="/etc/udev/scripts/inputdev.sh %k", \
                        RESULT="inputdev", MODE="0664", GROUP="video"
KERNEL="js[0-9]*",      MODE="0664"

# AOE character devices
SUBSYSTEM="aoe",                MODE="0220", GROUP="disk"
SUBSYSTEM="aoe", KERNEL="err",  MODE="0440"


Zuletzt bearbeitet von cc am 14. Jan 2006 1:30, insgesamt 2-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

killerhippy



Anmeldungsdatum: 19.05.2000
Beiträge: 529

BeitragVerfasst am: 14. Jan 2006 0:34   Titel:

Hast du im ersten code-block den Inhalt zweimal gepostet? Oder ist das wirklich der Inhalt von der Datei? Dann solltest du vielleicht dafür sorgen, dass die Eintraege nicht doppelt vorkommen. Vielleicht war's das ja schon...

Wenn nicht, du hast ja
Zitat:
# vc devices (all members of the tty subsystem)
KERNEL="ptmx", MODE="0666", GROUP="root"
KERNEL="console", MODE="0600", GROUP="root"
KERNEL="tty", MODE="0666", GROUP="root"
KERNEL="tty[0-9]*", GROUP="root"

Also sollte /dev/console angelegt werden. Wenn nicht, dann solltest du in der udev.conf das logging einschalten. Sollte keine udev.log in /var/log angelegt werden, dann findest du bestimmt die Einträge in /var/log/syslog. Neu booten und gucken, was du finden kannst.
_________________
Es gibt keine dumme Fragen!

Killerhippy
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

cc



Anmeldungsdatum: 18.04.2003
Beiträge: 191

BeitragVerfasst am: 14. Jan 2006 1:55   Titel:

sorry habe mein posting korriegiert

in /etc/udev/udev.conf is logging eingeschaltet aber ich finde keine udev logs

in syslog finde ich folgende einträge:
Code:


Jan 14 00:20:16 ns1 udev[3138]: creating device node '/dev/lp0'

Jan 14 00:20:26 ns1 udev[3365]: removing device node '/dev/vcs1'
Jan 14 00:20:26 ns1 udev[3366]: removing device node '/dev/vcsa1'
Jan 14 00:20:26 ns1 udev[3381]: creating device node '/dev/vcs1'
Jan 14 00:20:26 ns1 udev[3390]: creating device node '/dev/vcsa1'
Jan 14 00:20:26 ns1 udev[3400]: creating device node '/dev/vcs2'
Jan 14 00:20:26 ns1 udev[3408]: creating device node '/dev/vcs3'
Jan 14 00:20:26 ns1 udev[3416]: creating device node '/dev/vcsa2'
Jan 14 00:20:26 ns1 udev[3425]: creating device node '/dev/vcs4'
Jan 14 00:20:26 ns1 udev[3433]: creating device node '/dev/vcsa3'
Jan 14 00:20:26 ns1 udev[3443]: creating device node '/dev/vcs5'
Jan 14 00:20:26 ns1 udev[3451]: creating device node '/dev/vcsa4'
Jan 14 00:20:26 ns1 udev[3461]: creating device node '/dev/vcs6'
Jan 14 00:20:26 ns1 udev[3469]: creating device node '/dev/vcsa5'
Jan 14 00:20:26 ns1 udev[3491]: removing device node '/dev/vcs1'
Jan 14 00:20:26 ns1 udev[3492]: creating device node '/dev/vcsa6'
Jan 14 00:20:26 ns1 udev[3493]: removing device node '/dev/vcsa1'
Jan 14 00:20:26 ns1 udev[3500]: creating device node '/dev/vcs1'
Jan 14 00:20:26 ns1 udev[3507]: creating device node '/dev/vcsa1'
 
Benutzer-Profile anzeigen Private Nachricht senden

cc



Anmeldungsdatum: 18.04.2003
Beiträge: 191

BeitragVerfasst am: 14. Jan 2006 23:45   Titel:

während des Bootvorgangs bekomme auf dem screen folgende Fehlermeldung:
Code:

bootlogd: ioctl (/dev/ttyzf, TIOCCONS): Bad file descriptor
 
Benutzer-Profile anzeigen Private Nachricht senden

killerhippy



Anmeldungsdatum: 19.05.2000
Beiträge: 529

BeitragVerfasst am: 18. Jan 2006 18:31   Titel:

Hilft das?

http://www.mail-archive.com/debian-laptop@lists.debian.org/msg46174.html
_________________
Es gibt keine dumme Fragen!

Killerhippy
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

cc



Anmeldungsdatum: 18.04.2003
Beiträge: 191

BeitragVerfasst am: 06. Feb 2006 17:31   Titel:

nein, ich möchte nicht zu der testing version upgraden, weil ein wichtiger server ist.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy