Rechtevergabe von Verzeichnis

Antworten
Nachricht
Autor
engelu
Beiträge: 2
Registriert: 26. Jan 2006 14:01

Rechtevergabe von Verzeichnis

#1 Beitrag von engelu » 26. Jan 2006 14:16

Habe unter Suse 10 eine Fat Partition zur Freigabe unter Samba angelegt. Die Dateirechte sind nur für root vergeben. Andere lassen sich auch mit Chmod Chgrp usw. unter root nicht einstellen. Wer kann mir helfen.

Benutzeravatar
killerhippy
Beiträge: 529
Registriert: 19. Mai 2000 19:36
Kontaktdaten:

#2 Beitrag von killerhippy » 27. Jan 2006 1:59

Nur root darf mounten ausser in /etc/fstab ist das anders konfiguriert. So kommt es, dass auch sudoers beim mounten im Mountpointverzeichnis Rootrechte erzeugen selbst wenn dies vorher einem user gehört hat und auch wenn root mit chown die Ordnerrechte des Mountpoints nach dem Mounten ändern möchte, darf er das nicht. Versuche mal Folgendes:

In einem Terminalfenster, z.B. xterm rufe die manpage von mount auf

Code: Alles auswählen

man mount
und schau dir die Optionsmöglichkeiten bezüglich user und group an und die "Mount options for" für das betreffende Dateisystem. Ausserdem brauchst du dann bestimmt noch die manpage von fstab.

Darin stehen die notwendigen Informationen um einen mountpoint, der von /etc/fstab bereitgehalten wird, zu konfigurieren, der von einem user gemountet werden darf.

Reicht dir diese Hilfe? Wenn nicht, frag noch mal.
Es gibt keine dumme Fragen!

Killerhippy

rbtux
Beiträge: 69
Registriert: 23. Jun 2004 11:59

#3 Beitrag von rbtux » 27. Jan 2006 11:24

hallo engelu

ich glaube, dass diese Berechtigungen in den Inodes im Filesystem (also ext2/3, reiserfs etc.) gespeichert werden. FAT arbeitet jedoch nicht mit Inodes, evtl können daher auch keine berechtigungen gesetzt werden.

schau doch noch das hier an:

viewtopic.php?t=1030113
Computer führen dazu, dass man die alten Fehler jetzt 100 mal schneller macht ;)

engelu
Beiträge: 2
Registriert: 26. Jan 2006 14:01

#4 Beitrag von engelu » 27. Jan 2006 16:34

Vielen Dank für die schnelle Hilfe! Habe das Problem mit der fstab und umask gelöst. Funzt jetzt einwandfrei. :lol:

Antworten