x-server: Dual-Monitur funktioniert nur nach restart

Antworten
Nachricht
Autor
marquies
Beiträge: 4
Registriert: 29. Sep 2004 8:45

x-server: Dual-Monitur funktioniert nur nach restart

#1 Beitrag von marquies » 27. Jan 2006 15:16

Hallo zusammen,

ich habe hier einen Desktop-PC (Debian sarge, KDE (mit GDM), GF FX 5200 (aktueller Treiber) mit 2 Monitoren (Benq, 1x VGA, 1x DVI). Ich habe X entschprechend konfiguriert. Wenn ich den X-Server per startx starte, läuft alles wunderbar. Auch wenn ich den GDM manuell starte läuft alles. Nur wenn ich den PC boote, kommt der X mit nur einem Schirm. Wenn ich dann den GDM neu starte kommt er mit beiden. Ich habe überlegt, ob er beim booten ne andere Config nimmt, aber das tut er nicht. Ich hab echt keine Ahnung mehr. Hier ein Auszug aus der Config:

Code: Alles auswählen

Section "Screen"
    Identifier     "Right Screen"
    Device         "NVIDIA Corporation NV34 [GeForce FX 5200]"
    Monitor        "Standardbildschirm"
    DefaultDepth    24
    Option         "TwinView" "true"
    Option         "SecondMonitorHorizSync" "28.0-75.0"
    Option         "SecondMonitorVertRefresh" "43-75.0"
    Option         "MetaModes" "1280x1024, 1280x1024; 1280x1024, 1280x1024;"
    Option         "TwinViewOrientation" "LeftOf"
    Option         "Xinerama" "on"
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Right Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection
Ich hab schon überall gesucht aber nix zu meinem Problem gefunden. Ich hoffe Ihr habt was parat. Vielen Dank schonmal.

Gruß,
marquies

Alex.MH

#2 Beitrag von Alex.MH » 27. Jan 2006 17:08

Schau mal in /var/log/Xorg.0.log

Da muesste stehen, was schief gelaufen ist.

Gruss,
Alex

Antworten