Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Einstellen Keyboard Layout für den Textmodus

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
gorgonz
Gast





BeitragVerfasst am: 28. Jan 2006 18:31   Titel: Einstellen Keyboard Layout für den Textmodus

Ursache des Ganzen:

opensuse 10 lief nur bis zum textmodus hoch, weil ein usb drive in fstab stehen geblieben ist und jetzt nicht mehr dran war. Ich soll das root PW eingeben, aber wegen des (unpassenden) KBD Layouts schaff ich es nicht mein PW mit seinen Sonderzeichen einzugeben.

Meine Fragen:

- wahrscheinlich ist das Default Layout vom Textmodus auf 'en' oder 'us' eingestellt. Wie und wo kann ich es auf deutsches Layout umstellen?

- Unter Windows konnte ich immer die Scancodes direkt eingeben, wenn ich mit einer falschen Tatstaut arbeitete, z.B. ALT-GR 65 für 'A'. Gibt es unter Linux eine entsprechende Eingabemöglichkeit?

Mein Dank an Euch vorweg
 

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 29. Jan 2006 13:44   Titel:

Vor Eingabe des Loginnamens kannst du probieren wie die Tasten belegt sind und das Passwort danach eingeben. Eine deutsche Tastenbelegung solltest du mit:
/usr/X11R6/bin/xmodmap /usr/share/xmodmap/xmodmap.de
für X und mit:
/usr/bin/loadkeys de-latin1-nodeadkeys.map
für die Konsole erhalten.

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 29. Jan 2006 15:55   Titel:

hi

vielleicht helfen dir die befehle
setkeycodes
oder
setkey

weiter.

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Gast
Gast





BeitragVerfasst am: 29. Jan 2006 22:45   Titel:

Zitat:
... opensuse 10 lief nur bis zum textmodus hoch, ...

Da gibt es mehrere (Textmodi).
Wenn er nun im Runlevel S landet, kann er nicht probieren (mit dem Login-Namen), weil es wird das root-PW erfragt. Selbst mit Kenntnis des en-Layouts hat er wohl schlechte Karten um an öäüß zu kommen.

Vielleicht hilft beim booten ein init=/bin/bash, die zwei Sonderzeichen bekommt man noch zusammen (falls der Bootmanager kein de-Layout kennt), da kommt dann die Bekanntschaft mit vi, um die fstab zu beackern. Warum ein mc nicht in der Grundpacket-Auswahl enthalten ist, weiß wohl keiner.
 

gorgonz
Gast





BeitragVerfasst am: 30. Jan 2006 0:01   Titel: x Parameter helfen hier nicht

Gast hat wahrscheinlich recht mit dem RunLevel S. Zumindest ist es so, dass ich kein Login angeben kann, sondern nur noch das passwort .

Aber auch der Hinweis auf setkeycodes hatte einen guten Nebeneffekt. Über man hab ich erfahren, dass man sich beliebige scan codes zu Tasten ausgeben lassen kann mit 'showkey -a'. Die könnten dann dem setkeycodes angeboten werden, ... wenn ich mal drin bin Wink

Den Tipp mit init=/bin/bash probier ich beim nächsten boot mal aus. Ist das als boot parameter einzugeben oder wo erfolgt das?

Mein Dank für den Einsatz Eurer Zeit Smile
 

Gast
Gast





BeitragVerfasst am: 31. Jan 2006 3:46   Titel:

init=irgend_ein_Programm als Bootparameter
Linux startet, nachdem es sich (also der Kernel) entfaltet hat, das Programm init (/sbin/init) welches dann so etwas wie die Wurzel aller anderen Programme ist und vor einem Konsolen-Login (b.z.w. X.-Window-Start ...) allerlei notwendiges/nützliches (entsprechend des vorgesehenen Runlevels) startet. So das wichtigste ist eben auch Dateisysteme einhängen (ggf. vorher prüfen). Bei schwerwiegenden Fehlern wird dann nur Runlevel S angesteuert, root soll erstmal den Kram in Ordnung bringen, ehe es evtl noch schlimmer wird. In deinem Fall hörte es sich nach »eigentlich Nebensache« an, ob das externe Laufwerk vorhanden ist (oder nicht), warum dann aber der Abbruch? Du wirst dem externen Teil wohl doch einen lebenswichtigen Mountpoint zugedacht haben (oder fsck wird etwas irritiert).

Probier also erstmal, ob Du eine shell bekommst. Sollte es irgendwie mit dem Bootparameter nicht funktionieren, dann von Install-CD das Rettungssystem starten. Dann musst Du sehr wahrscheinlich aber deine Partition manuell mounten, aber auch mit Shell per Bootparameter ist die Root-Partition vielleicht nur ro gemountet.
Also erstmal bis dahin, und lass doch mal vielleicht die Fehlermeldung bezüglich deiner fehlenden Platte verlauten (den grafischen Bootbildschirm evtl. wegdrücken <ESC>?).
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy