Wie übergibt man b. booten die Bildfrequenz als Parameter?

Antworten
Nachricht
Autor
knutux
Beiträge: 3
Registriert: 05. Feb 2006 1:24

Wie übergibt man b. booten die Bildfrequenz als Parameter?

#1 Beitrag von knutux » 11. Feb 2006 19:10

Hallo,

ich möchte nicht nur die Auflösung und die Farbtiefe beim booten (vga=0x31b) einstellen, sondern auch die Bildfrequenz.
Konnte dazu leider nichts finden ( ist das eventuell gar nicht vorgesehen? ).
Ich nutze SUSE 10.0 mit Grub.

Hintergrund der Geschichte ist, dass mein Syncmaster 713BM beim booten und in der Textkonsole leider nur im vga-Modus ein Bild machen will (und das ist links auch noch abgeschnitten, so dass die ersten Buchstaben einer Zeile nicht sichtbar sind) .
Wenn ich bei grub vga=0x31b eintrage meldet der Monitor, dass er 1280x1024@60Hz braucht und zeigt sonst schwarz. Auch die Konfiguration von Grub über yast führt zum gleichen Ergebnis.
Der xserver arbeitet korrekt , also handelt es sich wohl nicht um ein grundsätzliches Hardware- bzw Grafikproblem.

Vielen Dank, Knutux

Benutzeravatar
Janka
Beiträge: 3585
Registriert: 11. Feb 2006 19:10

Re: Wie übergibt man b. booten die Bildfrequenz als Parameter?

#2 Beitrag von Janka » 11. Feb 2006 19:25

knutux hat geschrieben:Hallo,
ich möchte nicht nur die Auflösung und die Farbtiefe beim booten (vga=0x31b) einstellen, sondern auch die Bildfrequenz.
Konnte dazu leider nichts finden ( ist das eventuell gar nicht vorgesehen? ).
Das geht nur mit dem Framebuffer-Mode, da die normalen Modi ja vom Video-Bios der Grafikarte festgelegt werden. Ob du was verstellen kannst, hängt davon ab, ob es einen speziellen Framebuffertreiber für deine Grafikkarte gibt. Schau dir mal die Doku unter

Code: Alles auswählen

/usr/src/linux/Documentation/fb/
an.

Janka[/code][/quote]

knutux
Beiträge: 3
Registriert: 05. Feb 2006 1:24

toll,

#3 Beitrag von knutux » 11. Feb 2006 22:24

vielen Dank für den Hinweis.
Das Verzeichnis /usr/src/linux/ gibt es zwar auf meinem System (suse 10.0) nicht, aber kann jetzt nach Hinweisen zum framebuffer suchen.

Benutzeravatar
Janka
Beiträge: 3585
Registriert: 11. Feb 2006 19:10

Re: toll,

#4 Beitrag von Janka » 12. Feb 2006 19:53

knutux hat geschrieben:vielen Dank für den Hinweis.
Das Verzeichnis /usr/src/linux/ gibt es zwar auf meinem System (suse 10.0) nicht,...
Dafür musst du ein Kernelquellenpaket installieren.

Antworten