Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 15. Dez 2018 12:06

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 6 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 19. Feb 2006 10:40 
Offline

Registriert: 20. Okt 2004 14:56
Beiträge: 6
Wohnort: Bornich
Hallo,

ich habe auf einem Athlon 2400+ mit 1,5 GB Ram und Hercules Propehte 9000 128 MB Grafikkarte, es läuft alles super nur die 3d Grafik spinnt.

Ich habe es schon mit Suse 1.0-OSS und Kanotix versucht imm das selbe.

Wenn Ich ein Spiel starte z.b freedoom oder Tuxkart oder PPracer bleibt einfach nach ca 10-20 sekunden alles stehen nix bewegt sich mehr gar nix es hilft nur noch ein druck auf den RESET knopf !!!

Ich habe schon den Grafikkarten Installer von ATI (von der ATI Homepage) probiert -> Ergibnis der Rechner bleit nicht mehr hängen aber alles ruckelt und man kann die 3D Programme nicht benutzen.

Dann habe ich das unter Kanotix probiert:


Code:
su 
init 3 
update-scripts-kanotix.sh 
install-radeon-debian.sh 


aber dann friert der Rechner wieder ein !
es nützt auch nichts mittels Strg+Alt+Backspace den Xserver neu zu starten, der Rechner reagiert überhaupt nicht mehr !!!

was kann man den sonst noch tun ?
oder liegt das an der Grafikkarte und ich kaufe mir ne neue Linuxtaugliche ?

Ich bin wirklich für jede art von Hilfe Dankbar

Gruß
Robert


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 28. Feb 2006 14:53 
Offline
Benutzeravatar

Registriert: 28. Feb 2006 14:36
Beiträge: 13
Wohnort: Weeze
Hallo!

Was steht denn in den Logs?
Also vom X und den messages?

Wenn du den ATI Treiber genommen hast und es Ruckelt was sagt denn glxinfo? Läuft dann überhaupt dri?

Wie schaut deine x-config aus?

So long


Sebastian van de Meer

_________________
http://www.kernel-error.de


Nach oben
   
 Betreff des Beitrags: Wo finde ich diese Logs ?
BeitragVerfasst: 01. Mär 2006 4:14 
Offline

Registriert: 20. Okt 2004 14:56
Beiträge: 6
Wohnort: Bornich
Hallo,

ich bin leider ein absoluter Linux Newbie, und hab keine Ahnung wo ich diese Informationen herbekomme.
Wo finde ich diese Logs ?
was ist glxinfo und dri ?
wo ist diese x-config ?

ich würde gerne diese Infos geben hab aber kein Plan wo ich sie finde !!

Gruß
Robert


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 01. Mär 2006 11:20 
Offline
Benutzeravatar

Registriert: 28. Feb 2006 14:36
Beiträge: 13
Wohnort: Weeze
Hallo!

Die messages Datei findest du unter: /var/log
Friert dein Rechner ein, startest du ihn einfach neu und schaust in die Datei herein. Zwar stehen hier nun ein paar neue Informationen(vom Booten was du ja gerade gemacht hast) aber davor stehen die Informationen bis zum einfrieren.

Ich habe jetzt keine Ahnung welchen x-server dein System genau benutzt. x.org oder xfree86.

Die Konfigurationsdatei findest jeweils unter /etc/X11/ sie nennt sich dann xorg.conf oder xfree..... ist aber durch nachschauen zu finden.

Die Logdateien zu den x-servern findest auch jeweils in /var/log. Jeweils unter dem namen des x-servers.log! Hat dein x-server nach dem booten wieder gestartet hängt ein.old an der interessanten log Datei.

DRI ist das direkt rendering. Wenn du so willst deine 3D Unterstützung. Läuft kein dri läuft auch kein 3D.

glxinfo ist ein Programm welches dir Informationen ausgibt. Unter anderem auch ob dri läuft oder nicht.
Wenn du im gestarteten x-server in einer Konsole folgenden Befehl eingibst:

glxinfo |grep direct

Sollte etwas in dieser Art ausgegeben werden:
direct rendering: Yes
OpenGL renderer string: Mesa GLX Indirect

Steht nun bei direct rendering ein No dann ist nix mit 3D.

Bis dahin..


Sebastian van de Meer

_________________
http://www.kernel-error.de


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 03. Mär 2006 9:32 
Offline

Registriert: 20. Okt 2004 14:56
Beiträge: 6
Wohnort: Bornich
Hallo,

nachdem ich bei Suse: glxinfo |grep direct eingegeben hatte kam:
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect

das hat mich so geärdert das ich Suse runtergeschmissen und kanotix drauf gemacht habe.

Da war direkt direct rendering: Yes -> soweit so gut nur wurde mir jetzt nichts mehr angezeigt vom OpenGL renderer !

Da hab ich mir gedacht mach mal ein Kernel Update und ein Dist Upgrade, gesagt getan:

Läuft alles perfekt nur eben ohne OpenGLrenderer.

Ich habe dann versucht mittels:
Code:
su
init 3
update-scripts-kanotix.sh
install-radeon-debian.sh
einen Neuen Grafikkarten treiber zu installieren, das hat jedoch zu einem neuen Problem geführt, mein Monitor (TFT) meldet auf einmal nach dem Update Falsches Eingangssignal !!!
und ich kann außer dieser Monitor anzeige nichts mehr sehen !!
Mittels <strg><alt><f2> komme ich auf eine konsole aber das hilft mir auch nicht wirklich weiter.
Als Xserver benutze ich Xorg !!
In der konsole habe ich schon versucht mittels xorgcfg die Karte neu zu konfiguieren aber dann kommt nur ne Fehlermeldung in der sinngemäs steht: "Geht nicht im Framebuffer mode"

Ich habe jetzt Kanotix wieder neu aufgesetzt und habe alles bis auf den neuen Grafiktreieber installiert, es läuft soweit ganz gut nur wie kann ich das mit dem Grafiktreiber noch hinbekommen ?

Viele Leute sagen Sie hätten Probleme mit Linux auf dem Notebokk, aber da läuft bei mir alles bestens, da musste ich nix machen. Bei mir macht der Desktop PC Probleme !!

Wäre echt fein wenn jemand auch für ein letztes Problem ein Rat wüsste.
Gruß
robert


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 03. Mär 2006 10:59 
Offline
Benutzeravatar

Registriert: 28. Feb 2006 14:36
Beiträge: 13
Wohnort: Weeze
Neuinstallation weil klappt nicht.. Ach klappt immer noch nicht... Tz neue Distri.. hm Neuinstallation... klappt nicht o.O

Also meiner Erfahrung nach gibt es recht wenig Gründe Linux einer Neuinstallation zu unterziehen :-P Ganz sicher sind Probleme mit dem VGA-Treiber kein Grund! Wenn du das so betreibst wirst du den Problemen nie auf den Grund kommen und lernen kannst auch nix dabei :( Lesen, denken, probieren bis es klappt. Um so länger du das betreibst um so schneller wirst du auch mit Problemen dieser Art fertig!

Wenn du auf eine Konsole kommst, ist doch alles geritzt. Den X-Server konfigurierst du dann einfach mittels mc / vi / nano oder ähnlich in dessen Konfigurationsdatei. Anleitungen gibt es hier wie immer tausende im Internet. Ganz einfach über google zu finden.

Hast du unter Suse mal einer Anleitung zur Installation eines ATI-Treibers gefolgt?

Kanotix und bla... Diese ganzen "Live Systeme" sind keine saubere Sache für die Installation und wirkliche Arbeit auf einem System. So ist zumindest meine Erfahrung.

Die Versionen von Suse sind im allgemeinen sehr gut. Leider kann man bei den vielen "Helferlein" und der ganzen Automatik nicht immer genau sehen und verfolgen was das System nun im einzellen tut.

Wenn du schon beim Distributionsfummel bist könntest du dir mal Mandriva ex. Mandrake anschauen. Hier habe ich recht gute Erfahrungen mit. Recht simpel für Anfänger aber nicht zu automatisiert das man nicht auch mal eben irgendwo herumfummeln könnte. Die letzte Version die ich in der Hand hatte war aber eine 9.2 ob es bei den neusten auch so ist kann dir aber sicher jemand anderes beantworten.

Ach ja... noch ein Tipp zu deiner Kanotix... Tipper doch einfach mal ein: apt-cache search mesa in deine root-konsole. Vielleicht gibt er dir ja eine passende Antwort :-P

Ich glaube aber dein Problem lässt sich durch R.T.F.M. lösen!

In diesem Sinne...



Sebastian van de Meer

_________________
http://www.kernel-error.de


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 6 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de