Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Routing funktioniert nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
frenchen
Gast





BeitragVerfasst am: 21. Feb 2006 13:53   Titel: Routing funktioniert nicht

Hallo,

wir haben ein PC mit 2 Netzwerkkarten, der mit der Distribution OSS von Suse eingerichtet worden ist.
Wir haben einen DHCP- und Proxyserver erstellt.

Das DHCP funktioniert wunderbar, jeder Client bekommt eine IP aus dem Pool.
Mit dem Server kommen wir ins Internet, aber mit den Clients nicht.

Wir können bis zur 2 ten Netzwerkkarte pingen.

So nu noch einges zum Aufbau:

Die erste Netzwerkkarte ist eine interne Karte, an dieser hängt ein Hub, die andere Netzwerkkarte ist mit dem Internet verbunden.

Es ist kein Router dazwischen. Die Routingfunktion muss der Server mit übernehmen.
 

joersch
Gast





BeitragVerfasst am: 21. Feb 2006 16:18   Titel:

Mahlzeit,

dann muss du deinem server auch sagen, dass er routen soll!
und den clients sagen, dass sie den server als standardgateway nutzen sollen.
und das per dhcp-server (vielleicht auch dns mit übergeben)

Gruss
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 21. Feb 2006 16:20   Titel: Re: Routing funktioniert nicht

frenchen hat folgendes geschrieben::
Hallo,
Es ist kein Router dazwischen. Die Routingfunktion muss der Server mit übernehmen.

Ist das denn auch freigeschaltet?

YaST->Netzwerkdienste->Weiterleitung: IP-Weiterleitung aktivieren
YaST->Sicherheit und Benutzer->Firewall->Masquerading: Masquerading für Netzwerke aktivieren

(Bei der Gelegenheit sollte man sich auch Gedanken über die anderen Firewall-Regeln machen. Exclamation )

Janka
 
Benutzer-Profile anzeigen Private Nachricht senden

frenchen
Gast





BeitragVerfasst am: 21. Feb 2006 16:23   Titel:

Wir haben eine routing Tabelle angelegt und das Standardgateway eingeschrieben.

Die Clients sollen sich nur anstäpseln und los surfen.

Wenn wir versuchen vom Client uns über den Server ins Internet zu wählen, kommt in der Regel eine Passwortabfrage.
Danach geschieht nichts mehr, außer das uns gesagt wird, dass es diese Website nicht gibt.

P.S. den Proxy tragen wir im Browser ein, aber ansonsten sollte es ohne Client konfigurationen möglich sein ins Internet zu gehen.
 

frenchen
Gast





BeitragVerfasst am: 21. Feb 2006 16:24   Titel:

Ist beides aktiviert worden(Firewall und IP-Weiterleitung)
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 21. Feb 2006 16:30   Titel:

frenchen hat folgendes geschrieben::
Wir haben eine routing Tabelle angelegt und das Standardgateway eingeschrieben.

Die Clients sollen sich nur anstäpseln und los surfen.

Wenn wir versuchen vom Client uns über den Server ins Internet zu wählen, kommt in der Regel eine Passwortabfrage.
Danach geschieht nichts mehr, außer das uns gesagt wird, dass es diese Website nicht gibt.

P.S. den Proxy tragen wir im Browser ein, aber ansonsten sollte es ohne Client konfigurationen möglich sein ins Internet zu gehen.

Vermutlich ist an eurer Proxy-Konfiguration was faul. Mach es erstmal ohne Proxyserver und melde dich dann nochmal. Den sollte man nämlich erst konfigurieren, wenn es ohne geht.

Janka
 
Benutzer-Profile anzeigen Private Nachricht senden

rattenkind
Gast





BeitragVerfasst am: 22. Feb 2006 3:08   Titel:

Poste doch mal, was in der root konsole folgendes ergibt:
Code:
ifconfig -a
route -n
cat /proc/sys/ipv4/ip_forwarding
 

frenchen
Gast





BeitragVerfasst am: 22. Feb 2006 9:08   Titel:

rattenkind hat folgendes geschrieben::
Poste doch mal, was in der root konsole folgendes ergibt:
Code:
ifconfig -a
route -n
cat /proc/sys/ipv4/ip_forwarding


hallo hier die Daten(cat /proc/sys/ipv4/ip_forwarding gibt es nicht--> oft nur Informationen zu ipv6 gefunden, allerdings in anderen Ordnern)


ifconfig

th0 Protokoll:Ethernet Hardware Adresse 00:10:B5:D5:40:08
inet Adresse:192.168.0.2 Bcast:192.168.15.255
Maske:255.255.240.0
inet6 Adresse: fe80::210:b5ff:fed5:4008/64
Gültigkeitsbereich:Verbindung
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2277 errors:0 dropped:0 overruns:0 frame:0
TX packets:3693 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 Sendewarteschlangenlänge:1000
RX bytes:214808 (209.7 Kb) TX bytes:451769 (441.1 Kb)

Interrupt:9 Basisadresse:0xe00

eth0:mail Protokoll:Ethernet Hardware Adresse 00:10:B5:D5:40:08
inet Adresse:192.168.0.3 Bcast:192.168.15.255
Maske:255.255.240.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:9 Basisadresse:0xe00

eth0:prin Protokoll:Ethernet Hardware Adresse 00:10:B5:D5:40:08
inet Adresse:192.168.0.4 Bcast:192.168.15.255
Maske:255.255.240.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:9 Basisadresse:0xe00

eth0:prox Protokoll:Ethernet Hardware Adresse 00:10:B5:D5:40:08
inet Adresse:192.168.0.5 Bcast:192.168.15.255
Maske:255.255.240.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:9 Basisadresse:0xe00

eth1 Protokoll:Ethernet Hardware Adresse 00:10:B5:57:45:F5
inet Adresse:172.20.10.31 Bcast:172.20.15.255
Maske:255.255.248.0
inet6 Adresse: fe80::210:b5ff:fe57:45f5/64
Gültigkeitsbereich:Verbindung
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:217943 errors:0 dropped:0 overruns:0 frame:0
TX packets:18142 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 Sendewarteschlangenlänge:1000
RX bytes:22387024 (21.3 Mb) TX bytes:1854769 (1.7 Mb)
Interrupt:5 Basisadresse:0xcf00

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:280518 errors:0 dropped:0 overruns:0 frame:0
TX packets:280518 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 Sendewarteschlangenlänge:0
RX bytes:18480374 (17.6 Mb) TX bytes:18480374 (17.6 Mb)

sit0 Protokoll:IPv6-nach-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 Sendewarteschlangenlänge:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)


route -n


Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use
Iface
172.20.8.0 0.0.0.0 255.255.248.0 U 0 0 0
eth1
192.168.0.0 0.0.0.0 255.255.240.0 U 0 0 0
eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0
eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 172.20.10.31 0.0.0.0 UG 0 0 0
eth1
 

frenchen
Gast





BeitragVerfasst am: 22. Feb 2006 9:24   Titel:

rattenkind hat folgendes geschrieben::
Poste doch mal, was in der root konsole folgendes ergibt:
Code:
ifconfig -a
route -n
cat /proc/sys/ipv4/ip_forwarding


Ich habe jetzt unter folgendem Pfad cat /proc/sys/net/ipv4/ip_forward
eine

1

ausgegeben bekommen.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy