Treiber für GeForce 2 Ti?

Software besorgen und anwenden
Antworten
Nachricht
Autor
LinuxCLP
Beiträge: 8
Registriert: 26. Feb 2006 17:40

Treiber für GeForce 2 Ti?

#1 Beitrag von LinuxCLP » 27. Feb 2006 9:36

Hallo,
Ich habe unter Suse 10.0 und KDE die Meldung, dass ich keine 3D-Unterstützung für meine Grafikkarte habe! Und das, obwohl Linux den Kartentyp bei der Installation richtig erkannt hat...
Gibt es dafür einen aktuelen Treiber, der das behebt? Und wenn ja, wie installiere ich den?

MfG LinuxCLP

nvidia

#2 Beitrag von nvidia » 27. Feb 2006 14:41

auf nvidia.de den linuxtreiber zeihen und installieren.

dZ

#3 Beitrag von dZ » 04. Mär 2006 8:54

auf der website von nvidia gibt es detailierte install-anleitungen für verschiedenen distributionen. bei der GF2 Ti ist allerdings zu beachten dass diese nur mehr in der legacy version unterstützt werden da die karte schon etwas älter ist. die treiber funktioneren in den allermeisten fällen einwandfrei.

ftp://download.nvidia.com/XFree86/Linux ... README.txt

hier findest du die installanleitung.

dZ

LinuxCLP
Beiträge: 8
Registriert: 26. Feb 2006 17:40

#4 Beitrag von LinuxCLP » 18. Mär 2006 9:10

Ich habe es erst mit einer etwas neueren version versucht, die (laut readme) auch die GF 2 ti unterstützt (v. 7167). Doch wenn ich unter init 3 den installer starte, sagt er mir, ich hätte den falschen kernel, und er versucht, den passenden von der ftp-site zu laden. problem dabei: wie öffne ich eine i-net verbindung unter init 3 ???
Außerdem kommt da noch ein anders problem: wenn er den kernel dann nicht runterlädt und versucht, sich einen passenden zu kompilieren, fragt er nach dem programm "gcc". Er sagt, es sei nicht installiert, oder "not in your PATH". Das Paket ist installiert, ich habs unter yast nachgeschaut...

Benutzeravatar
grantlbart
Beiträge: 112
Registriert: 19. Mär 2003 3:05
Wohnort: München

#5 Beitrag von grantlbart » 18. Mär 2006 10:40

Gehen wir mal planmässig vor:

-Sind make, gcc und kernel sourcen installiert?
-Liefert der Befehl
simmerl:/home/wolfgang # rpm -q kernel-default
kernel-default-2.6.13-15.8
simmerl:/home/wolfgang # rpm -q kernel-source
kernel-source-2.6.13-15.8
die gleiche Version?
-Den Treiber hast Du ja schon runtergeladen.
Dann gehts weiter, als root auf der Konsole unter init 3:

-cd/ usr/src/linux
-make cloneconfig
-make prepare-all
-wechseln in das Verzeichnis in dem sich der Treiber befindet cd /home/....
-sh NVIDIA-Linux-x86-1.0-7676-pkg1.run --kernel-source-path=/usr/src/linux
(Die Version (7676) musst Du natürlich anpassen)
-sax2 -m 0=nvidia
-init 5

Fertig
-
Greetz
Grantlbart

LinuxCLP
Beiträge: 8
Registriert: 26. Feb 2006 17:40

#6 Beitrag von LinuxCLP » 19. Mär 2006 9:49

es klappt noch nicht...

- make, gcc und kernel-source SIND installiert, jedenfalls laut YaST.
- meine kernel-version stimmt überein (2.6.13-15)

Fehlermeldung bei "make config":
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 11: command not found
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 12: command not found
HOSTCC scripts/basic/fixdep
/bin/sh: gcc: command not found
make[1]: *** [scripts/basic/fixdep] Error 127
make: *** [scripts_basic] Error 2

und bei "make prepare-all" kommt folgendes:
Makefile:494: .config: No such file or directory
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 11: command not found
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 12: command not found
make: gcc: command not found
CHK /usr/src/linux-2.6.13-15/include/linux/version.h
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 11: command not found
/usr/src/linux-2.6.13-15/scripts/gcc-version.sh: line 12: command not found
HOSTCC scripts/basic/fixdep
/bin/sh: gcc: command not found
make[2]: *** [scripts/basic/fixdep] Error 127
make[1]: *** [scripts_basic] Error 2
make: *** [/usr/src/linux-2.6.13-15/include/linux/autoconf.h] Error 2


Das install-programm gibt auch nach eingabe des abgeänderten Befehls die gleiche Fehlermeldung heraus wie vorher.

Hilfe?

Antworten