Brother Drucker unter suse original treiber problem

Antworten
Nachricht
Autor
mr.Zeno

Brother Drucker unter suse original treiber problem

#1 Beitrag von mr.Zeno » 07. Mär 2006 19:21

Hallo ihr lieben,

ich habe mich nun viel durchgegoogelt um meinen Brother 1230 Laserdrucker unter (open) Suse 10 64bit (KDE) zum software duplex drucken zu bekommen. Die Suse Treiber funktionieren bloß ohne duplex :( Von Brother werden Treiber gestellt die ich fürher einmal so weit ich mich erinnern kann ohne weitere Probleme installieren konnte und die mir das software duplex (also erste hälfte Drucken umdrehen, 2 hälfte drucken) ermöglicht haben.

Was habe ich versucht:
http://www.unixboard.de/vb3/archive/...p/t-16912.html
http://solutions.brother.com/linux/s...drivers.html#2
http://solutions.brother.com/linux/s...linux_faq.html
http://solutions.brother.com/linux/s...r_install.html
http://solutions.brother.com/linux/s..._install2.html

dort habe ich die meine bisherige "inspiration" her.

Konkret sah dies folgendermaßen aus:
die von SUSE mitgelieferten Treiber funktionieren gut, bloß unterstützen eben nicht das duplex.

also habe ich den Brother treiber von runtergeladen.
http://solutions.brother.com/linux/s...r_drivers.html
yast --> paket intallieren:
es kommt die Fehlermeldung:
ERROR(InstTarget:E_RpmDB_subprocess_failed)
---
2006-03-07 00:52:46 hl1230lpr remove ok
Additional rpm output:
/var/tmp/rpm-tmp.17759: line 4: /etc/init.d/lpd: No such file or directory
error: %postun(hl1230lpr-1.1.2-1) scriptlet failed, exit status 127

2006-03-07 00:53:21 hl1230lpr-1.1.2-1.i386.rpm install failed
rpm output:
/var/tmp/rpm-tmp.70551: line 2: /etc/init.d/lpd: No such file or directory
error: %post(hl1230lpr-1.1.2-1) scriptlet failed, exit status 127


Also hab ich ln -s /etc/init.d/cups /etc/init.d/lpd ausgeführt was auch geholfen hat. Also Paket installiert.
laut anleitung (http://solutions.brother.com/linux/s...r_install.html) mus ich nun /etc/printcap editieren. Bei mir ist sie praktisch leer ("#This file was automatically generated by cupsd( from the /etc/cups/printers.conf file. All chages to this file will be lost") Der in der Datei erwähnte file aus auch leer
Den Cups Wrapper (http://solutions.brother.com/linux/s...ivers.html#red) finde ich nicht zum installieren in yast, nur wenn ich das Paket über rpm -ihv --nodeps cupswrapperHL1230-1.0.2-1.i386.rpm installiere (was funktioniert) kann ich es sehen. Naja er meldet sich sogar gleich, "CupsWrapper1230 benötigt lpr"
Nach der installation von dem Wrapper habe ich auch einen installierten Drucker in CUPS, konfigurieren kann ich ihrn aber nicht. Es kommt die Fehlermeldung:"Laden eines passenden Treibers für Drucker HL1230 ist nicht möglich. Fehlermeldung des Verwaltungsprogramms:
/var/tmp/440cd03551be4(Zeile 55): syntax error, unexpected KEYWORD, expecting STRINGPART or QUOTED"

Nun weiß ich absolut nicht weiter. Habt ihr vielleicht eine Idee was an dieser Stelle tun kann? Leider benutze ich noch nicht so lange Linux so dass mir konkrete Befehle mehr helfen.

Vielen Dank Schon einmal!!

Mr. Zeno

mr.Zeno

#2 Beitrag von mr.Zeno » 07. Mär 2006 19:22

Sorry die Links haben nicht funktioniert also nochmal



Hallo ihr lieben,

ich habe mich nun viel durchgegoogelt um meinen Brother 1230 Laserdrucker unter (open) Suse 10 64bit (KDE) zum software duplex drucken zu bekommen. Von Brother werden Treiber gestellt die ich fürher einmal so weit ich mich erinnern kann ohne weitere Probleme installieren konnte und die mir das software duplex (also erste hälfte Drucken umdrehen, 2 hälfte drucken) ermöglicht haben.

Was habe ich versucht:
http://www.unixboard.de/vb3/archive/ind ... 16912.html
http://solutions.brother.com/linux/sol/ ... ers.html#2
http://solutions.brother.com/linux/sol/ ... x_faq.html
http://solutions.brother.com/linux/sol/ ... stall.html
http://solutions.brother.com/linux/sol/ ... tall2.html

dort habe ich die meine bisherige "inspiration" her.

Konkret sah dies folgendermaßen aus:
die von SUSE mitgelieferten Treiber funktionieren gut, bloß unterstützen eben nicht das duplex.

also habe ich den Brother treiber von runtergeladen.
http://solutions.brother.com/linux/sol/ ... ivers.html
yast --> paket intallieren:
es kommt die Fehlermeldung:
ERROR(InstTarget:E_RpmDB_subprocess_failed)
---
2006-03-07 00:52:46 hl1230lpr remove ok
Additional rpm output:
/var/tmp/rpm-tmp.17759: line 4: /etc/init.d/lpd: No such file or directory
error: %postun(hl1230lpr-1.1.2-1) scriptlet failed, exit status 127

2006-03-07 00:53:21 hl1230lpr-1.1.2-1.i386.rpm install failed
rpm output:
/var/tmp/rpm-tmp.70551: line 2: /etc/init.d/lpd: No such file or directory
error: %post(hl1230lpr-1.1.2-1) scriptlet failed, exit status 127


Also hab ich ln -s /etc/init.d/cups /etc/init.d/lpd ausgeführt was auch geholfen hat. Also Paket installiert.
laut anleitung (http://solutions.brother.com/linux/sol/ ... stall.html) mus ich nun /etc/printcap editieren. Bei mir ist sie praktisch leer ("#This file was automatically generated by cupsd(8) from the /etc/cups/printers.conf file. All chages to this file will be lost") Der in der Datei erwähnte file aus auch leer :(
Den Cups Wrapper (http://solutions.brother.com/linux/sol/ ... s.html#red) finde ich nicht zum installieren in yast, nur wenn ich das Paket über rpm -ihv --nodeps cupswrapperHL1230-1.0.2-1.i386.rpm installiere (was funktioniert) kann ich es sehen. Naja er meldet sich sogar gleich, "CupsWrapper1230 benötigt lpr"
Nach der installation von dem Wrapper habe ich auch einen installierten Drucker in CUPS, konfigurieren kann ich ihrn aber nicht. Es kommt die Fehlermeldung:"Laden eines passenden Treibers für Drucker HL1230 ist nicht möglich. Fehlermeldung des Verwaltungsprogramms:
/var/tmp/440cd03551be4(Zeile 55): syntax error, unexpected KEYWORD, expecting STRINGPART or QUOTED"

Nun weiß ich absolut nicht weiter. Habt ihr vielleicht eine Idee was an dieser Stelle tun kann? Leider benutze ich noch nicht so lange Linux so dass mir konkrete Befehle mehr helfen.

Vielen Dank Schon einmal!!

Mr. Zeno

Antworten