Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Druckerproblem: CUPS Deamon konnte nicht initialisiert werden

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
marta
Gast





BeitragVerfasst am: 14. März 2006 8:57   Titel: Druckerproblem: CUPS Deamon konnte nicht initialisiert werden

Habe einen HP Laserjet 1010 (USB-Anschluß) und arbeite mit Suse 9.1.
Leider hatte ich schon oft das Problem, daß der Drucker nicht will. Bisher habe ich diesen dann über YAST --> Hardware --> Drucker entfernt und wieder hinzugefügt.
Jetzt bekomme ich aber immer die Fehlermeldung "CUPS Deamon konnte nicht erfolgreich initialisiert werden".
Über hilfreiche Tipps würde ich mich sehr freuen.
 

brum
Gast





BeitragVerfasst am: 14. März 2006 10:29   Titel: cups

Hallo marta,

kann es vielleicht (1. Fall) sein, dass du erst den druckerauftrag ausführst und dann den drucker einschaltest ?
In diesem fall geht schaltet cups den drucker auf deaktiviert und lässt sich dann nur mit adminrechten - zb. im webfrontend oder 'kcmshell printmgr' wieder einschalten.
(Ich nutze für 'meine' User das programm gtklpq dafür, welches dann mit sudo-rechten ausgeführt wird.)

Dein 2. fall sieht schon eteas böser aus. Wenn du als root /etc/init.d/cupsd start ausführst (kenne SuSE net kann evtl auch ./etc/init.d/cupssys start o.ä. sein), bekommst due diese fehlermeldung. Steht denn dann etwas brauchbares in dem Logile?
( /var/log/cups/err_log) ?

bye brum
 

marta
Gast





BeitragVerfasst am: 14. März 2006 20:53   Titel:

Hallo brum (-Bär?) !
Vielen Dank für die schnelle Hilfe - konnte erst jetzt wieder an den Rechner.
habe den CUPS-Daemon neu gestartet (bei Suse: /etc/rc.d/cups restart) -->
cupsd: Child exited with status 98!
Im error_log steht z.B. als letzter Eintrag:
Full reload complete.
E [14/Mar/2006:21:52:20 +0100] StartListening: Unable to bind socket - Address already in use.
Vielleicht sollte ich mal alle Pakete für CUPS neu installieren?
Bis dann
marta
 

brum
Gast





BeitragVerfasst am: 15. März 2006 11:35   Titel: cups

Hallo,

eigentlich bin ich froh, dass bei mir cups (liegt vielleicht an der Vorkonfiguration des Distributors Wink - Mandriva) so gut läuft, auf einer Kiste einen Drucker installieren und alle anderen im Netz sehen diesen Drucker sofort - ohne weitere Konfigurationen, eben wie einen lokal installierten und können sofort darauf zugreifen -> so dass ich in diesen Fehlermeldungen etwas unbedarft bin ....

Die Meldung klingt so, als ob etwas anderes schon auf den cups-Port zugreift, was aber wenig wahrscheinlich ist. Wird cups 2x gestartet?

mach mal bitte: $ ps -ef|grep cups
root 2814 1 0 08:25 ? 00:00:00 cupsd
brum 9018 8951 0 11:25 pts/6 00:00:00 grep cups

so siehts aus, wenn cups schon im Leerlauf steht.

Installiere doch cups mal neu, unbedingt auch alle Konfigurationen dazu löschen.
1-entfernen von cups
2.- löschen, was nach cups richt ... (/etc/cups/...)
3 - neu d'raufspielen

Vielleicht bringts was - viel Erfolg

bye brum
 

marta
Gast





BeitragVerfasst am: 15. März 2006 20:30   Titel:

Hallo brum,
hurra, gerade hat mein Drucker wieder was gedruckt.
Also: der Prozeß cupsd lief überhaupt nicht (ps -ef).
Habe dann über YAST alle Pakete, die zu cups gehören erstmal aktualisiert, hat aber nichts gebracht. Also habe ich diese gelöscht (außer cups-libs --> wg. zu zahlreichen Abhängigkeiten), den Rechner mal durchgestartet und die gleichen Pakete wieder installiert. Dann konnte ich den Drucker wieder problemlos einrichten und schon ein Office-Dokument mit Foto drucken.
Vielen Dank noch einmal für deine Hilfe !!!!
marta Smile
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy