Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
mount: unknown filesystem type 'smbfs'?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
B@sti



Anmeldungsdatum: 25.03.2006
Beiträge: 6

BeitragVerfasst am: 26. März 2006 15:21   Titel: mount: unknown filesystem type 'smbfs'?

Hi Leute,

bin blutiger Anfänger, also bitte nich über mich herfallen Wink

Wollte per mount auf meinen WinXP Rechner zugreifen, doch wenn ich den Befehl
Code:
mount -t smbfs //sebastian/c /home/Basti/xp-mnt
eingebe kommt die Fehlermeldung:
Code:
mount: unknown filesystem type 'smbfs'?

Wieso? Und wie kann ich das Problem lösen?

MfG
Basti
 
Benutzer-Profile anzeigen Private Nachricht senden

rattenkind
Gast





BeitragVerfasst am: 26. März 2006 16:05   Titel:

Linux-Distribution?
Code:
uname -a
cat /proc/filesystems
lsmod

ratte
 

B@sti



Anmeldungsdatum: 25.03.2006
Beiträge: 6

BeitragVerfasst am: 26. März 2006 16:25   Titel:

uname -a
Code:
Linux Fedora 2.6.15-1.2054_FC5 #1 Tue Mar 14 15:48:33 EST 2006 i686 i686 i386 GNU/Linux


cat...
Code:
nodev   sysfs
nodev   rootfs
nodev   bdev
nodev   proc
nodev   binfmt_misc
nodev   debugfs
nodev   securityfs
nodev   sockfs
nodev   usbfs
nodev   pipefs
nodev   futexfs
nodev   tmpfs
nodev   inotifyfs
nodev   eventpollfs
nodev   devpts
        ext2
nodev   ramfs
nodev   hugetlbfs
        iso9660
nodev   mqueue
nodev   selinuxfs
        ext3
nodev   rpc_pipefs
nodev   autofs


lsmod
Code:
bash: lsmod: command not found
 
Benutzer-Profile anzeigen Private Nachricht senden

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 27. März 2006 18:06   Titel:

B@sti hat folgendes geschrieben::


lsmod
Code:
bash: lsmod: command not found


Sieht so aus als haettest Du das mounten als normaler user versucht (da Du nicht einfach lsmod ausfuehren kannst, probiere /sbin/lsmod).
Probiere es mal als root oder aendere Deine /etc/fstab, zBsp:
Code:
//sebastian/c /home/Basti/xp-mnt           smbfs    user,rw


Ach, ja: Der Name des linux-Benutzers sollte entweder dem Windows bekannt sein oder benutze die Option "username=Domaene\\Freigabebenutzer". Ob Du dabei dann Slashes oder Backslashes und wieviele davon benutzen musst, haengt davon ab ob in der Kommandozeile oder vielleicht in einem Skript benutzt.
 
Benutzer-Profile anzeigen Private Nachricht senden

B@sti



Anmeldungsdatum: 25.03.2006
Beiträge: 6

BeitragVerfasst am: 27. März 2006 23:14   Titel:

Nein, habe es als Admin (su) versucht... und nun?
 
Benutzer-Profile anzeigen Private Nachricht senden

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 28. März 2006 7:54   Titel:

Versuche, das Modul "smbfs" zu laden (dies sollte eigentlich automatisch geschehen):
Code:
modprobe smbfs


Und schicke eine mögliche Fehlermeldung.
 
Benutzer-Profile anzeigen Private Nachricht senden

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 28. März 2006 12:24   Titel:

@basti

hi

wenn du zum root wechselst mach
su -

dann hast du auch die Pfade Variablen des root.

dadurch geht dann auch ein lsmod.


mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

B@sti



Anmeldungsdatum: 25.03.2006
Beiträge: 6

BeitragVerfasst am: 31. März 2006 12:03   Titel:

Lateralus hat folgendes geschrieben::
Versuche, das Modul "smbfs" zu laden (dies sollte eigentlich automatisch geschehen):
Code:
modprobe smbfs


Und schicke eine mögliche Fehlermeldung.


Code:
bash: modprobe: command not found


Kann es sein das ich ein allgemeines Problem mit meiner Linuxinstallation habe? Das da was schief gelaufen ist? Oder warum bekomm ich bei den Befeheln die ihr mir nennt meist ein "command not found"?
 
Benutzer-Profile anzeigen Private Nachricht senden

Hans Solo
prolinux-forum-admin


Anmeldungsdatum: 20.04.2004
Beiträge: 601
Wohnort: AT

BeitragVerfasst am: 31. März 2006 12:58   Titel:

hi frag halt:
wie wechselst du zum root?
ansonsten versuche
/sbin/modprobe

mfg
arno
_________________
[root@host]# cd /pub
[root@host]# more beer
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 31. März 2006 13:34   Titel:

Hallo,

B@sti hat folgendes geschrieben::
Oder warum bekomm ich bei den Befeheln die ihr mir nennt meist ein "command not found"?
Kleiner Grundkurs: Wenn Du dich einloggst, wird diesem Benutzer eine Umgebungs-Einstellungen (ENVIRONMENT) mitgegeben zBsp. Programm-Pfade. Diese Einstellungen sind für 'normale' Benutzer andere als für root. (Der Programm-Pfad zBsp. wird im allgemeinen aus der /etc/profile abgelesen und für root sind hierin zusätzlich /usr/sbin und /sbin (sbin steht fuer s(ystem)bin).)
Im Fall des Benutzerwechsels mit 'su' ändert sich aber wirklich nur der Benutzer, das ENVIRONMENT bleibt wie vorher.
Erst mit 'su -' wird diese Login-Prozedur komplett ausgeführt, mit der Folge, dass zBsp. /sbin/lsmod nur durch Angabe des Namens 'lsmod' funktioniert.

Als welcher Benutzer Du gerade tätig bist erfährst Du mit
Code:
whoami


Zuletzt bearbeitet von komsomolze am 11. Jul 2006 14:31, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

B@sti



Anmeldungsdatum: 25.03.2006
Beiträge: 6

BeitragVerfasst am: 02. Apr 2006 12:23   Titel:

HI,

danke. Ich wusste das mit su, aber mit su - kannte ich nicht. Nun funktionieren auch die Befehle Embarassed

Code:
modprobe smbfs
FATAL: Module smbfs not found.


Code:
lsmod
Module                  Size  Used by
ppdev                   8645  0
autofs4                19013  1
hidp                   15937  2
rfcomm                 34517  0
l2cap                  23617  10 hidp,rfcomm
bluetooth              44069  5 hidp,rfcomm,l2cap
sunrpc                136573  1
ip_conntrack_netbios_ns     3009  0
ipt_REJECT              5441  1
xt_state                2241  2
ip_conntrack           49261  2 ip_conntrack_netbios_ns,xt_state
nfnetlink               6489  1 ip_conntrack
xt_tcpudp               3265  4
iptable_filter          3137  1
ip_tables              11657  1 iptable_filter
x_tables               12613  4 ipt_REJECT,xt_state,xt_tcpudp,ip_tables
video                  14917  0
button                  6609  0
battery                 9285  0
ac                      4933  0
ipv6                  225569  12
lp                     12296  0
parport_pc             25445  1
parport                34313  3 ppdev,lp,parport_pc
floppy                 57733  0
nvram                   8393  0
uhci_hcd               28881  0
snd_intel8x0           30301  1
snd_ac97_codec         83937  1 snd_intel8x0
snd_ac97_bus            2497  1 snd_ac97_codec
snd_seq_dummy           3781  0
snd_seq_oss            28993  0
snd_seq_midi_event      7105  1 snd_seq_oss
snd_seq                47153  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          8909  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            45009  0
3c59x                  41577  0
snd_mixer_oss          16449  1 snd_pcm_oss
mii                     5313  1 3c59x
snd_pcm                76869  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              22597  2 snd_seq,snd_pcm
snd                    50500  11 snd_intel8x0,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9377  1 snd
i2c_i810                5317  0
i2c_algo_bit            8393  1 i2c_i810
snd_page_alloc         10441  2 snd_intel8x0,snd_pcm
i2c_i801                8397  0
i2c_core               20673  2 i2c_algo_bit,i2c_i801
dm_snapshot            16237  0
dm_zero                 2241  0
dm_mirror              19985  0
dm_mod                 50649  6 dm_snapshot,dm_zero,dm_mirror
ext3                  116809  2
jbd                    53077  1 ext3


Danke für eure Mühen!

Grüße.
Basti
 
Benutzer-Profile anzeigen Private Nachricht senden

komsomolze



Anmeldungsdatum: 03.03.2006
Beiträge: 429

BeitragVerfasst am: 02. Apr 2006 16:09   Titel:

hallo,

Zitat:
Linux Fedora 2.6.15-1.2054_FC5 #1 Tue Mar 14 15:48:33 EST 2006 i686 i686 i386 GNU/Linux

modprobe smbfs
FATAL: Module smbfs not found.
ich kenne Fedora jetzt nicht, aber das verwundert mich doch.
Hast Du einen eigenen Kernel gebaut ohne smbfs?
Überpruefe doch bitte das Vorhandensein in /lib/modules...../fs/smbfs.
Falls Fedora auf das Modul verzichtet hat (?, deprecated?): Vielleicht arbeitet es mit dem Modul cifs. Liegt dieses vor? (/lib/modules...../fs/cifs)
Die mount-Optionen sind ziemlich änlich (siehe man mount.cifs, man smbmount).

AD:
Habe gerade den Fedora-i586 heruntergeladen: KEIN smbfs !!! (dto. i686)
Also mache das ganze mit dem Modul cifs (mount.cifs oder 'mount -tcifs ...')


OffTopic:
Wie ich sowas hasse:
Code:
suse-traceroute (lst.de~okir orig): -I interface
fedora-traceroute(lst.de~okir modif.): -i interface
debian-traceroute(BSD): -i interface -I (ICMP statt udp)
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy