Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
eth1 oder eth2, was denn nun ?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Raphael
Gast





BeitragVerfasst am: 14. Apr 2006 9:37   Titel: eth1 oder eth2, was denn nun ?

Ich habe auf meinem Centrino-Laptop unter Debian (etch), Kernel 2.6.15-1-686 seit drei Tagen ein Problem das ich nicht so ganz nachvollziehen kann.

Die Wireless Karte funktioniert eigentlich problemlos ( Treiber ipw2200) und wurde standardmässig immer als eth1 erkannt.
/etc/network/interfaces ist korrekt enthält die korrekten Einstellungen für eth1 und beim Booten wird automatisch eine im Router für diesen Laptop festgelegte IP-Adresse bezogen. Alles wunderbar, eigentlich.
Neuerdings aber, seit drei Tagen, wird mal eth1 als Wireless erkannt, und ein andermal eth2.
Das Gerät hat kein eth2 !
Das geschieht scheinbar zufällig nach jedem Startvorgang, also immer wenn der Laptop zwischendurch ausgeschaltet war.
Wenn also vorher eth1 korrekt erkannt wurde, passiert es nach einem Neustart, dass eth1 nicht mehr als WLAN erkannt wird, sondern eth2. Ich muss dann in diesem Fall den Eintrag für eth1 in /etc/network/interfaces in eth2 ändern. Dann funktioniert eth2 genau wie vorher eth1.
Wenn ich aber den Rechner neu starte, springt das Ganze irgendwie wieder zurück zu eth1 und ich muss das nochmal ändern.
Dieses Verhalten erscheint zufällig.

Es scheint also so, als sei Debian sich nicht so richtig einig welches gerät da jetzt eigentlich das WLAN ist.
Ich habe die Vermutung dass irgendwas falsch eingestellt ist, weiss aber nicht was.

Hoffe ihr könnt mir helfen ?
Das nervt nämlich und ich hab keine Ahnung woran das liegen könnte.

Systemupdate mach ich ürigens täglich.
 

schappi-aktiv
Gast





BeitragVerfasst am: 14. Apr 2006 10:09   Titel: ifconfig

Hallo,

poste doch mal die ifconfig ausschriften deiner beiden zustände.

bei mir hatte sich auch mal (aber stabil) die netzwerkreihenfolge verändert, weil irgensowas wie sit (ip6 over ip4 ?) als netzgerät erkannt wurde, an einer andern kiste mal firewire...

vielleicht hat sich auch was in der stratreihenfolge verändert und es hilft ein definiertes entladen/laden der module?

bye
 

Raphael
Gast





BeitragVerfasst am: 14. Apr 2006 18:57   Titel:

Momentan ist es eth2
Komischerweise passiert das nicht immer.
Heute Mittag war es auch schon eth2 und zwischendurch war der Rechner aus.
Aber wenn ich morgen früh wieder einschalte, ist es garantiert wieder eth1

ifconfig sagt:
Code:

eth2      Protokoll:Ethernet  Hardware Adresse 00:0E:35:20:2D:8B
          inet Adresse:192.168.69.12  Bcast:192.168.69.255  Maske:255.255.255.0
          inet6 Adresse: fe80::20e:35ff:fe20:2d8b/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1492  Metric:1
          RX packets:150 errors:0 dropped:0 overruns:0 frame:0
          TX packets:126 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:97296 (95.0 KiB)  TX bytes:16915 (16.5 KiB)
          Interrupt:9 Basisadresse:0x8000 Speicher:ffdfe000-ffdfefff

lo        Protokoll:Lokale Schleife
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:38 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:2636 (2.5 KiB)  TX bytes:2636 (2.5 KiB)


iwconfig sagt:
Code:

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

eth2      IEEE 802.11b  ESSID:"green-parrot"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:09:5B:CE:0B:8A
          Bit Rate=11 Mb/s   Tx-Power=20 dBm
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:7A0C-1FEA-09D3-3E8B-166D-AC3C-6F   Security mode:open
          Power Management:off
          Link Quality=88/100  Signal level=-41 dBm  Noise level=-83 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.
 

Raphael
Gast





BeitragVerfasst am: 16. Apr 2006 7:55   Titel:

echt nicht mehr lustig.
Nachdem jetzt zwei Tage alles bei eth2 blieb, ist es plötzlich wieder eth1.
Hat denn niemand einen Tip für mich ?
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 16. Apr 2006 11:29   Titel:

Es wäre nützlich, wenn du auch die Angaben, der unkonfigurierten Interfaces postest: "ifconfig -a"
 
Benutzer-Profile anzeigen Private Nachricht senden

Raphael
Gast





BeitragVerfasst am: 19. Apr 2006 9:57   Titel:

ifconfig -a:
Code:

eth0      Protokoll:Ethernet  Hardware Adresse 00:0C:76:F6:7E:72
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:5 Basisadresse:0xc800

eth1      Protokoll:UNSPEC  Hardware Adresse 00-10-DC-00-00-5D-94-CC-00-00-00-00-00-00-00-00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth2      Protokoll:Ethernet  Hardware Adresse 00:0E:35:20:2D:8B
          inet Adresse:192.168.69.12  Bcast:192.168.69.255 Maske:255.255.255.0
          inet6 Adresse: fe80::20e:35ff:fe20:2d8b/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1492  Metric:1
          RX packets:1444 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1348 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:8582977 (8.1 MiB)  TX bytes:934609 (912.7 KiB)
          Interrupt:9 Basisadresse:0x2000 Speicher:ffdfe000-ffdfefff

lo        Protokoll:Lokale Schleife
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:48 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:3328 (3.2 KiB)  TX bytes:3328 (3.2 KiB)

sit0      Protokoll:IPv6-nach-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


Momentan scheint es stabil bei eth2 zu bleiben.
Hatte nur vor 2 Tagen wieder eth1, was nach einem Reboot aber wieder zu eth2 wurde.
Vielleicht wird da manchmal hardwaremässig irgendwas nicht erkannt ?
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 20. Apr 2006 10:53   Titel:

Was UNSPEC bei eth1 bedeutet, weiß ich nicht, aber eth0 sieht definitiv wie eine andere Netzwerkkarte aus. Sicher, dass du nicht noch eine andere Netzwerkkarte in dem Rechner hast?

Vielleicht mal ein "lspci" als root versuchen, dass sollte dir alle mögliche Hardware in deinem System anzeigen.
 
Benutzer-Profile anzeigen Private Nachricht senden

Raphael
Gast





BeitragVerfasst am: 20. Apr 2006 11:51   Titel:

Klar steckt da noch ne andere Karte drin.
Das Teil hat ja auch einen Anschluss für ein Cat 5 Kabel, also einen "normalen" Netzwerkanschluss, sowie einen Firewire Anschluss.

Nach dem morgendlichen Bootvorhgang bin ich mal wieder bei eth1 gelandet.

lspci sagt:
Code:

0000:00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 21)
0000:00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 21)
0000:00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
0000:00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
0000:00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 03)
0000:00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
0000:00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
0000:00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
0000:02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:02:04.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
0000:02:04.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
0000:02:04.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 04)
0000:02:09.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 22. Apr 2006 9:52   Titel:

Dann könnte ich mir dein Problem nur so erklären, dass sich die Reihenfolge, in denen die Module geladen werden, welche die entsprechenden Treiber enthalten, von Zeit zu Zeit unterscheidet.

Abhilfe wäre vielleicht, die Treiber in den Kernel zu kompilieren, oder aber die Reihenfolge des Ladens explizit anzugeben. (VIelleicht ist dies über die /etc/modules.conf - oder wie immer die Datei bei dir heißt - möglich.)

Eine Alternative wäre, in den Init-Prozess weit hinten ein Skript einzuhängen, welches analysiert, welches Interface die WLAN-Karte hat und dann diese umzukonfigurieren:

Dieses Skript kopierst du nach /etc/init.d und verlinkst es mit S99irgendwas in /etc/rc5.d oder welches runlevel auch immer bei dir default ist - ich hoffe, es stimmt soweit alles, aber prinzipiell müsste das funktionieren.

Code:
#!/bin/sh

WLAN_IP=192.168.69.12
LAN_IP=192.168.0.33    # oder wie auch immer

WLAN_NET=192.168.69.0
LAN_NET=192.168.0.0  # oder wie auch immer

case $1 in

   start)
      # Bestimmt das Interface des WLAN-Adapters
      wlan=$(iwconfig | grep "IEEE 802.11b" | awk ' { print $1 } ')

      # Bestimmt das Interface des LAN-Adapters - funktioniert nur, wenn
      # ifconfig nur zwei Zeilen mit "Ethernet" ausgibt
      for iface in $(ifconfig | grep "Ethernet" | awk ' { print $1 } '); do
         if test "$iface" != "$wlan"; then
            lan=$iface
         fi
      done

      ifconfig $wlan down
      ifconfig $lan down

      ifconfig $wlan netmask $WLAN_NET $WLAN_IP up
      ifconfig $lan netmask $LAN_NET $LAN_IP up
   ;;

   stop)
      ifconfig eth0 down
      ifconfig eth1 down
      ifconfig eth2 down
   ;;

   restart)
      $0 stop
      $0 start
   ;;

esac
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy