Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Habe Samba-Zugriff aber Ping und http funktionieren nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
marryloo2
Gast





BeitragVerfasst am: 15. Apr 2006 16:48   Titel: Habe Samba-Zugriff aber Ping und http funktionieren nicht

Hallo mein Name ist Mario und habe folgendes Problem:
Ich habe gerade die Debian Sarge 3.1-r1 als Entwicklungsumgebung auf meinem Server installieret.
Samba, Apache , PHP, Mysql, Postgresql installiert.So weit so gut.
Über Samba kann ich auf dem Server Dateien und Verzeichnisse anlegen, über lynx kann ich auf der Konsole die info.php im Document-Root aufrufen.
Also physikalisch funktioniert das ganze.
Nur funktioniert kein ping (Zeitüberschreitung der Anforderung) und ich kann von meinem Windows-XP Rechner die info.php und auch sonst keine Datei über http aufrufen.
Auch SSH-Zugriff über Putty geht nicht und auch kein FTP-Zugriff überr den Total-Commander.
Warum kann ich auf die Samba-Freigabe zugreifen aber sonst nichts ???
Wer kann mich in die richtioge Richtung schubsen ?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 15. Apr 2006 21:53   Titel:

Weil die Daemons nicht für entfernten Zugriff konfiguriert sind. Oder weil du seltsame Paketfilterregeln (Ping geht nicht) installiert hast.

Letzeres ist mittels "iptables -nvL" zu überprüfen.

Janka
 
Benutzer-Profile anzeigen Private Nachricht senden

marryloo2
Gast





BeitragVerfasst am: 16. Apr 2006 10:00   Titel:

[quote="Janka"]Weil die Daemons nicht für entfernten Zugriff konfiguriert sind. Oder weil du seltsame Paketfilterregeln (Ping geht nicht) installiert hast.

Letzeres ist mittels "iptables -nvL" zu überprüfen.

Ich bin kein Linux-Crack aber ich kann mir mein System i.d.R. schon selber aufsetzen, zumindest klappte das noch mit der Debian Woody. Da funktionierte alles auf anhieb.
Das man einen Webserver auf entfernten Zugriff konfigurieren muss, wäre mir neu, wozu ist er denn sonst da ?
Und wie gesagt ich habe mir das Grundsystem installiert und dann Samba, Mysql, Apache, PHP4, Postgresql, lynx und mc, sonst nix.
Ich habe auch kein iptables konfiguriert (habe nämlich keine Ahnung davon).
iptables -nvl spuckt nur >Unknown arg '-nvl'< aus.
Laut der Hilfe gibt es keine Option -l und alle anderen Optionen ergeben entweder die selbe Meldung oder >no command specified<.
Aber trotzdem vielen Dank für die Antwort.
 

C-Lerner
Gast





BeitragVerfasst am: 16. Apr 2006 22:12   Titel:

Wohl ein Problem der Namensauflösung sein.
Smb-ähnliches kann mit Netbios-Broadcasts aufglöst werden (obsolet), ansonsten DNS, hosts (lmhosts für smb), ...
Wie hast Du den Rechnern IP-Adressen zugewiesen? Benutzte für erste Tests eben erstmal diese, statt der Namen.
Zum Thema Namnesauflösung per DNS oder den hosts-Dateien wurde schon genügend geschrieben, also hier mal suchen oder googeln.
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 17. Apr 2006 0:13   Titel:

marryloo2 hat folgendes geschrieben::

Das man einen Webserver auf entfernten Zugriff konfigurieren muss, wäre mir neu, wozu ist er denn sonst da ?

z.B. um eine lokale Desktopsuche, ein lokales Wiki, ein lokales Hilfesystem, eine lokale Webanwendung laufen zu lassen?

Zitat:

Ich habe auch kein iptables konfiguriert (habe nämlich keine Ahnung davon).
iptables -nvl spuckt nur >Unknown arg '-nvl'< aus.
Laut der Hilfe gibt es keine Option -l und alle anderen Optionen ergeben entweder die selbe Meldung oder >no command specified<.

Merkt man. Du musst außerdem richtig abschreiben. Nochmal in groß:

Code:

# iptables -nvL


Janka
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy