chkrootkit meldung

Antworten
Nachricht
Autor
Benutzeravatar
Pseudomonas
Beiträge: 120
Registriert: 16. Nov 2005 12:55
Wohnort: /home/anonymous

chkrootkit meldung

#1 Beitrag von Pseudomonas » 11. Mai 2006 12:39

Hi,

ich habe chkrootkit gestartet und bekomme folgende meldung:

cupsChecking `z2'... user root deleted or never logged from lastlog!
Checking `chkutmp'... The tty of the following user process(es) were not found
in /var/run/utmp !
! RUID PID TTY CMD
! root 5364 tty7 /usr/X11R6/bin/X -br -nolisten tcp :0 vt7 -auth /var/lib/xdm/authdir/authfiles/A:0-9VubYI
! root 5091 pts/5 /bin/su root -c /opt/kde3/bin/kdesu_stub -
! root 5094 pts/5 /opt/kde3/bin/kdesu_stub
chkutmp: nothing deleted

hab ich mir da irgendwas eingefangen?


gestartet hab ich ckrootkit in einem terminal unter kde (eingeloggt als normaler user) nach eingabe von 'kdesu konsole'. Ich hab ein mit Bastille "behandeltes" Suse 10.0 OSS, root-login auf tty1 bis tty6 disabled.

Gruß
Gunnar
F#mmaj7/9

klopskuchen
prolinux-forum-admin
Beiträge: 1444
Registriert: 26. Jun 2004 21:18
Kontaktdaten:

#2 Beitrag von klopskuchen » 25. Mai 2006 13:26

/var/run/utmp enthält Informationen über am System angemeldete Benutzer. Das Kommando "who" zB. benutzt diese Datei. Deine chkrootkit-Meldungen besagen, das Benutzerprozesse gefunden wurden, die nicht in der utmp-Datei geloggt sind.
utmp selbst ist eine Struktur in C, zu der in der manpage steht: "because not all programs use utmp logging".
Deine Ausgabe enthält lediglich die Prozesse, unter denen du gerade gearbeitet hast: die sudo-Sitzung(tty7 ist die erste "X-Konsole", pts/5 das X-Terminal in dem gerade chkrootkit läuft).

MfG, Klopskuchen
When all else fails, read the instructions .

Benutzeravatar
Pseudomonas
Beiträge: 120
Registriert: 16. Nov 2005 12:55
Wohnort: /home/anonymous

#3 Beitrag von Pseudomonas » 25. Mai 2006 15:28

Hi Klopskuchen,

alles klar! Danke für Deine Antwort. :)

Gruß
Gunnar 8)
F#mmaj7/9

Antworten