Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Mit Windows 98 SE über Suse-Linux 10.0 ins internet

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Floh1111



Anmeldungsdatum: 06.06.2006
Beiträge: 1
Wohnort: Oldenburg

BeitragVerfasst am: 06. Jun 2006 22:23   Titel: Mit Windows 98 SE über Suse-Linux 10.0 ins internet

Hi erstmal,

Ich möchte mit dem alten Windows 98 SE PC meines Bruders, über mein Suse-Linux 10.0 System ins Internet gehen. (Was nicht klappt sonst währe ich nicht hier)
Beide Computer sind über eine Netzwerkkarte verbunden und der Datenaustausch (Ping) funktioniert.
Mein Linuxsystem ist über die erste serielle Schnitstelle (dev/ttsy0) mit einem 56K-Modem verbunden welches wiederum mit dem Internet komuniziert.
Die Internetverbindung stelle ich mit KInternet über verschiedene Call-by-Call Anbieter her.

Hier mein Konfigurations-Versuch des Windows 98 SE Clienten:

Start - Systemsteuerung – Netzwerk:

Computername: Friedjof

TCP/IP-Protokoll für 3Com 3c-90x...
IP-Adresse: 192.168.0.2
Sebnetzmask: 255.255.255.0
Gateway: 192.168.0.1
DNS-Konfiguration:
DNS Aktivieren,
Host: Firedjof,
Suchreihenfolge für DNS-Server: 192.168.0.1

Frage: Was ist Falsch? Ist was zu viel? Fehlt was?

Frage: Wie muss ich Firefox 1.5 oder den Internetexplorer 6 Konfigurieren?



Hier mein Konfigurations-Versuch für den Suse-Linux 10.0 Gateway (Hab mitlerweile ordendlich rumgewurschtelt):

Hardware:
Netwerkkarte: 3Com 3C-905C-TX 10/100 Mbit
Modem: Serielles 56K-Modem von Macom

Betriebsystem: Suse-Linux 10.0
Kernel-Version: 2.6.13-15-default
KDE-Version: 3.4.2 level „b“
Hardware-Architektur: i686

Konfiguration: Modem
K-menü – Kontrollzentrum – YaST2-Module – Netzwerkgeräte – Modem:

Unter dem Kartei-Reiter „Modemgeräte“ ist hier mein Modem mit dem Gerätenamen „modem0“ und einem Call-by-Call-Provider aufgeführt

Unter dem Kartei-Reiter „Provider“ sind alle meine Call-by-Call-Provider aufgeführt und so konfiguriert (Mit diesen Wähle ich mich über Kinternet ein):

Dail-on-Demand: Nein
Während verbindung DNS ändern: Ja
DNS automatisch abrufen: Ja
Ignoranz-Modus: Nein
Externe Firewall-Schnittstelle: Ja
Idle Time-Out (Sekunden): 600

IP-Details:

Dynamische IP-Adresse: Ja
Lokale IP-Adresse Ihres Rechners: --
Entfernte IP-Adresse: --
Standartroute: Ja

Frage: Ist das richtig? Ist was zu viel? Fehlt was?




Konfiguration: Netzwerkkarte
K-menü – Kontrollzentrum – YaST2-Module – Netzwerkgeräte – Netzwerkkarte:

Hier ist unter „Name“ meine Netzwerkkarte aufgeführt. Diese ist so konfiguriert (Bearbeiten)

IP-Adresse: 192.168.0.1
Subnetzmask: 255.255.255.0

Hostname und Nameserver:
Hostname: Clemens
Domainname: site
Nameserver 1: --
Domain-Suche 1: site

Routing:
Standartgateway: --
Konfiguration für Experten: Nein
IP-Weiterleitung aktivieren: Nein

Erweitert - Option für DHCP-Client:
------

Erweitert - Besondere einstellungen:
MTU: --
Geräteaktivierung: Beim Systemstart
Benutzergesteuert: Nein
Firewall-Zone: Interne Zohne (Nicht geschützt)

Erweitert - Zusätzliche Adressen:
-------

Frage: Ist das richtig? Ist was zu viel? Fehlt was?




Konfiguration: Firewall
K-menü – Kontrollzentrum – YaST2-Module – Sicherheit und Benutzer – Firewall:

Start:
Service starten: Beim Systemstart

Schnittstellen:
AT Modem: Externe Zohne
3Com 3C905C-TX Netzwerkkarte: Internet Schnittstelle

Erlaubte Dienste:
Interne Zone: Alle Dienste sind erlaubt
Externe + Entmilitarisierte Zohne: Keine Dienste sind erlaubt nur der TCP-Port 4662 ist unter erweitert für aMule offen
Firewall vor interner Zone schützen: Nein

Masquerading:
Masquerading für Netzwerke: Ja
Anfragen an Masqueraded IP umleiten: --

Broadcast:
Interne + Entmilitarisierte Zone: -- Nicht akzeptierte Broadcast Pakete Protokollieren: Ja
Externe Zone: -- Nicht akzeptierte Broadcast Pakete Protokollieren: Nein

Ipsec-Unterstützung:
Nicht aktiviert

Protokollierungs-level:
Nur kritische protokollieren


Frage: Ist das richtig? Ist was zu viel? Fehlt was?
Ich wette meinen Arsch das da noch sehr viel falsch ist und fehlt. Also nehmt euch bitte ein wenig viel Zeit für mich.

Ich währe euch auch für den Link zu einem HowTo oder einer Schritt für Schritt Erklährung sehr dankbar!

Herzlichen Dank im Vorraus...
_________________
Pentium III 600 Mhz
ATI 3D Rage Pro 8 mb
128 mb RAM
Suse Linux 10.0
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 07. Jun 2006 0:19   Titel:

1. IP-Weiterleitung muss am Linuxrechner aktiviert sein.
2. Du brauchst außerdem noch Masquerading auf dem Linuxrechner. Danach wurde hier bereits letztens gefragt, und ich habe da auch geantwortet. Bitte selber suchen.
3. Damit du am Windowsrechner den Linuxrechner als DNS-Server angeben kannst, muss da natülich auch ein DNS-Server drauf laufen. In deiner Konfiguration ist der "dnsmasq" empfehlenswert.

Da man Masquerading meines Wissens (noch) nicht über YaST einrichten kann, musst du dich ein wenig mit den Systeminterna auskennen, um ein funktionierendes Ergebnis zu erhalten. Gleiches gilt für dnsmasq.

Schwierigkeitsgrad für Admin-Novizen ist etwa 3/5, weil so viele Kleinigkeiten zu beachten sind.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy