Waterchill Treiber geht unter Linux nicht

Software besorgen und anwenden
Antworten
Nachricht
Autor
mrgreen5000
Beiträge: 8
Registriert: 15. Mai 2006 19:59

Waterchill Treiber geht unter Linux nicht

#1 Beitrag von mrgreen5000 » 18. Jun 2006 4:38

Ich habe eine USB Waterchill Xtreme Edition Pumpe (Wasserkühlung) und versuche die mit Ndiswrapper unter Linux funktionsfähig zu machen.
Aber irgendwie will das nicht....

mfg
mrgreen
Zuletzt geändert von mrgreen5000 am 14. Mär 2012 8:41, insgesamt 2-mal geändert.

Benutzeravatar
jochen
prolinux-forum-admin
Beiträge: 699
Registriert: 14. Jan 2000 15:37
Wohnort: Jülich
Kontaktdaten:

#2 Beitrag von jochen » 18. Jun 2006 18:39

:shock: ndiswrapper?!? Wasserkühlung?!?

Öhm... Wer weiss, vielleicht habe ich ja einen wichtigen Trend verschlafen. Aber NDIS steht für "Network Driver Interface Specification". Ich kann mir beim besten Willen nicht vorstellen, dass eine Wasserkühlung von PC wie eine Netzwerkkarte angesprochen wird...?

Nur weil man Windowstreiber für Netzwerkkarten mittels ndiswrapper mehr schlecht als recht zum laufen bringen kann, funktioniert das noch lange nicht mit allen Treibern jeglicher Art, die eine *.inf-Datei mitbringen.

Weiterhin: Wozu braucht man einen Treiber für die Kühlung? Pumpe an - Wasser läuft - Rechner wird gekühlt, oder nicht? Vielleicht, wenn der Rechner die Pumpleistung regeln soll, aber dann müsste man erst mal wissen, wie die zwei miteinander kommunzieren sollen.

Auf die Gefahr hin, mich hier als Nichtswisser in Sachen Wasserkühlung geoutet zu haben,
Jochen
Die grösste Lüge der EDV? "Mal eben..."

mrgreen5000
Beiträge: 8
Registriert: 15. Mai 2006 19:59

#3 Beitrag von mrgreen5000 » 19. Jun 2006 1:53

Aber NDIS steht für "Network Driver Interface Specification"
...dacht ich mir schon :cry:
Wozu braucht man einen Treiber für die Kühlung? Pumpe an - Wasser läuft
...jou stimmt schon. aber das Display welches ich habe wird mit kleinen Infos versorgt von der Pumpe und die wiederrum mit der Software und USB. Von daher wird sie unter Linux schon erkannt----nur als USV Gerät :oops:

petameta
prolinux-forum-admin
Beiträge: 1294
Registriert: 14. Feb 2003 13:19

#4 Beitrag von petameta » 19. Jun 2006 13:38

Als ersten Anhaltspunkt gucke doch mal, ob die Pumpe in irgendeiner Weise erkannt wird. Evtl. ist ja nen USB-seriell-Konverter oder sowas verbaut.

Dazu steck die Pumpe mal ein und gucke, was

- "tail -f /var/log/kern.log" in dem Moment des Einsteckens sagt.
- was lsusb -vv sagt.

mrgreen5000
Beiträge: 8
Registriert: 15. Mai 2006 19:59

#5 Beitrag von mrgreen5000 » 19. Jun 2006 18:34

Hm
Zuletzt geändert von mrgreen5000 am 14. Mär 2012 8:42, insgesamt 1-mal geändert.

petameta
prolinux-forum-admin
Beiträge: 1294
Registriert: 14. Feb 2003 13:19

#6 Beitrag von petameta » 19. Jun 2006 20:48

Die Ausgabe der Hardwareerkennung ist nicht sehr hilfreich, es sind zuwenig Informationen drin. Zudem wird's ja fälschlicherweise als USV erkannt.

Versuch's lieber mal mit den Befehlen, die ich Dir geschrieben habe: Zunächst machst Du ne Konsole auf, tippst dann "su" um Dich als root anzumelden. Als nächstes die Pumpe abziehen, den Befehl mit tail tippen und gucken, was beim einstecken so passiert. Das kannst Du hier mit copy&paste posten.

lsusb kannst Du nach dem "su" einfach so tippen (USB-Stecker muß drin sein).

mrgreen5000
Beiträge: 8
Registriert: 15. Mai 2006 19:59

#7 Beitrag von mrgreen5000 » 19. Jun 2006 23:48

Die Datei Kern.log gibts auf meinem Sys nicht.

mfg
mrgreen
Zuletzt geändert von mrgreen5000 am 14. Mär 2012 8:43, insgesamt 1-mal geändert.

petameta
prolinux-forum-admin
Beiträge: 1294
Registriert: 14. Feb 2003 13:19

#8 Beitrag von petameta » 20. Jun 2006 6:57

Der kern.log ist nicht so wichtig, die Ausgabe von lsusb muß reichen.

So nen Tip: Nimm code-tags anstatt quote, dann sieht's schöner aus:

Code: Alles auswählen

Bus 001 Device 003: ID 1267:b106 Logic3 / SpectraVideo plc
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0         8
  idVendor           0x1267 Logic3 / SpectraVideo plc
  idProduct          0xb106
  bcdDevice            1.02
  iManufacturer           1 asetek Inc ©2005
  iProduct                2 WaterChill® ChillControl (TM)
  iSerial                 3 506438200113
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           41
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0xa0
      Remote Wakeup
    MaxPower               50mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass         3 Human Interface Devices
      bInterfaceSubClass      0 No Subclass
      bInterfaceProtocol      0 None
      iInterface              4
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.10
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      52
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              10
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval             250
Das ist der interessante Teil.

Ich möchte Dir nicht zuviel Hoffnung machen: So ne Wasserkühlung ist nen ziemlich ausgefallenes Gerät, da gibt's nicht unbedingt Linux-Treiber zu. Allerdings gibt's schon Software, die Displays ansteuert. Wenn's also irgend nen Standardcontroller ist könnte man zumindest erstmal das Display ansteuern.

Also die Ausgabe sagt erstmal soviel nicht, leider. Zumindest läuft's wohl irgendwie als HID (Human Interface Device). Wo taucht die Pumpe denn im Gerätemanager unter Windows auf (also welcher Klasse von Geräten wird sie zugeordnet) ?

mrgreen5000
Beiträge: 8
Registriert: 15. Mai 2006 19:59

#9 Beitrag von mrgreen5000 » 21. Jun 2006 1:39

Bei Windows 1 genau das gleiche...
Zuletzt geändert von mrgreen5000 am 14. Mär 2012 8:43, insgesamt 1-mal geändert.

petameta
prolinux-forum-admin
Beiträge: 1294
Registriert: 14. Feb 2003 13:19

#10 Beitrag von petameta » 21. Jun 2006 7:28

Ist schon komisch daß das als HID läuft. Im lsusb-output steht was von "Logic3 / SpectraVideo". Die Firma hat ne Internet Seite, Logic 3 ist ne Produktreihe. Allerdings kommt man nur in nen Shop, weitere Infos gibt es nicht. Ich nehme mal an man hat dort nen Controller Chip eingekauft.

Weiteres probieren mit google und "linux logic 3 spectravideo" bringt z. B. diesen Thread. Dort gibt's um die VapoChill, allerdings ohne Erfolg.

Antworten