mausstick deaktivieren

Antworten
Nachricht
Autor
Jan_B87
Beiträge: 9
Registriert: 23. Jun 2006 21:47

mausstick deaktivieren

#1 Beitrag von Jan_B87 » 23. Jun 2006 21:51

ch hab ein dell latitude c610. die tastautur besitzt wie die Thinkpad Notebooks solch ein mausstick (keine ahnung wie das richtig heißt)
dummerweise hat das bei mir ein eigenleben entwickelt, wahrscheinlich ist da staub auf den kontakten und der cursor schießt immer über den ganzen desktop. weil ich sowieso nur das touchpad oder eine usbmaus benutze, wollte ich das ding aus der konfiguration des xservers nehmen. aber das steht nicht als einzelnes inputdevice drin... wie deaktiviere ich nun den mausstick?

ich hänge mal noch die konfigurtionsdatei an. ich hab auch etwas rumexperimentiert und imputdevices auskommentiert, habs aber nicht geschafft, den mausstick zu deaktivieren. ich hab meine tastatur auch mal auseinandergenommen und alles sauber gemacht - es hat nicht geholfen. der cursor macht noch immer was er will und rennt über den ganzen desktop. wäre nett, wenn mir jemand helfen könnte, denn so kann man echt nicht arbeiten... versucht mal so etwas anzuklicken :wink: könnte es sein, dass irgendein hotplug den mausstick einhängt?

ich bin verzweifelt. ich hab das ganze auch schon mal im ubuntu forum versucht, da konnte mir aber keiner weiterhelfen :
http://www.ubuntu-forum.de/artikel/1103 ... ieren.html



# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

#Section "InputDevice"
#Identifier "Configured Mouse"
#Driver "mouse"
#Option "CorePointer"
#Option "Device" "/dev/input/mice"
#Option "Protocol" "ExplorerPS/2"
#Option "ZAxisMapping" "4 5"
#Option "Emulate3Buttons" "true"
#EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

#Section "InputDevice"
#Driver "wacom"
#Identifier "stylus"
#Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
#Option "Type" "stylus"
#Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

#Section "InputDevice"
#Driver "wacom"
#Identifier "eraser"
#Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
#Option "Type" "eraser"
#Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

#Section "InputDevice"
#Driver "wacom"
#Identifier "cursor"
#Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
#Option "Type" "cursor"
#Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon Mobility M6 LY [Radeon Mobility 9000]"
Driver "ati"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon Mobility M6 LY [Radeon Mobility 9000]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
#InputDevice "Configured Mouse"
#InputDevice "stylus" "SendCoreEvents"
#InputDevice "cursor" "SendCoreEvents"
#InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Bild

petameta
prolinux-forum-admin
Beiträge: 1294
Registriert: 14. Feb 2003 13:19

#2 Beitrag von petameta » 25. Jun 2006 8:49

Soweit ich weiß sind die Dinger einfach als PS/2-Gerät angebunden. Versuch mal, die Sektion "Synaptics Touchpad" zu entfernen, die ja auf /dev/psaux zeigt.

Zudem wird direkt darüber /dev/input/mice benutzt. Ich bin mir nicht sicher, ob da das PS/2-Gerät mit drin ist, oder dies nur den Input von USB-Geräten liefert. Ändere es also evtl. mal in /dev/input/mouse0.

Edit: Letzteres ist ja eh schon auskommentiert, von daher dürfte es keinen Unterschied machen.

Benutzeravatar
Janka
Beiträge: 3585
Registriert: 11. Feb 2006 19:10

#3 Beitrag von Janka » 25. Jun 2006 15:28

Statt /dev/input/mice musst du /dev/input/mouseXYZ eintragen.
/dev/input/mice fasst *alle* Zeigergeräte als eines zusammen.

Welches mouseXYZ das richtige (externe Maus) ist, muss du ausprobieren.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Jan_B87
Beiträge: 9
Registriert: 23. Jun 2006 21:47

#4 Beitrag von Jan_B87 » 02. Jul 2006 10:45

also das bearbeiten der xorg.conf hat keinerlei auswirkungen. ich bekämpfe das problem an der wurzel. kennt sich jemand mit udev aus? ich hab eine config erstellt /etc/udev/rules.d/10-udev.rules die gefüttert werden möcht :) was muß ich tippen, damit udev den trackpointer nicht nach /dev/input einhängt?
danke für eure hilfe

Benutzeravatar
Janka
Beiträge: 3585
Registriert: 11. Feb 2006 19:10

#5 Beitrag von Janka » 03. Jul 2006 17:23

Wenn du die Mausgeräte nicht mittels /dev/mouseXYZ einzeln auslesen kannst sind diese per Hardware an denselben Port geschaltet. Dann kannst du gar nichts machen. An udev zu drehen ist unnötig und wird gar nichts bringen.

Mach bitte mal (in einer root-Textkonsole)

# init 3
# od /dev/input/mouse0
An den Mäusen ruckeln, gucken, welche es ist...
# od /dev/input/mouse1
An den Mäusen ruckeln, gucken, welche es ist...
etc.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Jan_B87
Beiträge: 9
Registriert: 23. Jun 2006 21:47

#6 Beitrag von Jan_B87 » 05. Jul 2006 20:05

Code: Alles auswählen

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/class/input/input0
H: Handlers=kbd event0
B: EV=120013
B: KEY=1007 2002000 4380207a f840d001 f2ffffdf ffefffff ffffffff ffffffff
B: MSC=10
B: LED=7

I: Bus=0010 Vendor=001f Product=0001 Version=0100
N: Name="PC Speaker"
P: Phys=isa0061/input0
S: Sysfs=/class/input/input1
H: Handlers=kbd event1
B: EV=40001
B: SND=6

I: Bus=0011 Vendor=0002 Product=0007 Version=0000
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/class/input/input2
H: Handlers=mouse0 event2 ts0
B: EV=b
B: KEY=6420 0 70000 0 0 0 0 0 0 0 0
B: ABS=11000003

I: Bus=0011 Vendor=0002 Product=000a Version=0000
N: Name="TPPS/2 IBM TrackPoint"
P: Phys=synaptics-pt/serio0/input0
S: Sysfs=/class/input/input3
H: Handlers=mouse1 event3 ts1
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3 

Benutzeravatar
Janka
Beiträge: 3585
Registriert: 11. Feb 2006 19:10

#7 Beitrag von Janka » 05. Jul 2006 21:14

Der Trackpoint sollte sich laut dieser Angabe an /dev/input/mouse1, das Touchpad hingegen an /dev/input/mouse0 finden lassen.

/dev/input/mouse0 als Maus sollte X also den Trackpoint ignorieren lassen. Wenn das nicht klappt, guck mal unter /var/log/Xorg.0.log nach, was da genau abgeht.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Antworten