Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Grub meldet Fehler während Installation :(

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Umstieg auf Linux
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Linux-Beginner
Gast





BeitragVerfasst am: 15. Jul 2006 19:39   Titel: Grub meldet Fehler während Installation :(

Hallo!

Ich bin ein absoluter Linux-Neuling und habe mir jetzt mal SUSE 10.1 für den Anfang neben WinXP Pro auf meiner S-ATA HD installiert. Es lief soweit eigentlich alles ganz gut, jedoch kam ich irgendwann mal auf die Idee unter Windows XP die Partitionsgrößer aller Partitionen (inkl. der Ext3-Partitionen) mit Partition Magic zu ändern.
Nach einem Neustart erschien dann jedoch statt dem blauen Grub-Menü nur noch Grub in Kommandozeilenform mit der Bemerkung "bash-link line editing" oder so ähnlich.
Nunja da ich damit erstmal nichts anfangen konnte, habe ich den MBR mithilfe der WinXP CD-ROM neu geschrieben.
Dann habe ich das Linux-System über die SUSE-DVD gebootet und woltle über Yast Grub neu installieren, ich habe also alles konfiguriert gehabt wie es vorher war und habe auf Beenden geklickt.
Jedoch bringt er mir dann eine Fehlermeldung, dass etwas bei der Installation von Grub nicht geklappt hat und zwar steht dort
"Error 17: cannot mount the selected drive" glaube ich, jedenfalls dass er die Partition in wessen MBR Grub geschrieben werden, nicht mounten kann (es steht hd0 dort)

Noch ein paar Angaben zu der Festplatte:
-160GB Kapazität
-sda1=primäre NTFS-Partition (Systempartition für Win)
-sda5-sda8=4 weitere logische NTFS-Partitionen (Win)
-sda9=Linux Ext3-Partition (Mountpoint "/")
-sda10=SWAP-Partition
-sda11=Ext3-Partition (Mountpoint "/home")

Ich weiß leider nicht mehr weiter, was ich jetzt noch tun soll um den Bootloader wieder richtig zu installieren.
Ich habe es auch schon mit Lilo versucht, aber da kommt ein ähnlicher Fehler, dass er kein Zugriff auf eine Partition hat.

Ich hoffe ihr könnt mir vielleicht helfen
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 15. Jul 2006 20:38   Titel:

Das /-Dateisystem aus einem Rettungssystem (CD) heraus von Hand mounten geht aber noch?

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Linux-Beginner
Gast





BeitragVerfasst am: 15. Jul 2006 21:02   Titel:

Ja, das ist noch möglich, er mountet es ja beim Systemstart selbst wie ich das so sehe, ich kann ja dann auch darauf zugreifen und die Dateien lesen.

Ich habe jetzt irgendwo gelesen, dass Grub nicht damit zurecht kommt, wenn die Partition in wessen MBR er geschrieben werden soll, über 128GB "entfernt" von der Linux-System-Partition liegt. Das ist bei mir der Fall, die Linux Systempartition beginnt erst ab Sektoren die "hinter" 135GB liegen glaube ich.
Ich werde es mal probieren die Partition zu veschieben, hoffentlich klappt es Smile[/b]
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Umstieg auf Linux Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy