Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
VMWare Fehlermeldung (SuSE 10.1)

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
BeTonToD



Anmeldungsdatum: 17.04.2006
Beiträge: 78
Wohnort: Karlsruhe

BeitragVerfasst am: 29. Jul 2006 20:59   Titel: VMWare Fehlermeldung (SuSE 10.1)

Hallo,
Ich hab ein kleines Problem:
ich bekomme folgende Fehlermeldung:
Code:

make[4]: *** [/tmp/vmware-config3/vmmon-only/linux/driver.o] Fehler 1
make[3]: *** [_module_/tmp/vmware-config3/vmmon-only] Fehler 2
make[2]: *** [modules] Fehler 2
make[1]: *** [modules] Fehler 2
make[1]: Leaving directory `/usr/src/linux-2.6.16.13-4-obj/i386/smp'
make: *** [vmmon.ko] Fehler 2
make: Leaving directory `/tmp/vmware-config3/vmmon-only'
Unable to build the vmmon module.



bei der installation.
Ich hab auch schon den patch und die kernel sources installiert... klappt trozdem net..

-----Details-----------------
Suse 10.1
VMWare Workstation 5.5.1-19175
patch: 102
(hoffe des is alles^^)
----------------------------------

hoffe auf hilfe...

MFG BeTonToD
_________________
Ich hatte probleme bei Windows.....
.....jetzt hab ich sie bei Linux Wink
 
Benutzer-Profile anzeigen Private Nachricht senden

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 29. Jul 2006 21:03   Titel:

Welche Version von vmware und welchen Kernel benutzt Du ? Was meinst Du mit Patch ?

Probier's mal mit vmware any (meintest Du das mit Patch ?). Das Archiv entpacken und das Skript runme.pl ausführen.
 
Benutzer-Profile anzeigen Private Nachricht senden

BeTonToD



Anmeldungsdatum: 17.04.2006
Beiträge: 78
Wohnort: Karlsruhe

BeitragVerfasst am: 29. Jul 2006 23:03   Titel:

Danke,
ja den patch mein (sorry)...
die version vom VMware workstation hab ich doch rein geschrieben..
kernel:? (wie ist der befehl nochmal...)
diese runme.pl hab ich auch schon ausprobiert (von diesem any-patch)

MFG BeTonToD
_________________
Ich hatte probleme bei Windows.....
.....jetzt hab ich sie bei Linux Wink
 
Benutzer-Profile anzeigen Private Nachricht senden

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 30. Jul 2006 8:23   Titel:

BeTonToD hat folgendes geschrieben::
die version vom VMware workstation hab ich doch rein geschrieben..


Jo stimmt :-)

BeTonToD hat folgendes geschrieben::
kernel:? (wie ist der befehl nochmal...)


uname -r
 
Benutzer-Profile anzeigen Private Nachricht senden

G. W.



Anmeldungsdatum: 31.05.2006
Beiträge: 54

BeitragVerfasst am: 30. Jul 2006 9:01   Titel: Re: VMWare Fehlermeldung (SuSE 10.1)

BeTonToD hat folgendes geschrieben::
Code:
make[4]: *** [/tmp/vmware-config3/vmmon-only/linux/driver.o] Fehler 1
make[3]: *** [_module_/tmp/vmware-config3/vmmon-only] Fehler 2
make[2]: *** [modules] Fehler 2
make[1]: *** [modules] Fehler 2
make[1]: Leaving directory `/usr/src/linux-2.6.16.13-4-obj/i386/smp'
make: *** [vmmon.ko] Fehler 2
make: Leaving directory `/tmp/vmware-config3/vmmon-only'
Unable to build the vmmon module.

Das ist genau der Teil der Fehlermeldung, der am wenigsten über das Problem aussagt.

Poste die Fehlermeldung doch bitte einfach nochmal, diesmal ab dem und einschließlich des letzten gcc-Aufrufs.

Die Meldungen oben kommen nur von make und sind zuwenig.
 
Benutzer-Profile anzeigen Private Nachricht senden

BeTonToD



Anmeldungsdatum: 17.04.2006
Beiträge: 78
Wohnort: Karlsruhe

BeitragVerfasst am: 30. Jul 2006 9:38   Titel:

Code:
Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel.  Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes] y

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.16.13-4-smp/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config4/vmmon-only'
make -C /lib/modules/2.6.16.13-4-smp/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.16.13-4-obj/i386/smp'
make -C ../../../linux-2.6.16.13-4 O=../linux-2.6.16.13-4-obj/i386/smp modules
  CC [M]  /tmp/vmware-config4/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config4/vmmon-only/linux/driver.h:20,
                 from /tmp/vmware-config4/vmmon-only/linux/driver.c:49:
/tmp/vmware-config4/vmmon-only/./include/compat_wait.h:37:5: warning: "VMW_HAVE_EPOLL" is not defined
/tmp/vmware-config4/vmmon-only/./include/compat_wait.h:43:5: warning: "VMW_HAVE_EPOLL" is not defined
In file included from /tmp/vmware-config4/vmmon-only/linux/driver.h:20,
                 from /tmp/vmware-config4/vmmon-only/linux/driver.c:49:
/tmp/vmware-config4/vmmon-only/./include/compat_wait.h:60: error: conflicting types for ‘poll_initwait’
/usr/src/linux-2.6.16.13-4/include/linux/poll.h:45: error: previous declaration of ‘poll_initwait’ was here
/tmp/vmware-config4/vmmon-only/linux/driver.c:145: warning: initialization from incompatible pointer type
/tmp/vmware-config4/vmmon-only/linux/driver.c:149: warning: initialization from incompatible pointer type
make[4]: *** [/tmp/vmware-config4/vmmon-only/linux/driver.o] Fehler 1
make[3]: *** [_module_/tmp/vmware-config4/vmmon-only] Fehler 2
make[2]: *** [modules] Fehler 2
make[1]: *** [modules] Fehler 2
make[1]: Leaving directory `/usr/src/linux-2.6.16.13-4-obj/i386/smp'
make: *** [vmmon.ko] Fehler 2
make: Leaving directory `/tmp/vmware-config4/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.


und hier noch die kernel version: 2.6.16.13-4-smp
_________________
Ich hatte probleme bei Windows.....
.....jetzt hab ich sie bei Linux Wink
 
Benutzer-Profile anzeigen Private Nachricht senden

demon
Pro-Linux


Anmeldungsdatum: 24.11.1999
Beiträge: 389
Wohnort: Wörth am Rhein

BeitragVerfasst am: 01. Aug 2006 15:11   Titel:

Hallo,

es verwundert ein wenig, denn der Patch sollte eigentlich das Problem lösen. Dazu folgende Vorgehensweise:

- Patch entpacken
- Im vmware-Verzeichnis nach der Datei vmmon.tar suchen (alternativ im /usr-Verzeichnis, wenn Du nicht weisst, wo die Datei liegt: find . -name vmmon.tar)
- Datei vmmon.tar durch die aus dem Patch ersetzen
- Danach die Datei vmnet.tar suchen und auch ersetzen
- Zum Schluss noch ein mal das vmwaresetup-Script ausführen

Gruss,
demon
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

BeTonToD



Anmeldungsdatum: 17.04.2006
Beiträge: 78
Wohnort: Karlsruhe

BeitragVerfasst am: 07. Aug 2006 1:49   Titel:

(sorry das ich so spät antworte...)
Wenn ich diesen befehl ausfürher findet er keine Datei und bei den anderen sachen find ich auch nix...
Kannst du mir bitte den genauen Ort sagen wo das VMware-Verzeichnis liegt?

trozdem vielen dank...
MFG BeTonToD
_________________
Ich hatte probleme bei Windows.....
.....jetzt hab ich sie bei Linux Wink
 
Benutzer-Profile anzeigen Private Nachricht senden

rbtux



Anmeldungsdatum: 23.06.2004
Beiträge: 69

BeitragVerfasst am: 07. Aug 2006 9:33   Titel:

hallo

wo das ding liegt kann ich dir nicht sagen aber ersetz doch mal den . durch ein / im find befehl.
_________________
Computer führen dazu, dass man die alten Fehler jetzt 100 mal schneller macht Wink
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

BeTonToD



Anmeldungsdatum: 17.04.2006
Beiträge: 78
Wohnort: Karlsruhe

BeitragVerfasst am: 07. Aug 2006 12:40   Titel:

Es geht!!!
Ich hab mir das neue vmware-any-any-update runtergeladen es damit versucht und es gieng!!!
Übrigens das mit diesem "find" befehl klappt irgendiwe immer noch nicht sorichtig Very Happy

gruß BeTonToD
_________________
Ich hatte probleme bei Windows.....
.....jetzt hab ich sie bei Linux Wink
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy