Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Hilfe bei Samba benötigt mit opensuse 10.0

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Skymaster



Anmeldungsdatum: 03.01.2006
Beiträge: 8

BeitragVerfasst am: 07. Aug 2006 14:31   Titel: Hilfe bei Samba benötigt mit opensuse 10.0

Hi, ich brauche mal Hilfe bei Samba.

Ich habe mir schon einiges an Beiträgen und Howto gelesen, aber irgendwie komme ich nicht weiter!
Systeme:1. opensuse 10.0 Samba 3.0.x , Firewall erstmal abgschaltet zum Probieren
2. Windows XP

Ich habe mit Yast den Samba Server eingerichtet.
rootpasswort für samba wurde abgefragt und vergeben.
Der Domiancontroller ist PDC gesetzt.
Die backend smbpasswd ist munlop gesetzt.
Hier die smb.conf:

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2006-07-11
[global]
workgroup = TUX-NET
printcap name = cups
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = Yes
domain master = Yes
netbios name = Klaus
passdb backend = smbpasswd:munlop
winbind gid = 10000-20000
winbind uid = 10000-20000
os level = 65
preferred master = Yes
idmap gid = 10000-20000
idmap uid = 10000-20000
local master = Yes
security = user

[homes]
comment = Home Directories
valid users = %S
read only = No
inherit acls = Yes

[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700

[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
write list = root

Die smbpasswd:

# This file is the authentication source for Samba if 'passdb backend' is set
# to 'smbpasswd' and 'encrypt passwords' is 'Yes' in the [global] section of
# /etc/samba/smb.conf
#
# See section 'passdb backend' and 'encrypt passwords' in the manual page of
# smb.conf for more information.
chrissi:1001:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU ]:LCT-00000000:
nobody:65534:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:[DU ]:LCT-00000000:

Die smbusers:

# This file allows you to map usernames from the clients to the server.
# Unix_name = SMB_name1 SMB_name2 ...
#
# See section 'username map' in the manual page of smb.conf for more
# information.

root = administrator
;nobody = guest pcguest smbguest

So jetzt zu den Problemen:
1. chrissi habe ich als user in die smbpasswd nachgetragen durch die Konsole, sollte der Nutzer nicht auch in der smbuser stehen?
2. Die Freigaben werden auf XP erkannt! Jedoch egal was ich bei der Benutzerabfrage und Passwort eingebe, es funktioniert nicht! Weder chrissi noch root! (Sollte der root nicht auch in der smbpasswd stehen?)
3. Wenn ich das Homesverzeichnis anklicke sagt er mir, dass es nicht da ist.

Windows Xp Freigaben kann ich ohne Probleme zugreifen! Nur halt nicht von Windows Xp auf die Linuxfreigaben! Grundsätzlich möchte eigentlich nur vom Xp-Rechner auf das /home/Documents von chrissi zugreifen.

Hoffe, Ihr könnt mir mal helfen!?

Gruß Klaus
 
Benutzer-Profile anzeigen Private Nachricht senden

sumsi
Gast





BeitragVerfasst am: 07. Aug 2006 18:27   Titel: conf

Hallo,

die smb.conf sieht aus, als wäre die mit einem Tool verunstaltet.
Die machen meistens mist.

Lösch die und lege sie einfach p.a.p. munaell lt. Lehrbuch an.
Diese muss nicht gross werden, um zu funktinieren Smile

bye sumsi
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 07. Aug 2006 19:10   Titel:

Sollten da tatsächlich XXXXX in der smbpasswd stehen, hast du noch kein Kennwort für diesen Benutzer gesetzt. Vermutlich wurden sie mit "smbpasswd -ae Username" angelegt, das ergibt dieses Ergebnis.

Du hast nun die Wahl, den Benutzern ein Kennwort zu geben: "smbpasswd Username", oder "null passwords = yes" in die smb.conf zu schreiben.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Skymaster



Anmeldungsdatum: 03.01.2006
Beiträge: 8

BeitragVerfasst am: 07. Aug 2006 20:22   Titel:

Danke für die Hilfe!

Ich habe erstmal mit dem Yast die Authentifikation smbpasswd-Datei den Wert munlop wieder gelöscht!
Dann noch folgendes:
[global]
passdb backend = smbpasswd:munlop (alt)
passdb backend = smbpasswd (neu)

Irgendwie hat der immer eine Datei mit dem Namen munlop angelegt und dort bei smbpasswd -ae usernamen diesen dort reingeschrieben! Habe also alle Dateien Namens Munlop gelöscht!

Dann habe ich den Tip von Janka genutzt und erstmal den Usern ein passwort verpasst, denn das xxxx war wirklich so wie von janka beschrieben! So einfach ist die Löschung! Ich könnte mich dafür selber eine Hauen! Laughing

Jetzt läuft es! Die Nutzer können sich in ihr eigenes Verzeichnis einloggen, also auch von Windows XP aus!

Mal ne Frage so allgemein! Ist das so jetzt auch einiger Maßen sicher?

Gruß Klaus

und danke
 
Benutzer-Profile anzeigen Private Nachricht senden

Skymaster



Anmeldungsdatum: 03.01.2006
Beiträge: 8

BeitragVerfasst am: 07. Aug 2006 21:07   Titel:

Zu früh gefreut! Sad

Der Smb-Client unter Linux macht es, aber Xp auf dem anderen will es doch nicht! *grrrrr
Dacht wenn es smb-client unter lInux macht wird XP es auch machen! Naja ich suche weiter nach dem Fehler!
Ich vermute es liegt an XP!?
Ich suche weiter!
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 07. Aug 2006 22:12   Titel:

MS-Windows XP Home oder Professional?

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Skymaster



Anmeldungsdatum: 03.01.2006
Beiträge: 8

BeitragVerfasst am: 07. Aug 2006 23:13   Titel:

Problem hat sich erledigt! War zwischen den Kopfhörern! Muss bei der smb.conf natürlich auch die Nutzer auf XP mit gleichem Namen und Passwort einrichten, dann greift auch XP auf die richtigen Ordner zu!

Ich habe jetzt die Nutzer einmal auf der Suse eingerichtet, dann bei Samba und bei XP. Jetzt können die XP - Nutzer auf ihre Ordner auf der Suse zugreifen, die anderen Nutzer-Ornder zwar einsehen, aber die Daten nicht öffenen, außer ich gebe die Ordner dafür frei! Wink

Es ist XP-Prof

Jetzt läuft es aber wirklich gut!!!!!

Gruß Klaus
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy