Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
internet - router

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
rObYYY
Gast





BeitragVerfasst am: 09. Aug 2006 13:21   Titel: internet - router

Hallo,
ich bin vor einigen tagen auf Linux umgestiegen.
Da ich vorher nur mit Windows meine Erfahrungen gemacht habe, und jez vor einem größeren für mich unlogischem Problem stehe wollte ich euch mal um Hilfe beten.

Also,
ich benutze Suse 10.1, habe eine onboard netzwerkkarte und einen router.
Der router läuft über dhcp so habe ich auch mein linux über Yast configuriert.

Am anfang lief erstmal garnichts doch mitleirweile komme ich auf 2-3 seiten.
es funktionieren unteranderem kayl.de egocrew.de. Diese Seiten brauchen besimmt 2min für den seitenaufbau wo imgegegen mein 2. windows pc nur ein paar sec braucht.

Seiten wie google.de funktionieren garnicht, es kommt ledeglich eine kleine fehlermeldung in der steht:

"Probieren sie evtl statt ww.google.de , www.google.de"
etwas in dieser art.

Ich habe dann mal ei bisschen rumprobiert und die console geöfnet.
Ping novell.de
er fängt sofort an zu pingen aber wenn ich dann mal ping web.de etc eingebe braucht er erstmal 15sec bevor er ping und dan kommt der Text : "(212.72.195.42)56(84)Files of Data" und danach pingt er erst.

diese seite baut er trotzdem nicht im firefox auf der bei suse dabei ist.

Ich hoffe ihr habt meine frage verstanden Smile auch wenn sie sehr schwer und evtl doof gestellt ist.

Mit freundlichen Grüßen
Robert S.
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 09. Aug 2006 18:27   Titel:

Das fühlt sich an, als ob dein Rechner nicht den richtigen Nameserver mitbekommt. Versuche mal, die IP-Adresse des Routers als Nameserver (über YaST) einzutragen, statt die Nameserver-Adresse über DHCP zu beziehen.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

rObYYY
Gast





BeitragVerfasst am: 09. Aug 2006 18:39   Titel:

danke erstmal,
hat aber leider nichts verändert.
Ich verstehe nicht, dass nicht alle inet seiten funktionieren und einige schnell und andere sehr sehr langsarm.

zB. pro-linux.de braucht lange zum laden doch wenn man einmal drauf ist und dann die site switched zb forum post geht es sehr schnell Sad ich bin echt am verzeifeln
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 10. Aug 2006 12:25   Titel:

Das hängt damit zusammen, dass SuSE einen DNS-Cache einrichtet. Wenn er die IP-Adresse eines Servers erst einmal kennt, muss er weitere Anfragen nicht mehr an den (hier unzuverlässigen) Nameserver im Router richten.

Versuch' mal folgende Nameserver

195.20.224.234
194.25.2.129
194.8.57.8

direkt mit "dig @Nameserver-IP www.pro-linux.de" abzufragen. Wenn du bei zumindest einem dieser Server eine "ANSWER SECTION" zurückbekommst, trag' diesen Rechner als Nameserver ein.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

rObYYY
Gast





BeitragVerfasst am: 10. Aug 2006 13:53   Titel:

Danke ich habe das mit allen 3 ips gemacht und es hat funktioniert!

als ersten namenserver habe ich 192.168.0.1 (ip des routers) eingetragen
die 3 anderen sind
195.20.224.234
194.25.2.129
194.8.57.8

und jez geht jede inet site! Danke Laughing Laughing Laughing Laughing

Dennoch nicht so sher schnell gibt es da noch einstellungen die das beschleinigen?
und kannst du mir evtl sagen warum genau das jez mit den einstellungen funktioniert?

Mit freundlichen Grüßen
Robert S
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 10. Aug 2006 21:17   Titel:

Prüfe es mit "dig" wie oben beschrieben nach. Es befindet sich im Paket bind-utils, falls du es noch nicht installiert hast.

Den Router nimmst du am besten aus der Liste raus raus, da er ja nicht zuverlässig antwortet -- das sorgt für die immer noch vorhandenen Verzögerungen.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

rObYYY
Gast





BeitragVerfasst am: 11. Aug 2006 8:14   Titel:

;; reply from unexpected source: 217.237.149.161#53, expected 192.168.0.1#53

; <<>> DiG 9.3.2 <<>>
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14042
;; flags: qr rd ra; QUERY: 1, ANSWER: 13, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;. IN NS

;; ANSWER SECTION:
. 15259 IN NS J.ROOT-SERVERS.NET.
. 15259 IN NS K.ROOT-SERVERS.NET.
. 15259 IN NS L.ROOT-SERVERS.NET.
. 15259 IN NS M.ROOT-SERVERS.NET.
. 15259 IN NS A.ROOT-SERVERS.NET.
. 15259 IN NS B.ROOT-SERVERS.NET.
. 15259 IN NS C.ROOT-SERVERS.NET.
. 15259 IN NS D.ROOT-SERVERS.NET.
. 15259 IN NS E.ROOT-SERVERS.NET.
. 15259 IN NS F.ROOT-SERVERS.NET.
. 15259 IN NS G.ROOT-SERVERS.NET.
. 15259 IN NS H.ROOT-SERVERS.NET.
. 15259 IN NS I.ROOT-SERVERS.NET.

;; Query time: 61 msec
;; SERVER: 194.25.2.129#53(194.25.2.129)
;; WHEN: Fri Aug 11 09:13:17 2006
;; MSG SIZE rcvd: 228


Das habe ich was sollich rausnehmen etc?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 11. Aug 2006 9:40   Titel:

Zitat:
; reply from unexpected source: 217.237.149.161#53, expected 192.168.0.1#53

Igitt, was ist das?!

Anstatt einen eigenen DNS-Server/DNS-Proxy bietet der Router nur an, Anfragen an den vom Provider vorgegebenen DNS-Server weiterzuleiten. Dabei hat der Routerhersteller aber übersehen, dass die IP-Adresse der Antwortpakete natürlich auch wieder umgeschrieben werden muss.

So ist das Müll, und funzt auch mit MS-Windows nur mit bestimmten ServicePack-Versionen. DNS-Antworten von beliebigen Adressen entgegenzunehmen ist nämlich ein hübsches Sicherheitsleck, da dort ja ein böser Bube sitzen könnte, der eine Bankwebseite nachbaut und dann die DNS-Enträge auf *seinen* Server zeigen lässt (das ist schon passiert!). Sowas ist im Browser nicht zu erkennen.

Nimm den Router aus der Liste raus und trag stattdessen 217.237.149.161 (das ist der Nameserver deines Providers) ein.

Der Router ist Mist und gehört dem Hersteller tief in dessen Hinterteil geschoben.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

rObYYY
Gast





BeitragVerfasst am: 11. Aug 2006 10:56   Titel:

Vielen dank Wink

Nun läuft es sehr gut und schnell
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy