Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Kanotix - Probleme mit Grub - kann MSDOS, BeOS und WIN98SE nicht starten

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Umstieg auf Linux
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Ottonang



Anmeldungsdatum: 18.08.2006
Beiträge: 10

BeitragVerfasst am: 18. Aug 2006 6:41   Titel: Kanotix - Probleme mit Grub - kann MSDOS, BeOS und WIN98SE nicht starten

Hallo, bin neu hier.

Habe bei mir auf einem älteren PC die aktuelle Kanotix-Version auf hdb9 installiert.
Den Grub habe ich im MBR installieren lassen.

hda1 ist eine primäre FAT-Partition 700 MB mit MSDOS6.22
hda2 ist eine primäre FAT32-Partition 3 GB mit BeOS
hda3 ist eine primäre FAT32-Partition 3 GB mit WIN98SE+
hda4 ist eine primäre NTFS-Partition 12 GB mit W2KSP4++
hdb1 bis hdb8 sind FAT-Partitionen (Daten und so)
hdb9 ist eine Reiser-FS-Partition mit Kanotix
hdb10 ist Linux-Swap

Der Grub zeigt mir ein komplettes Auswahlmenü an, wenn auch mit namentlich fehlerhaften Einträgen.
Das Problem ist: derzeit kann ich leider nur W2K und Kanotix mittels Grub starten!
- wähle ich das BS auf der hda1 Partition aus, dann erscheint nach wenigen Sekunden die Anzeige "Starten von MS-DOS ... ", ein Cursor blinkt und die Kiste ist fest
- wähle ich hda2 aus, blinkt kurz darauf ein Cursor und die Kiste ist fest
- wähle ich hda3 aus, erscheint der Hinweis auf eine fehlerhafte "Config.sys" und ich soll am "amerikanischen" Prompt den Weg zur Command.com eingeben (die Angaben in der Config.sys sind aber alle richtig)
- wähle ich hda4 aus, dann bootet W2K sauber und richtig
Kanotix kann ich natürlich auch booten (aber so richtig glücklich bin ich mit dem Kanotix übrigens nicht ...)

Ich möchte dazu noch ergänzen das laut "cat" in der Grub-"menu.lst"-Datei bei allen 4 BS auf der hda "makeactive" und "chainloader +1" drin steht. Aber es gibt folgenden
Unterschied (Auszug):

tittle Windows 95/98/Me (hda3)
root (hd0,2)
makeactice
chainloader +1
tittle Windows2K/XP/2003 (hda4)
chainloader (hd0,3) +1

Nun läst sich ja W2K auf hda4 starten, WIN98SE auf hda3 nicht ... . Crying or Very sad
ich habe auch schon vor der "Root"-Zeile mit temporären und logisch sinnvollen "hide" und "unhide"-Einträgen für hd0,0 bis hd0,3 getestet, aber auch das leider ohne Erfolg.
Irgendwie scheint der vom "chainloader" gewiesene Weg ungünstig zu sein Wink

Ich suche also die ultimativen Tipps, wie ich die Betriebssysteme auf hda1 bis hda3 wieder bootfähig bekomme - also via Grub starten kann - und wie ich die Anzeige für den Grub editieren kann, also wie ich die Datei "menu.lst" editieren kann.

Und vielleicht hat auch gleich noch einer den ultimativen Tip für eine schmale, schnelle Distri, welche für die Kiste bestehend aus einem ASUS XP55T2P4 mit AMD K6-III 400 und 128 MB EDO RAM, samt PCI Geforce2MX100, SB128PCI, D-Link DFE-Netzwerkkarte, IBM DPTA 20 GB und DJNA 15 GB sowie LG Combolaufwerk gut geeignet ist. Internet per Netzwerk, aber ohne DHCP. Ich muß nämlich das W2K runternehmen, weil ich die Lizenz für ein Notebook brauche, auf welchem weder Knoppix, noch Kanotix noch DSLinux nutzbar sind (ein DELL Latitude CPx von anno 2000). Auch rumliegende SuSE-Linix 6.4, 7.1 und Caldera Open Linux für Desktop 2.4 funktionieren leider nicht auf dem oben beschriebenen Desktop PC, das der G2MX Chipsatz der Grafikkarte denen zu neu ist.

So, nun hoffe ich auf Erleuchtung und "ultimative" Tips Smile

Danke

MfG
Ottonang
PS:
- solange ich das W2K noch nutzen kann, kann ich ja noch Distris saugen und die ISO für die Install brennen. Denn wie das Brennen unter Linux geht, dazu habe ich bisher absolut keinen blassen Dunst.
- ich hatte vorher im MBR den "Bootcommander" von V-Communications "zu sitzen", die
Software war dabei in der 1. prim Part also auf MSDOS installiert damit konnte ich bequem per Tastatur die Boot-Auswahl treffen
den Grub kennt diese alte Software leider nicht und war daher unfähig via Grub auf der Linux Partition das Kanotix zu booten, so machte ich dann eine Neuinstall mit dem Grub in den MBR und kann nun MSDOS, BeOS und WIN98SE nicht mehr booten Crying or Very sad
 
Benutzer-Profile anzeigen Private Nachricht senden

sumsi
Gast





BeitragVerfasst am: 19. Aug 2006 10:11   Titel: antwort

Hallo,

Grub-Syntax für 2x Window$:

title windows
hide (hd0,1)
unhide (hd0,0)
root (hd0,0)
makeactive
chainloader +1

title windows_2
hide (hd0,0)
unhide (hd0,1)
root (hd0,1)
makeactive
chainloader +1

nachzulesen bei:
http://de.opensuse.org/SDB:Mehrere_Windows-Installationen_von_einer_Festplatte_booten

Muss'te jetzt nur noch an Deine Partitionen angleichen.
Bzw. deinen Eintrag hide/unhide hinzufügen, so das die andere Windowspartition immer versteckt wird.

> Denn wie das Brennen unter Linux geht, dazu habe ich bisher absolut keinen blassen Dunst.
Musst k3b aufrufen und denken, "diss is 'n Nero" Wink

Viel Spass
sumsi
 

Ottonang



Anmeldungsdatum: 18.08.2006
Beiträge: 10

BeitragVerfasst am: 19. Aug 2006 11:25   Titel:

Ich zitiere mal aus meinem eigenen Beitrag:
Zitat:
ich habe auch schon vor der "Root"-Zeile mit temporären und logisch sinnvollen "hide" und "unhide"-Einträgen für hd0,0 bis hd0,3 getestet, aber auch das leider ohne Erfolg.

....
Zur Erläuterung: ich habe ja defakto 4 mal "eine Dose", deshalb auch hd0,0 bis hd0,3 und deshalb hatte ich dann auch gleich jeweils 3 unhide und 1 hide Eintrag drin. Aber bei der Nutzung von "Escape" und "e", "o" und Co bleibt das alles halt nur temporär drin. Wie ich die oben genannte Datei bei gebooteten Linux am Prompt wirklich editieren kann, weiß ich auch noch immer nicht.

MfG
Ottonang
PS: Nero kenne ich auch nicht - ich kenne bisher bloß WinOnCD 3.6 OEM auf WIN95a Wink
 
Benutzer-Profile anzeigen Private Nachricht senden

Ottonang



Anmeldungsdatum: 18.08.2006
Beiträge: 10

BeitragVerfasst am: 21. Aug 2006 7:10   Titel: es hat sich erledigt

Ursache: der Grub aus der HD-Install von Knoppix hatte mir den MBR der hda ziemlich zerschossen.
*
Hatte beim Probieren danach mit Kanotix, Ubunto 5.10 und Kubuntu 5.10 immer das selbe Fehlerbild mit den gleichartigen Einträgen in den bekannten Datei menu.lst.
Also habe ich mal den PC von bootfähigen Disketten mit MSDOS 6.22 bzw. WIN98SE gebootet und fdisk /mbr ausgeführt. Damit konnte ich dann zumindest hda2 und hda3 wieder bootfähig herstellen und nach dem Aktiv setzen der Partition auch wieder richtig booten. Nach einer erneuten Installation von Kubuntu 5.10 war dann aus dessen nun wieder neu installierten Grub das Booten von BeOS und WIN98SE wie auch W2K nun problemlos möglich, allerdings sah nun auch die menu.lst etwas anders aus.

Habe dann nochmals die aktuelle Knoppix CD-Version mit sudo knippix-installer installiert, wo mir dessen Grub wieder den MBR auf der hda zerschoß. Das Problem hat der Grub aus dem aktuellen Knoppix aber schienbar nur, wenn auf der hda 4 primäre Partitonen vorhanden sind.

So, nun muß ich noch die total zerschossene hda1 Partition neu installieren und dann könnte mein o.g. PC so funktionieren, wie ich das auch wartet habe. Wenn auch mit Ubuntu, welches nicht von daheim mit Applikationen so heillos überfrachtet ist, als das wiederum für Servicezwecke hervorragend geeignete Knoppix.

MfG + Danke
Ottonang
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Umstieg auf Linux Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy