Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
RPMs können nicht installiert werden...

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
slin



Anmeldungsdatum: 24.07.2006
Beiträge: 8

BeitragVerfasst am: 21. Aug 2006 13:15   Titel: RPMs können nicht installiert werden...

hallo erst mal...

also mein problem ist follgendes... ich habe mir cedega gedownloaded (als rpm) und will dies nun installieren... so weit so gut, aber wenn ich es installieren will kommt follgende fehlermeldung:

/home/nils/cedega-small-5.2.3-1.i386.rpm is not available or fully up to date


wie kann ich diesen fehler beheben??

danke schon mal
slin

edit: wie bekomme ich bilder in mein thema?? Embarassed
 
Benutzer-Profile anzeigen Private Nachricht senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 21. Aug 2006 13:54   Titel:

Hallo slin

1. Wie war denn die genaue Syntax deines rpm-Aufrufs? Liegt die zu installierende rpm-Datei im aktuellen Verzeichnis? Falls ja, dann versuche mal
Code:
rpm -Uhv ./<Datei>.rpm


2. Um zu schauen, ob es Sinn macht, das besagte Paket überhaupt aktualisieren zu wollen, hilft die Abfrage
Code:
rpm -qi cedega-small


Frohes Schaffen
Lothar
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

slin



Anmeldungsdatum: 24.07.2006
Beiträge: 8

BeitragVerfasst am: 21. Aug 2006 14:12   Titel:

so habe den oderen befehl eingegeben und dann kam dieses hier:
error: Failed dependencies:
pygtk2 >= 2.6 is needed by cedega-small-5.2.3-1.i386
dbus-python is needed by cedega-small-5.2.3-1.i386


Question

habe dann bei yast nach python geschaut und gesehen, dass ich dbus-1-python schon habe und pygtk2 gab es gar nicht.... Question
 
Benutzer-Profile anzeigen Private Nachricht senden

lotharb



Anmeldungsdatum: 10.02.2002
Beiträge: 411
Wohnort: Heroldsberg (ERH)

BeitragVerfasst am: 21. Aug 2006 14:39   Titel:

OK, es liegt also an unerfüllten Abhängigkeiten...

'dbus-1-python' ist u.U. was anderes als 'dbus-python'. Da musst du halt nochmal genau hingucken.

Betreffend 'pygtk2' musst du vermutlich eigene Nachforschungen anstellen. Meine eigenen bevorzugten Anlaufstellen in solchen Situationen sind die hier:
http://rpmseek.com/index.html?hl=de
http://packman.links2linux.de/
http://rpm.pbone.net/
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

slin



Anmeldungsdatum: 24.07.2006
Beiträge: 8

BeitragVerfasst am: 21. Aug 2006 15:05   Titel:

danke hat sich erledigt...

ich sag nur das nächste mal besser hinschauen!!! hatte die falsche rpm erwischt Embarassed

trozdem danke
 
Benutzer-Profile anzeigen Private Nachricht senden

G. W.



Anmeldungsdatum: 31.05.2006
Beiträge: 54

BeitragVerfasst am: 22. Aug 2006 19:01   Titel:

Genau so sieht's aus...

Solche Fehlermeldungen über angeblich nicht installierte Abhängigkeiten, die unter anderem Namen doch installiert sind, bedeuten immer, dass das zu installierende Paket nicht das richtige ist.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy