Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Namensauflösung im lokalen Netzwerk funktioniert nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
kolAflash



Anmeldungsdatum: 08.09.2006
Beiträge: 4
Wohnort: Hamburg

BeitragVerfasst am: 08. Sep 2006 3:17   Titel: Namensauflösung im lokalen Netzwerk funktioniert nicht

Moin Moin,
ich hab ein SuSe 10.1 System mit KDE 3.5 und allen Updates auf meinem Notebook. Es läuft inzwischen recht eindrucksvoll bis auf die Tatsache, dass die Namensauflösung im lokalen Netzwerk nicht funktioniert.
Das Notebook hängt bei mir Zuhause mit einigen anderen Windows-XP Computern in einem Netzwerk ohne einen Server oder Domaine. Die IPs und der restliche Kram für den Internetzugang werden über DHCP von einem WLAN-Router im Netzwerk verteilt.

Mein Problem drückt sich nun z.B. so aus:
Ein anderer Windows-XP Rechner bei mir im Netzwerk heißt "Trada" und hat die IP 192.168.38.14

Code:
kolaflash@idefix:~> ping Trada
ping: unknown host Trada

kolaflash@idefix:~> ping 192.168.38.14
->ping funktioniert ohne Probleme


Ich habs auch nochmal mit nslookup probiert:

Code:
kolaflash@idefix:~> nslookup Trada
Server:         192.168.38.1
Address:        192.168.38.1#53

** server can't find Trada: NXDOMAIN


Außerdem kann ich z.B. google.de anpingen. Es ist also wirklich die LOKALE Namensauflösung auf dem Notebook, die nicht funktioniert.
Sie funktioniert auch mit allen anderen Programmen nicht. Ich habe z.B. einen kleinen Webserver auf dem anderen Computer laufen. Kann darauf im Webbrowser vom Notebook aus aber nur über http://192.168.38.14 und nicht http://Trada zugreifen.

Von dem Windows-XP Computer Trada, kann ich das Notebook mit "ping Idefix" problemlos anpingen.
Wobei ich auf dem Notebook den Samba-Server laufen habe. Aber das dürfte ja eigentlich nix an der Namensauflösung, oder?

Wenn ich das Notebook selber mit "ping idefix" anpinge geht das über die IP 127.0.0.1 (idefix ist der Name des Notebooks). Das wird aber wohl an der /etc/hosts liegen, die ich hier einmal ohne die enthaltenen Kommentare poste:

Code:
127.0.0.1       localhost
::1             localhost ipv6-localhost ipv6-loopback
fe00::0         ipv6-localnet
ff00::0         ipv6-mcastprefix
ff02::1         ipv6-allnodes
ff02::2         ipv6-allrouters
ff02::3         ipv6-allhosts
127.0.0.2       idefix idefix


Verwunderlich finde ich dabei, dass als localhost IP 127.0.0.1 aber als IP für den Namen des Notebooks 127.0.0.2 und nich auch ne 1 am Ende eingetragen ist.

Ich verwalte meine Netzwerkverbindungen in Linux mit dem KNetworkManager. Mir ist aufgefallen, dass dieser jedes mal wenn er eine neue Verbindung aufbaut die Datei /etc/resolv.conf KOMPLETT überschreibt. Nachher steht dann immer folgendes drin:

Code:
### BEGIN INFO
#
# Modified_by:  NetworkManager
# Process:      /usr/bin/NetworkManager
# Process_id:   8510
#
### END INFO

nameserver 192.168.38.1


Fehlt da vielleicht der Eintrag "search localdomain" Und wenn ja, wie bekomm ich den KNetworkManager dazu, dass mit in die Datei zu schreiben???

Schonmal Danke für die Hilfe!

Viele Grüße
kolAflash
 
Benutzer-Profile anzeigen Private Nachricht senden

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 08. Sep 2006 7:31   Titel:

Du könntest die IP von Trada einfach in die /etc/hosts eintragen - das ist bei einem kleinen Netzwerk noch nicht so tragisch. Wenn du das nicht willst, musst du untersuchen, ob der Nameserver einwandfrei funktioniert. Die Ausgabe von

Code:
"nslookup idefix"


wäre interessant.
 
Benutzer-Profile anzeigen Private Nachricht senden

kolAflash



Anmeldungsdatum: 08.09.2006
Beiträge: 4
Wohnort: Hamburg

BeitragVerfasst am: 08. Sep 2006 13:08   Titel: nslookup idefix

Hier ist die Ausgabe von "nslookup idefix"
Code:
kolaflash@idefix:~/eigene_dateien/Scripts> nslookup idefix
Server:         192.168.38.1
Address:        192.168.38.1#53

** server can't find idefix: NXDOMAIN

Für mich sieht das so aus, als wenn versucht wird den Namen idefix mit Hilfe meines Routers der die IP 192.168.38.1 hat aufzulösen. Der Router hat aber natürlich keine Ahnung von den Namen im Netzwerk.
Mit der Zahl #53 kann ich allerdings nix anfangen.

Außerdem hab ich eben festgestellt, dass folgendes funktioniert:
Code:
kolaflash@idefix:/usr/share/vnc/classes> java VncViewer host Trada port 5900

Es hadelt sich hierbei um den Java-Client von TightVNC. Mit dem genannten Befehl lässt sich ohne Probleme eine Verbindung herstellen.
Beim "nicht-Java"-Client von TightVNC funktioniert das allerdings nicht. Dort muss ich auch die IP angeben. Es muss also wohl irgendwie an Java liegen, dass es in diesem einen Fall funktioniert.
 
Benutzer-Profile anzeigen Private Nachricht senden

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 08. Sep 2006 16:43   Titel:

Ich glaube, ich habe es verstanden. Trada ist der NetBIOS Name und ebenso Idefix vom Samba-Server her. Das hat mit einem eigentlichen Domain-Namen (im Sinne von DNS) nicht viel zu tun (soweit ich weiß).

Folglich kann dir der Nameserver (DNS) auch nicht den Namen auflösen. Du wirst nicht daraum heraumkommen, die IP in der /etc/hosts einzutragen:

Code:
192.168.38.14   Trada


Der SMBClient müsste Trada ebenfalls finden. (Denn der redet ja NetBIOS).
 
Benutzer-Profile anzeigen Private Nachricht senden

kolAflash



Anmeldungsdatum: 08.09.2006
Beiträge: 4
Wohnort: Hamburg

BeitragVerfasst am: 10. Sep 2006 12:47   Titel:

Und wieso kann Java dann den NetBIOS-Namen auflösen?
Wobei das is nich so wichtig. Wichtig wäre mir jetzt ein Befehl, der mit Hilfe von Samba NetBIOS-Namen in IPs wandelt. Gibts den?
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 10. Sep 2006 20:45   Titel:

"net" aus dem samba-Paket:

$ net lookup NAME

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

kolAflash



Anmeldungsdatum: 08.09.2006
Beiträge: 4
Wohnort: Hamburg

BeitragVerfasst am: 11. Sep 2006 9:40   Titel:

Jo hab ich probiert! Leider scheint das auch nich ganz zu klappen, wie man hier sieht:

Code:
kolaflash@idefix:~> net lookup trada
[2006/09/11 10:39:22, 0] param/loadparm.c:map_parameter(2691)
  Unknown parameter encountered: "ldap filter"
[2006/09/11 10:39:22, 0] param/loadparm.c:lp_do_parameter(3436)
  Ignoring unknown parameter "ldap filter"
[2006/09/11 10:39:33, 0] utils/net_lookup.c:net_lookup_host(55)
  Didn't find trada#20


Ich hab auch etwas mi dem Befehl nmblookup rumprobiert. Zum Beispiel "nbmlookup Trada" und "nmblookup -R Trada"
Das hat aber leider auch nix gebracht. Andererseits hab ich nmblookup noch nie benutzt und daher keine große Ahnung von dem Tool.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy