Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
USB-Modem

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Shinji



Anmeldungsdatum: 03.01.2006
Beiträge: 14
Wohnort: Randpolen

BeitragVerfasst am: 07. Okt 2006 13:25   Titel: USB-Modem

Servus,
hab mich von meinem Acer...-Modem abgewand und ein "Ultron UMO-856USB" extern gekauft. Es steht groß und breit drauf "...ist für Windoof und Linux" geeignet aber es wird nicht erkannt. Ich hab jede usb-Verbindungen ausprobiert aber Es WILL EINFACH NIE!!!

Jegliche Info bitte an Mich!
Danke
_________________
Laß dich nie auf eine Diskussion mit einem Dummen ein,
denn wenn du dich auf sein Niveau begibst, schlägt er dich mit seiner Erfahrung!
 
Benutzer-Profile anzeigen Private Nachricht senden AIM-Name Yahoo Messenger MSN Messenger

rudifaxe



Anmeldungsdatum: 16.07.2005
Beiträge: 70
Wohnort: Winningen/Mosel

BeitragVerfasst am: 08. Okt 2006 0:02   Titel:

Hallo.
Um die ganze Sache zu verkürzen. In dieser Rubrik gibt es die Antwort!
Es muss ganz klar gesagt werden: Unter Linux ist das Betreiben eines USB-Modems kaum möglich. Es gibt da eine oder auch zwei Ausnahmen.


"Hallo,
das einzige usb-modem, welches ich kenne und was läuft ist das elsa usb. nicht das fun, das im grauen gehäuse. gibts bei ebay für 10EUR. "

So sei es!
Und noch was, Windoof???? Bleibe bitte bei Windows!
Fax
Smile
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 08. Okt 2006 10:22   Titel:

Wenn der Hersteller angibt, dass es unter Linux funzt, sollte es das wohl auch. Support sollte der Hersteller dir geben:
http://www.ultron.de/mailform.htm

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

sumsi
Gast





BeitragVerfasst am: 08. Okt 2006 13:39   Titel: elsa usb

Hallo,

wenn man schon meinen Satz wörtlich kopiert, so gehört es sich die Quelle anzugeben:

>
Code:
das einzige usb-modem, welches ich kenne und was läuft ist das elsa usb. nicht das fun, das im grauen gehäuse. gibts bei ebay für 10EUR.


Du musst beim Einstecken nach der Kernelmeldung sehen.
z.B. in der /var/log/messages
was passiert,welche Hardware erkann wurde.

Das Elsa Modem benötigt den acm-Treiber, welches als Modul dabei ist.
Bis Kernel 2.4 wurde dieser auch automtisch (bis auf Debian) geladen und das device erstellt.
Nun eben nicht mehr, keine Ahnung warum - andere Methode????

Wäre nett wenn ein moderner insider mir die neue Hardwareerkennung erklären könnte Wink

Habe also ein Script in eine stardatei gelegt, welches Treiber und Device verfügbar macht:

Code:
/sbin/modprobe cdc-acm

if [ -e /dev/usb ]; then
   echo "Datei /dev/existiert "
else
   echo "Datei /dev/usb wird angelegt"
   /bin/mkdir /dev/usb
fi

/bin/mknod /dev/usb/ttyACM0 c 166 0

if [ -e /dev/usb/ttyACM0 ]; then

   /bin/ln -s /dev/usb/ttyACM0 /dev/modem
   echo "Modem ist eingerichtet "
else
   echo "Fehler bei Modem-Device-Erstellung"
fi


So oder mit dem Modul deines Modems müsste es funktionieren und von Windows bekommt man Ausschlag und es versaut den Charakter Wink

bye sumsi
 

Shinji



Anmeldungsdatum: 03.01.2006
Beiträge: 14
Wohnort: Randpolen

BeitragVerfasst am: 15. Okt 2006 13:14   Titel: Genau!!!

Hab mich mal den Betreibern (irgend so'n genervten Hotline-Menschen 10min. nach seinem Feierabend Cool ) geredet & er hat mir zwei verschiedene Versionen von "*.tar.gz" treibern geschickt, die eigendlich auf der CD dabei seien sollen (Dort sin aber wie immer Windows-Treiber oben, jetzt sogar für WinXP 64Bit...). Ich weis jetzt nur nie wie ich diese Datei in das System einspeisen soll. in der Zip-Datei is 'ne Datei die "mdm.o" heest. Was isn *.o für 'ne Endung???
Die Andere hat mehrere Dateien und eene Installationsanleitung, aber mit der komm i oh nie klar! Im ganzen lautet sie:
"Installation
============

1. Unpack tar.gz package file:

$ gzip -dc slmodem-2.9.X.tar.gz | tar xf -

2. 'cd' to package directory:

$ cd slmodem-2.9.X

3. Review and edit 'Makefile' (if need):

In many cases you will need to correct path to your local kernel
source tree:

KERNEL_DIR=/path/to/linux

Default KERNEL_DIR is '/lib/modules/<kerne-version>/build'. Many Linux
Distributions use directory '/usr/src/linux-<version>' also.

Note: If you are using Linux kernel 2.4, only header files should be
available for build in $(KERNEL_DIR)/include

Another way to pass right value KERNEL_DIR is to use command line
parameter while running 'make':

$ make KERNEL_DIR=/path/to/linux ...

4. Run 'make' command to compile package:

$ make

5. Install. As 'root' user run:

# make install

It will install:

- application 'slmodemd' under '/usr/sbin' directory

- hardware specific drivers (kernel modules) 'slamr' and 'slusb'
under conventional kernel modules directory

- character device nodes '/dev/slamr0-3' with major number 212
(for pci modems) and '/dev/slusb0-3' with major number 213
(for usb modems).

- config modules for autoloading (by editing file '/etc/modules.conf')
(only with 2.4 kernels)

6. Config modem country.

Use AT+GCI=<T.35 country code> command to setup country.

Also you can setup default modem country by passing command line
parameter '--country=MY_COUNTRY' to program 'slmodemd'.

See output of 'slmodemd --countrylist' for a list of supported
country names and T.35 country codes (see also 'slmodemd --help').

Note: Command ATI7 shows currently installed country setting.

8. Uninstallation.

In package directory just type:

# make uninstall


Getting Started
===============

After successful installation and configuration:

1. Load modem driver.

Load your modem hardware specific kernel module:

# modprobe slamr

if you are using AMR/CNR/PCI modem, or

# modprobe slusb

if you are using SmartUSB56 Modem.

Note: this will be done automatically when modules were
configured for 'loading on demand'

Note: this is safe to load both 'alamr' and 'slusb' modules.

2. Run soft modem application.

# /usr/sbin/slmodemd [options] <device_name>

Where device name is appropriate device node for your modem
(look at output of 'dmesg' command).
Run '/usr/sbin/slmodemd --help' for details.

Examples:

# /usr/sbin/slmodemd --country=USA /dev/slamr0

, or for SmartUSB56 Modems:

# /usr/sbin/slmodemd --country=ITALY /dev/slusb0

3. Using the modem.

When 'slmodemd' is running this creates PTY (pseudo-terminal) to
emulate modem port device, also this creates symbolic link
like '/dev/ttySL0' (shown at startup).

Config your application to use this link '/dev/ttySL0' (or PTY node
itself) as modem port.

Note: Some application want 'to know' that they are working with
pseudo-terminal and may require additional configurations.

Known application notes:

- 'wvdial' requires option 'Carrier Check = no' in config file

- some versions of 'kppp' may not work properly with devices named
like '/dev/ttySL0'. To workaround this you may create symbolic link
'/dev/modem' ( # ln -s /dev/ttySL0 /dev/modem ) and use this link
as modem device with 'kppp'

4. Startup automation.

There are examples of startup scripts in 'scripts' directory.


ALSA mode
=========

ALSA has the built-in modem drivers included in 'alsa-driver' >= 1.0.2
and in Linux kernel >= 2.6.5. Currently there is 'intel8x0m' (snd-intel8x0m)
modem driver, which supports ICH based AC97 modems (MC97).

Recent 'alsa-driver' (>=1.0.6) has also support for NVidia NForce
(snd-intel8x0m) and ATI IXP (snd-atiixp-modem) based modems.

1. Configure your kernel and enable ALSA and ICH based modem support
( 'Device Drivers' -> 'Sound' -> 'Advanced Linux Sound Architecture' ->
'PCI devices' -> 'Intel i8x0/MX440; AMD768/8111 modems' ) .

2. Build and install kernel and modules as usual (make , make modules_install,
etc.). ICH modem driver modem module name is 'snd-intel8x0m'
(if was configured as module).

3. Build application 'slmodemd' with ALSA support. For this in
slmodem-2.9.x dir:

$ cd modem
$ make SUPPORT_ALSA=1

This will build 'slmodemd' with ALSA support. If compilation is failed
review Makefile (near ALSA_SUPPORT condition) and define right library
and/or CFLAGS

4. Use option '--alsa' when running 'slmodemd' and ALSA conventional
device name ('hw:0' or 'hw:1' for instance). If modem support in
the kernel was enabled as module module 'snd-intel8x0m' should be loaded.

Note: Recent version of 'alsa-lib' (>= 1.0.6) has built-in "modem" device
name support ('modem:0', 'modem:1', etc). It is recommended to use
those names with modems (mandatory with ATI IXP modems).

Note: When using ALSA modem driver you don't need to load other
modules ('slamr')."
Kann mir das mal jemand erklären??? auch mit den Eingabeaufforderungen komm i oh no nie klar. das muss man sich ja erst einmal aneignen.
Hab mich mit Linux erst seit nen halben Jahr beschäftigt & wees no nie so viel? Wer mir helfen kann sei gepriesen Exclamation
_________________
Laß dich nie auf eine Diskussion mit einem Dummen ein,
denn wenn du dich auf sein Niveau begibst, schlägt er dich mit seiner Erfahrung!
 
Benutzer-Profile anzeigen Private Nachricht senden AIM-Name Yahoo Messenger MSN Messenger

susmi
Gast





BeitragVerfasst am: 16. Okt 2006 15:54   Titel: srl

Hallo,

wenn ich die Ausschrift richtig deute ist das so ein slr-Modem.
Damit habe ich mich auch schon (Laptop) abgeqält, verschienede Versionen von dem Hersteller probiert ... die beste version (nicht die aktuellste) ging sogar soweit bis zum Anwählen und dann aus ;(

Dann habe ich Mandriva 2006 draufgespielt und das Modem läuft und läuft und läuft ...
von ganz alleine, muss nur kppp starten Wink
 

Shinji



Anmeldungsdatum: 03.01.2006
Beiträge: 14
Wohnort: Randpolen

BeitragVerfasst am: 17. Okt 2006 15:54   Titel:

Servus,
ich benutze ja SUSe 10.0 und hab es auch scho mit kppp ausprobiert (alle möglichen Stellungen in der Hardwareerkennung), aber es will einfach nie!!! Wenn du mir sagen könntest wie ich die ganzen Befehle eingebe und bestätige wäre ich schon froh!!! Das Entpacken war ja kein problem aber die Befehle; muss ich das im Terminal bearbeiten oder wo???
Sonst müsste ich das Microlink meinem Vater abknöpfen, da war das intialisieren ja leicht, aber er will ja auch über Linux surfen, tja pech. Muss ich wohl probieren & probieren & probieren, binn aber über jegliche Hilfe glücklich Wink

Gruß
_________________
Laß dich nie auf eine Diskussion mit einem Dummen ein,
denn wenn du dich auf sein Niveau begibst, schlägt er dich mit seiner Erfahrung!
 
Benutzer-Profile anzeigen Private Nachricht senden AIM-Name Yahoo Messenger MSN Messenger

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 17. Okt 2006 18:15   Titel:

Lad mal dieses Skript runter und laß es als root laufen. In der Ausgabe solltest Du Hinweise finden, welche Software Du benötigst.

Das Modem ist ja ein Softmodem. Somit hast Du zwei komponenten: Einmal den Hardwaretreiber. Dieser stellt das Modem als Soundkarte zur Verfügung. Somit kann sich der slmodemd einklinken und die Telefonleitung "hören". Der slmodemd macht die eigentliche Arbeit und simuliert die komplette Kommunikation in Software, horcht also auf ankommende Daten und generiert ein Signal für die Gegenstelle.

Konkret heißt das: Lade das passende Hardware-Modul. Welches das ist findest Du hoffentlich mit scanModem.gz raus. Dann konfiguriere slmodemd, gebe in kppp das richtige Gerät an (normalerweise /dev/ttySL0) und es solte funktionieren.

Oder probiere es mit ner Distribution, bei der schon alles richtig vorkonfiguriert ist :-).
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy