Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
lange Namensserverauflösung

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
phimei



Anmeldungsdatum: 31.08.2006
Beiträge: 16

BeitragVerfasst am: 08. Okt 2006 23:43   Titel: lange Namensserverauflösung

Hi,

Wenn ich mit SuSu Linux ins Internet gehe, dann hat er ziemlich lange bei der Namensauflösung. Ich habe auch schon die Linux-Firewall ausgestellt, ohne merkbaren Erfolg. Die Proxyeinstellungen hab ich auch überprüft, die sind auch in Ordnung. Was könnte es sonst noch für Gründe für das lahme Internet geben?

Herzlichen Dank im Vorraus!

GruPhi
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 09. Okt 2006 11:45   Titel:

Der Nameserver, den du verwendest, ist vermutlich lahm. Prüf' doch mal auf der Kommandozeile mit "dig" nach, wie lange Anfragen an bestimmte Server dauern. Benutzt du einen Router, hast du diesen als Nameserver angegeben? Evtl. ist er der Schuldige.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

phimei



Anmeldungsdatum: 31.08.2006
Beiträge: 16

BeitragVerfasst am: 09. Okt 2006 12:47   Titel:

Wenn ich dig in der Konsole eingeben kommt folgendes:

Zitat:
; <<>> DiG 9.3.1 <<>>
;; global options: printcmd
;; connection timed out; no servers could e reached


Als Namensserver habe ich den Router angeben. Dies sollte eigenlich keine Probleme machen, da ich mit dem Windoof-Notebook ohne weiteres in angenehmer Geschwindigkeit surfen kann.
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 09. Okt 2006 19:17   Titel:

Das sollte aber eher so aussehen:

Code:

$ dig
; <<>> DiG 9.3.1 <<>>
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28662
;; flags: qr rd ra; QUERY: 1, ANSWER: 13, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;.                              IN      NS

;; ANSWER SECTION:
.                       5083    IN      NS      C.ROOT-SERVERS.NET.
.                       5083    IN      NS      D.ROOT-SERVERS.NET.
.                       5083    IN      NS      E.ROOT-SERVERS.NET.
.                       5083    IN      NS      F.ROOT-SERVERS.NET.
.                       5083    IN      NS      G.ROOT-SERVERS.NET.
.                       5083    IN      NS      H.ROOT-SERVERS.NET.
.                       5083    IN      NS      I.ROOT-SERVERS.NET.
.                       5083    IN      NS      J.ROOT-SERVERS.NET.
.                       5083    IN      NS      K.ROOT-SERVERS.NET.
.                       5083    IN      NS      L.ROOT-SERVERS.NET.
.                       5083    IN      NS      M.ROOT-SERVERS.NET.
.                       5083    IN      NS      A.ROOT-SERVERS.NET.
.                       5083    IN      NS      B.ROOT-SERVERS.NET.

;; Query time: 49 msec
;; SERVER: 10.0.0.1#53(10.0.0.1)
;; WHEN: Mon Oct  9 20:14:04 2006
;; MSG SIZE  rcvd: 228


Außerdem kannst du ja vielleicht auch mal einen DNS-Request mit dig abschicken:

Code:

$ dig www.pro-linux.de

; <<>> DiG 9.3.1 <<>> www.pro-linux.de
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33988
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.pro-linux.de.              IN      A

;; ANSWER SECTION:
www.pro-linux.de.       20      IN      A       213.239.211.178

;; Query time: 5 msec
;; SERVER: 10.0.0.1#53(10.0.0.1)
;; WHEN: Mon Oct  9 20:15:30 2006
;; MSG SIZE  rcvd: 50


Dass es mit MS-Windows klappt, hat nichts zu sagen. Wir hatten hier in einem anderen Thread einen Router, der einen Bug in MS-Windows ausgenutzt hat -- nämlich die Absenderadresse der Antwort nicht mit der Empfängeradresse des Requests zu vergleichen -- mit genau den gleichen Phänomenen wie bei dir.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

phimei



Anmeldungsdatum: 31.08.2006
Beiträge: 16

BeitragVerfasst am: 10. Okt 2006 0:21   Titel:

Mhmm, leider verschwinder immer wieder der WEP-Key. Daher ging der Befehl "Dig" nach Hinten los.

Wenn ich jetzt "dig www.google.ch" mache, dann geht es soweit. Für den Query benötigt er 18msec. Wenn ich jedoch nur "dig" mache, dann kommt immer noch "connection timed out". Was ist den das Relevante vom diesem dig-befehl?
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 10. Okt 2006 7:56   Titel:

Beides. Ohne Argumente versucht dig, den Namen "." aufzulösen, was die DNS-Rootserver auf den Plan ruft. Da sollten alle Antworten, sonst hast du ein Problem.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy