Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 16. Nov 2018 12:49

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 6 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: lange Namensserverauflösung
BeitragVerfasst: 08. Okt 2006 23:43 
Offline

Registriert: 31. Aug 2006 21:45
Beiträge: 16
Hi,

Wenn ich mit SuSu Linux ins Internet gehe, dann hat er ziemlich lange bei der Namensauflösung. Ich habe auch schon die Linux-Firewall ausgestellt, ohne merkbaren Erfolg. Die Proxyeinstellungen hab ich auch überprüft, die sind auch in Ordnung. Was könnte es sonst noch für Gründe für das lahme Internet geben?

Herzlichen Dank im Vorraus!

GruPhi


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09. Okt 2006 11:45 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Der Nameserver, den du verwendest, ist vermutlich lahm. Prüf' doch mal auf der Kommandozeile mit "dig" nach, wie lange Anfragen an bestimmte Server dauern. Benutzt du einen Router, hast du diesen als Nameserver angegeben? Evtl. ist er der Schuldige.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09. Okt 2006 12:47 
Offline

Registriert: 31. Aug 2006 21:45
Beiträge: 16
Wenn ich dig in der Konsole eingeben kommt folgendes:
Zitat:
; <<>> DiG 9.3.1 <<>>
;; global options: printcmd
;; connection timed out; no servers could e reached
Als Namensserver habe ich den Router angeben. Dies sollte eigenlich keine Probleme machen, da ich mit dem Windoof-Notebook ohne weiteres in angenehmer Geschwindigkeit surfen kann.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09. Okt 2006 19:17 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Das sollte aber eher so aussehen:
Code:
$ dig
; <<>> DiG 9.3.1 <<>>
;; global options&#58;  printcmd
;; Got answer&#58;
;; ->>HEADER<<- opcode&#58; QUERY, status&#58; NOERROR, id&#58; 28662
;; flags&#58; qr rd ra; QUERY&#58; 1, ANSWER&#58; 13, AUTHORITY&#58; 0, ADDITIONAL&#58; 0

;; QUESTION SECTION&#58;
;.                              IN      NS

;; ANSWER SECTION&#58;
.                       5083    IN      NS      C.ROOT-SERVERS.NET.
.                       5083    IN      NS      D.ROOT-SERVERS.NET.
.                       5083    IN      NS      E.ROOT-SERVERS.NET.
.                       5083    IN      NS      F.ROOT-SERVERS.NET.
.                       5083    IN      NS      G.ROOT-SERVERS.NET.
.                       5083    IN      NS      H.ROOT-SERVERS.NET.
.                       5083    IN      NS      I.ROOT-SERVERS.NET.
.                       5083    IN      NS      J.ROOT-SERVERS.NET.
.                       5083    IN      NS      K.ROOT-SERVERS.NET.
.                       5083    IN      NS      L.ROOT-SERVERS.NET.
.                       5083    IN      NS      M.ROOT-SERVERS.NET.
.                       5083    IN      NS      A.ROOT-SERVERS.NET.
.                       5083    IN      NS      B.ROOT-SERVERS.NET.

;; Query time&#58; 49 msec
;; SERVER&#58; 10.0.0.1#53&#40;10.0.0.1&#41;
;; WHEN&#58; Mon Oct  9 20&#58;14&#58;04 2006
;; MSG SIZE  rcvd&#58; 228
Außerdem kannst du ja vielleicht auch mal einen DNS-Request mit dig abschicken:
Code:
$ dig www.pro-linux.de

; <<>> DiG 9.3.1 <<>> www.pro-linux.de
;; global options&#58;  printcmd
;; Got answer&#58;
;; ->>HEADER<<- opcode&#58; QUERY, status&#58; NOERROR, id&#58; 33988
;; flags&#58; qr rd ra; QUERY&#58; 1, ANSWER&#58; 1, AUTHORITY&#58; 0, ADDITIONAL&#58; 0

;; QUESTION SECTION&#58;
;www.pro-linux.de.              IN      A

;; ANSWER SECTION&#58;
www.pro-linux.de.       20      IN      A       213.239.211.178

;; Query time&#58; 5 msec
;; SERVER&#58; 10.0.0.1#53&#40;10.0.0.1&#41;
;; WHEN&#58; Mon Oct  9 20&#58;15&#58;30 2006
;; MSG SIZE  rcvd&#58; 50
Dass es mit MS-Windows klappt, hat nichts zu sagen. Wir hatten hier in einem anderen Thread einen Router, der einen Bug in MS-Windows ausgenutzt hat -- nämlich die Absenderadresse der Antwort nicht mit der Empfängeradresse des Requests zu vergleichen -- mit genau den gleichen Phänomenen wie bei dir.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 10. Okt 2006 0:21 
Offline

Registriert: 31. Aug 2006 21:45
Beiträge: 16
Mhmm, leider verschwinder immer wieder der WEP-Key. Daher ging der Befehl "Dig" nach Hinten los.

Wenn ich jetzt "dig www.google.ch" mache, dann geht es soweit. Für den Query benötigt er 18msec. Wenn ich jedoch nur "dig" mache, dann kommt immer noch "connection timed out". Was ist den das Relevante vom diesem dig-befehl?


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 10. Okt 2006 7:56 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Beides. Ohne Argumente versucht dig, den Namen "." aufzulösen, was die DNS-Rootserver auf den Plan ruft. Da sollten alle Antworten, sonst hast du ein Problem.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 6 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de