Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 12. Nov 2018 18:42

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 7 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: MagicPoint läuft nicht interaktiv
BeitragVerfasst: 15. Okt 2006 13:59 
Hallo,

ich hatte vor ein paar Jahren mal eine Präsentation mit MagicPoint gemacht und war sehr begeistert über den Funktionsumfang und Handling. es passt alles auf eine Seite ;-)

Die Kommunikation mit der Shell, d.h. die Darstellung von Befehlen ging immer mit der RPM-Variante in Echtzeit, nur zur Darstellung von X-Anwendungen (xclock, xeyes usw) musste ich das Paket selbst bauen.

Jetzt wollte ich das Programm wieder mal nutzen und es läuft eben nur mit den Grundfunktionen, also nur reine Darstellung :cry: - keine Abbildung/Rückgabe von Shellbefehlen, geschweige der Wiedergabe von X-Programmen.

Habe auch schon die Sourceinstalltion durchgeführt - ohne Erfolg.

Hat jemand einen guten Tip?

bye sumsi


Nach oben
   
 Betreff des Beitrags: traurig
BeitragVerfasst: 17. Okt 2006 16:41 
Hallo,

das ist ja traurig, dass sich keiner mit diesem tollen Programm beschäftigt :(

Aber vielleicht könn ihr mir doch helfen, indem ihr es mal installiert und die Beispiele, welche im der doc als sample liegen, mal testet.

Wie gesagt, mich interessiert, ob es an meinem System liegt, das ich keine Rückabewerte der Shell bekomme ...

Als, das ist ein Präsentationsprogramm, wo ich auf die Foliee date oder ls schriebn kann und ich bekomme die Rückgabe als Datum oder Verzeichnisinhalt heraus ....

Oder ich starte xclock und habe immer die aktuelle Uhrzeit...

So war es bis vor kurzen, mit meinem jetzigen System geht es nicht mehr :cry: :cry: :cry:

Bitte um Mithilfe , bei wem funktioniert es ??

zum Beispiel:
Code:
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%
%deffont "standard" xfont "helvetica-medium-r", tfont "standard.ttf", tmfont "hoso6.ttf"
%deffont "thick" xfont "helvetica-bold-r", tfont "thick.ttf", tmfont "hoso6.ttf"
%deffont "typewriter" xfont "courier-medium-r", tfont "typewriter.ttf", tmfont "hoso6.ttf"
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%
%% Default settings per each line numbers.
%%
%default 1 area 90 90, leftfill, size 2, fore "gray20", back "white", font "standard", hgap 0
%default 2 size 7, vgap 10, prefix " ", ccolor "black"
%default 3 size 2, bar "gray70", vgap 10
%default 4 size 5, fore "gray20", vgap 30, prefix " ", font "standard"
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%
%% Default settings that are applied to TAB-indented lines.
%%
%tab 1 size 5, vgap 40, prefix "  ", icon box "green" 50
%tab 2 size 4, vgap 40, prefix "      ", icon arc "yellow" 50
%tab 3 size 3, vgap 40, prefix "            ", icon delta3 "white" 40
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%  Seite 0 - Willkommen %%%%%%%%%%%%%%%%%%%%%
%page
%bgrad 25 25 256 45 1 "gray" "gray" "white" "white" "white" "white" "gray" "gray"

Willkommen

%size 3,FORE "black"
Mein Ort am -
%cont
%filter "date +%d.%m.%G "
%endfilter
%cont
 -
%cont
%filter "  date +%R"
%endfilter
%cont
 Uhr
%SIZE 16,FORE "red"

Hallo
%size 4,FORE "blue"


    

%% %area 50 90 15 20, leftfill, fore "black"


%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%PAGE
%bgrad 25 25 256 45 1 "gray" "gray" "white" "white" "white" "white" "gray" "gray"
%SIZE 8,FORE "blue"

ENDE

%SIZE 10,FORE "red"

	Danke für Ihre Aufmerksamkeit

%center
%xsystem "xclock -geometry %30x30+25+60 -update 1 -bg white -fg blue -hands green"
%%system "xeyes -geometry %50x20+25+60"

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
Viele Grüsse - bin auf positive Ergebnisse erwartungsvoll gespannt...
sumsi


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 20. Okt 2006 14:22 
Offline

Registriert: 20. Okt 2006 12:54
Beiträge: 14
Hallo sumsi,

leider schreibst Du nicht, was für eine Distribution und was für einen Desktop du verwendest.

Bei der Installation auf Debian mit KDE bekam ich eine Fehlermeldung, bei der irgendwelche GNOME-Bibliotheken vermißt wurden. Weiter fand ich einen kernel-patch-kdb, der allerdings offensichtlich nur bis Kernel 2.6.7 Gültigkeit hat.

Schade, es hätte mich auch sehr interessiert.

om


Nach oben
   
 Betreff des Beitrags: magicpoint
BeitragVerfasst: 20. Okt 2006 14:56 
Hallo,

danke dass Du Dich der Frage angenommen hast ;-)

Also jetzt habe ich Mandriva 2005.
Zuvor, als es noch funktionierte Mandrake 9.2.

Was mich nun interessiert ist, gehten die Optionen aus irgendein Grund generell nicht
mehr oder nur nicht bei mir :oops:

Hats du es mal ausprobiert, in der ..doc/ oder ..man/ liegen auch samples bei, in einem ist das Beispiel 'ls -l' und solche Konstrucktionen wie
Code:
Mein Ort am -
%cont
%filter "date +%d.%m.%G "
%endfilter
%cont
 -
%cont
%filter "  date +%R"
%endfilter 
bringen auch das Datum.
Man kann eben Vorträge über Linux halten, Änderungen am System machen, die dann in Echtzeit in der Bildershow eingebunden werden - eigentlich einmalig - müsste eben nur funktionieren ...

Viele Grüsse
sumsi


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 21. Okt 2006 10:38 
Offline

Registriert: 20. Okt 2006 12:54
Beiträge: 14
Hallo sumsi,

nach einigen Versuchen habe ich aufgegeben. Das Programm wird wohl auch nicht mehr richtig gepflegt. Habe die Samples mit verschiedenen Schaltern versucht zu starten, es tut sich nichts.

Auf einer Suchmaschine fand ich einige Einträge, die neuesten von denen waren aus dem Jahr 2003. Es liegt wohl daran, daß sich in der Zwischenzeit einiges im Linuxlager getan hat. Leider habe ich momentan auch keine Teststation hier, auf der ich es mit einem älteren Linux versuchen könnte. Was ich aus den Ergebnissen der Suchmaschine rauslesen konnte, war das, daß es mit einem RedHat oder FreeBSD wohl gut laufen soll.

Aber trotzdem versuche ich am Ball zu bleiben, und werde hier wieder berichten, sollte ich zu neuen Erkenntnissen kommen.

Gruß
om


Nach oben
   
 Betreff des Beitrags: :(
BeitragVerfasst: 21. Okt 2006 12:28 
Hallo om,

danke Dir für deinen Einsatz :), kann man eben nix machen.
Ist mir bloss unklar, woran das liegen kann ???

Soweit ich's in Erinnerung hatte, brauchte man die Schalter nur für X-Anwendungen
(musste so glaube ich im nicht-Vollbild-modus laufen), für die Shell-Kommunikation aber nicht nicht.

Grüsse sumsi


Nach oben
   
 Betreff des Beitrags: xorg
BeitragVerfasst: 29. Okt 2006 12:36 
Kann es vielleicht sein, dass es mit xorg nicht richtig zusammenarbeitet ?


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 7 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de