Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
iptables und xserver

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
ERit



Anmeldungsdatum: 24.10.2006
Beiträge: 2

BeitragVerfasst am: 24. Okt 2006 12:12   Titel: iptables und xserver

hej
ich hab eine frage bezüglich iptables: hab jetzt einige ports geblockt und ausgehenden traffic freigegeben, d.h. ich kann nach außen hin jedes port nutzen, für eingehenden traffic wird all das zugelassen, dass eine antwort auf einen request von meinem rechner darstellt. alle ports sind sonst geblockt, außer einige die ich benötige.

ausgabe von nmap:
[code]
Interesting ports on localhost (127.0.0.1):
Not shown: 1667 filtered ports
PORT STATE SERVICE
22/tcp open ssh
68/tcp closed dhcpc
80/tcp open http
111/tcp open rpcbind
3306/tcp open mysql
[/code]
mein problem: ich hatte port 111 geblockt und konnte dann nicht mehr ordnungsgemäß herunterfahren, da der portmap deamon nicht mehr beendet wurde. was hat dieser dienst für einen sinn?
weiters benötigen die NFS tools beim booten ca eine minute und der xserver hängt sich beim beenden auf ... die xserver ports gehen ja von 6000 bis 6007 (tcp und udp) aber wenn ich diese freigeben steht der xserver trotzdem wieder beim runterfahren ...
danke schon mal für eure hilfe,
lg
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 24. Okt 2006 18:17   Titel:

portmap gehört zum NFS-Server. Brauchst du das überhaupt?

X-Server: Welcher X-Server steht beim Runterfahren des Servers? Der lokale oder ein Remote-X?

Allgemein solltest du das loopback freigeben, dadurch bist du schonmal einige Probleme los.

# iptables -A INPUT -i lo -j ACCEPT

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

ERit



Anmeldungsdatum: 24.10.2006
Beiträge: 2

BeitragVerfasst am: 24. Okt 2006 19:09   Titel:

hej =)
also ich sag mal danke, das war auch die quelle aller fehler =) läuft alles wieder einwandfrei. ich meinre den lokalen xserver, und der benötigt anscheinend ein paar ports des lo interfaces. die nfs tools starten jetzt auch normal =)
danke für die hilfe.
lg
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy