"Vergessene" Windows CD zerstört SuSe Installation

Antworten
Nachricht
Autor
Heiliger Hain

"Vergessene" Windows CD zerstört SuSe Installation

#1 Beitrag von Heiliger Hain » 21. Dez 2006 23:35

Hallo,
leider vergaß ich, nach der Installation von Windows 2003 Server in eine VM eines Suse 10.0 Rechners die CD aus dem Laufwerk zu nehmen. Beim nächsten Rechnerstart (die Bootreihenfolge im Bios stand natürlich noch auf "CD zuerst") startete der Windows 2003 Bootvorgang. Als ich dies bemerkte, drückte ich zwar schnell noch den Resetknopf- aber es war wohl schon zu spät:
Beim Neustart des Rechners startete zwar das Grub Menü, aber die Auswahl der SuSe Einträge ergab stets folgende Fehlermeldung: Error 22: No such partition.
Da hat Windows wohl irgendetwas zerschossen (toll- vielen Dank). Beide Partitionen (Linux und Linux swap) sind in z.B. in cfdisk zu sehen, die swap Partition als erste, die andere als zweite.
Den MBR habe ich anhand einer Anleitung aus dem Internet wiederhergestellt, aber es funktioniert leider trotzdem nicht- wieder der oben beschriebene Fehler. Woran könnte dies liegen?
Ich habe noch nicht viel Erfahrung mit Linux und bin deshalb für jede Hilfe dankbar.

Euklid
Beiträge: 125
Registriert: 17. Sep 2006 15:39

#2 Beitrag von Euklid » 26. Dez 2006 12:26

Hallo!

Hast du es schon über die SuSE-Installations-CD/DVD probiert? Dort kann man meines Wissens den Bootloader wiederherstellen.

Viele Grüße, Euklid

linuxer32

#3 Beitrag von linuxer32 » 26. Dez 2006 12:46

jaja, mickisoft sollte man meiden, bringt nur unheil.

den nicht funktionierenden bootloader kannste wiederherstellen, z.b. mit dsl oder der susi-install-cd oder irgendeiner linux-live-cd.
bei grub muss nur die config datei (menu.conf in /boot/grub) korrekt sein.

checke mit fdisk, ob die partitionen auch noch linuxpartitionen sind. wenn nicht, stelle die letzte version wieder her. das sollte gehen.

ggf. kannste aus einem livesystem mit chroot /pfad/deiner/eingebundenen/hdd-distri dich in dein system einloggen und fehler beheben...

sumsi

grup-install

#4 Beitrag von sumsi » 27. Dez 2006 10:42

Hallo,

entweder hat deine Distri-CD eine Wiederherstellungsoption für den Bootmanager (?) oder
du startest sowas wie Knoppix, mountest dann die Linuxpartition und ruftst grub-install in der chroot-Umgebung auf. Beispiel:

mount /dev/hda2 /mnt/
chroot /mnt/
grup-install

Wenn dabei keine Fehlermeldung kommt, ist der Grub nun wieder so wie er zuvor war ;-)

LG sumsi

Antworten