Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 14. Nov 2018 16:14

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 4 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 21. Dez 2006 23:35 
Hallo,
leider vergaß ich, nach der Installation von Windows 2003 Server in eine VM eines Suse 10.0 Rechners die CD aus dem Laufwerk zu nehmen. Beim nächsten Rechnerstart (die Bootreihenfolge im Bios stand natürlich noch auf "CD zuerst") startete der Windows 2003 Bootvorgang. Als ich dies bemerkte, drückte ich zwar schnell noch den Resetknopf- aber es war wohl schon zu spät:
Beim Neustart des Rechners startete zwar das Grub Menü, aber die Auswahl der SuSe Einträge ergab stets folgende Fehlermeldung: Error 22: No such partition.
Da hat Windows wohl irgendetwas zerschossen (toll- vielen Dank). Beide Partitionen (Linux und Linux swap) sind in z.B. in cfdisk zu sehen, die swap Partition als erste, die andere als zweite.
Den MBR habe ich anhand einer Anleitung aus dem Internet wiederhergestellt, aber es funktioniert leider trotzdem nicht- wieder der oben beschriebene Fehler. Woran könnte dies liegen?
Ich habe noch nicht viel Erfahrung mit Linux und bin deshalb für jede Hilfe dankbar.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Dez 2006 12:26 
Offline

Registriert: 17. Sep 2006 15:39
Beiträge: 125
Hallo!

Hast du es schon über die SuSE-Installations-CD/DVD probiert? Dort kann man meines Wissens den Bootloader wiederherstellen.

Viele Grüße, Euklid


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Dez 2006 12:46 
jaja, mickisoft sollte man meiden, bringt nur unheil.

den nicht funktionierenden bootloader kannste wiederherstellen, z.b. mit dsl oder der susi-install-cd oder irgendeiner linux-live-cd.
bei grub muss nur die config datei (menu.conf in /boot/grub) korrekt sein.

checke mit fdisk, ob die partitionen auch noch linuxpartitionen sind. wenn nicht, stelle die letzte version wieder her. das sollte gehen.

ggf. kannste aus einem livesystem mit chroot /pfad/deiner/eingebundenen/hdd-distri dich in dein system einloggen und fehler beheben...


Nach oben
   
 Betreff des Beitrags: grup-install
BeitragVerfasst: 27. Dez 2006 10:42 
Hallo,

entweder hat deine Distri-CD eine Wiederherstellungsoption für den Bootmanager (?) oder
du startest sowas wie Knoppix, mountest dann die Linuxpartition und ruftst grub-install in der chroot-Umgebung auf. Beispiel:

mount /dev/hda2 /mnt/
chroot /mnt/
grup-install

Wenn dabei keine Fehlermeldung kommt, ist der Grub nun wieder so wie er zuvor war ;-)

LG sumsi


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 4 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de