Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 14. Nov 2018 16:25

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Bufferprobleme - TCP send window?
BeitragVerfasst: 22. Dez 2006 23:23 
Offline

Registriert: 22. Dez 2006 23:17
Beiträge: 9
Hey ihr =)

ich hab derzeit ein großes Problem.
Ich bin Techniker bei einem Internetradio. Seit neuem haben wir IceCast 2.

Das Problem:
Zuhörer die über IceCast zuhören haben einen riesen Buffer. Bei ca. 70 % buffert es dauerhaft - bei 20 % ab und zu - und bei 10 % nie bis 1 mal ab Tag.

Das ganze hab ich schon bei IceCast.org beschrieben, allerdings sagte "KarlH" nur, ich soll mal sowas wie die TCP Einstellungen checken?
(http://forum.icecast.org/viewtopic.php?p=6833#6833)

Ich weiß nicht wie das geht etc. - deswegen wollte ich euch mal fragen.

Habs auch schon versucht indem ich streamTranscoder, IceCast & Shoutcast ein "Nicelevel" von -1 bis -2 gegeben habe.
Trotzdem gehts nicht.

Hoffentlich wisst ihr was - ich denke nämlich das es am System liegt und nicht mehr an den Einstellungen von IceCast & streamTranscoder :(

Infos übers System:
- OS: SuSE Linux 9.3
- Dedicated Root Server
- Alle Rechte (root) vorhanden
- 64bit system
- AMD Athlon(tm) 64 Processor 3500+
- Rechenzentrum Karlsruhe
- Anbindung von 100 MBit/s derzeit.

Liebe Grüße & Frohe Weihnachten,
DenniX :)


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 27. Dez 2006 19:04 
Offline

Registriert: 22. Dez 2006 23:17
Beiträge: 9
Weiß echt keiner weiter oder so? :(


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 27. Dez 2006 20:46 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Offensichtlich nicht. Das kann passieren. Versuch doch mal, das Fehlerbild genauer zu beschreiben (Was ist ein "riesen Buffer"?). Vielleicht fällt dann ja jemandem was ein...

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 27. Dez 2006 21:34 
Offline

Registriert: 22. Dez 2006 23:17
Beiträge: 9
Also mit riesen Buffer ist gemeint, bei fast allen Zuhörern buffert der Stream beim Zuhören.

Es ist auch unterschiedlich.
Manche haben einen kurzen Stop in 10 Minuten, andere können keine 10 Sekunden ohne Buffern zuhören.
Winamp zeigt bei manchen an:
Buffer: 0%, Buffer: 20% [...] bis 100 und dann gehts weiter für 2 sek, und dann buffert es wieder^^

Hab heute 1&1 angerufen, die Leitung ist nicht runter gedrosselt auf 10 Mbps und die haben auch keine Störung. :( Hoffe ihr wisst wie ich das meine.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 30. Dez 2006 14:20 
Guten Tag

Normalerweise verwendet Echtzeit Audio Multimedia (bsp VoIP) UDP als Transportprotokoll und RTP als Realtime Transport Protocol mit RTCP als Realtime Transport Control Protocol.

TCP ist grundsaetzlich ungeeignet fuer eine solche Aufgabe, da TCP zum einen nur beschraenkt in den Sendezeiten handlebar ist und zum anderen ueberfluessigen Protokolloverhead produziert.

Schau dich also mal um ob du von TCP auf UDP umstellen kannst. Die meisten Player sollten damit klar kommen.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 30. Dez 2006 15:02 
Offline

Registriert: 22. Dez 2006 23:17
Beiträge: 9
In Netzwerktechnik bei Linux hab ich nicht so viel Erfahrung :(

Wie würd ich das machen bzw. geht das bei IceCast überhaupt?


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 30. Dez 2006 19:51 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Weitere Ideen: Ihr habt einfach zu viele Zuhörer. Oder das RZ schwindelt, weil die eigene Anbindung gar nicht ausreicht, um >100 Servern jeweils 100MBit/s zu gewähren.

In welchem RZ bist du? Ich könnte mal ein *b*ing von einem meiner Server zu dir machen -- wenn die Rechner nicht am selben Ort stehen, dürfte das recht aussagekräftig sein.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 30. Dez 2006 20:58 
Offline

Registriert: 22. Dez 2006 23:17
Beiträge: 9
Nein nein - jeder Server hat 100 Mbit/s. Das sollte das RZ in Karlsruhe sein.

Zu viele Zuhörer kann nicht sein ^^ wir haben durch den Buffer so viel verloren das wir nur noch >99 Zuhörer haben :(

Try mal: 87.106.1.80


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 30. Dez 2006 23:26 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Hrm, muss erstmal bing installieren. Mal gucken.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de