Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
NVIDIA Karte lässt sich einfach nicht installieren/konfigurieren HILFE

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
codec



Anmeldungsdatum: 23.12.2006
Beiträge: 2

BeitragVerfasst am: 23. Dez 2006 11:23   Titel: NVIDIA Karte lässt sich einfach nicht installieren/konfigurieren HILFE

Erstmal Hallo zusammen,

Habe vor ca. 4 Tagen angefangen mich mit Linux zu beschäftigen, da Windows langsam langweilig wurde. Wie dem auch sei.
Die Installation von SuSe 10.2 hat ohne Probleme funktioniert und alles läuft soweit. Nur kann ich 3D Anwendungen (wie zb. das mitgelieferte Spiel unter den Arcarde Games: irgendwas mit commander) nur extrem ruckelig laufen lassen, da die 3D Beschleunigung nicht aktivierbar ist mit den standard SuSe 10.2 NVIDIA Treibern.

Also habe ich erstmal die einfache installation der Treiber durch Yast probiert was auf vielen Seiten zu finden ist:

"Update your Kernel via YOU (YaST Online Update). Use

YaST -> Software -> Change installation Source -> Add

Protocol: HTTP
Server Name: : download.nvidia.com
Directory on Server: /opensuse/10.2

to add the NVIDIA ftp server as additional installation source.
Now use

YaST -> Software -> Install and Delete Software

to install the NVIDIA driver. Select the following packages:

x11-video-nvidia
nvidia-gfx-kmp-"kernel-flavor"

"kernel-flavor" depends on your installed kernel. Check with
"uname -r" for installed default/smp/bigsmp kernel. Use "sax2 -r"
for X.Org configuration."

^^ das hat ohne Probleme funktioniert, aber die 3D Beschleunigung hatte zwar ein Häckchen plötzlich, jedoch konnte ich das Spiel immernoch nicht starten. Also dachte ich mir neustart muss helfen. Neustart gemacht und dann flimmert der Bildschirm erst, es kommen graue Flächen und shadet dann zum schluss zu einem Weißen Bildschirm. (mit Strg +Alt + F1 komm ich trotzdem noch in die console die ich sehe.. nur die grafische oberfläche einschalten geht nicht > weißer Bildschirm)

also dachte ich mir ok, da muss ein Treiber problem vorliegen also ging ich nach langem hin und her zu der etwas komplizierteren installation über

Part 2 sah dann so aus:

"1) Kernel sources must be installed and configured. Usually this means
installing the 'kernel-source', 'make' and 'gcc' packages with YaST2.

2) Use the nvidia installer for 1.0-9629.

sh NVIDIA-Linux-x86-1.0-9629-pkg1.run -q

3) Configure X.Org with

sax2 -r -m 0=nvidia (0 is a digit, not a letter!)

NOTE: There is no need to try to enable 3D support. It's already
enabled, when the nvidia driver is running.

IMPORTANT: You need to recompile and install the nvidia kernel module
after each kernel update.

sh NVIDIA-Linux-x86-1.0-9629-pkg1.run -K"

installation lief ohne Probleme nur wenn ich dann zum Punkt kam "sax2 -r -m 0=nvidia" kam wieder großes geflaker, grauer hintergrund und am schluss war wieder ein weißer Bildschirm. 10 Stunden lang hab ich es ca. probiert, auch mit unterschiedlichen treibern. Alles fürht zum gleichen ergebniss.. kam nicht mehr auf die Grafische Oberfläche, da dort immer ein Weißer Bildschirm kommt.

Um es wieder zur grafischen Oberfläche zu schaffen hab ich einfach den Default Nvidia Treiber von SuSe eingesetzt (durch "sax2 -m 0=nv"). Kam dadurch immer wieder auf die Grafische Oberfläche, aber natürlich keine 3D Beschleunigung da es nur die default treiber sind.

Ich weiss jetzt wirklich nicht mehr weiter Leute und hoffe hier auf eine letzte Hilfe.

Zu meiner Hardware:

Notebook von Toshiba
Geforce4 Go 440
512 RAM
40 GB Festplatte
ca. 1600 mhz
P4 Mobile

Ich danke euch schonmal im vorraus.

Take Care

P.S.: Auch habe ich schon die Yast Treiber NVIDIA Installation wieder gelöscht und verschiedene kombinationen probiert.. alles nicht geholfen
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 23. Dez 2006 13:33   Titel:

Der weiße Bildschirm ist der Hintergrund des nVidia-Logos, das beim Starten von X kurz eingeblendet wird. Der konnte also gerade noch dargestellt werden, beim Rendern des Logos hat die Karte aber die Segel gestrichen.

Versuch es mal mit der neueren Version 1.0-9746 von der nVidia-Homepage. Evtl. funzt die besser: http://www.nvidia.com/object/unix.html

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

codec



Anmeldungsdatum: 23.12.2006
Beiträge: 2

BeitragVerfasst am: 23. Dez 2006 17:52   Titel:

danke Janka für die Antwort... ich muss aber glaube ich die treiber mit den 96XXXX installieren... hattes es zumindest mal mit den 97XXXX probiert, da meinte er ich soll die 96XXXX benutzen. was meinst du dazu? hab die Geforce4 440 Go
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 24. Dez 2006 17:32   Titel:

Das kann ich dir nicht genau sagen, da ich diese Karte nicht besitze. Versuch macht klug. Es gibt auf jeden Fall nur zwei Hauptlinien der nVidia-Treiber. Die für die "alten" (Riva TNT etc.) Karten, und die für die neueren (GeForce) Modelle.

EDIT: Guck mal hier
http://www.nvnews.net/vbulletin/showthread.php?t=78160
http://www.nvnews.net/vbulletin/showpost.php?p=996233&postcount=20


Da dieses Problem nicht ganz so selten zu sein scheint, und definitiv mit dem nVidia-Treiber selbst zusammenhängt solltest du einfach mal im nVidia-Treiberforum fragen. Da lesen auch die Supportleute von nVidia mit.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Scory



Anmeldungsdatum: 16.04.2004
Beiträge: 188

BeitragVerfasst am: 30. Dez 2006 13:16   Titel:

Du solltest die Startseite für den Treiberdownload bei Nvidia schon genauer lesen. Zitat:

Code:
Die mobilen Produkte (GeForce 6 Go, GeForce FX Go, GeForce4 Go, GeForce2 Go, Quadro4 Go GL, Quadro FX Go) werden nicht von den NVIDIA Referenztreibern unterstützt. Bitte setzen Sie sich mit dem Hersteller Ihres Notebooks in Verbindung, um den aktuellsten Treiber zu erhalten.
An dritter Stelle wird Deine GeForce4 Go genannt - also ist nix mit Nvidia Treiber.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy