Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
LaTeX Hintergrundfarbe über gesamtes Dokument

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
sesame
Gast





BeitragVerfasst am: 25. Dez 2006 0:30   Titel: LaTeX Hintergrundfarbe über gesamtes Dokument

Hallo,

habe ein Problem mit LaTeX:
Mit dem Befehl "\pagecolor{green}" lässt sich laut Anleitung die Hintergrundfarbe eines Dokuments einfärben (hier in grün).

\usepackage{color} ist auch vorhanden.

Bei der Ausgabe (pdf nach kompilieren) bleibt das Dokument allerdings weiss; es sind jedoch keine Fehler beim Kompilieren aufgetreten (nicht mal warnings oder badboxes).
Warum ist das Blatt nicht farbig?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 25. Dez 2006 12:54   Titel:

Bist du nach dieser http://www.uni-koeln.de/rrzk/kurse/unterlagen/latex/ergaenzungen/pdftex.pdf Anleitung vorgegangen?

Außerdem: Hat das Dokument mehr als eine Seite? \pagecolor wirkt ganz bestimmt wie viele andere Optionen erst auf die Folgeseiten.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

sesame
Gast





BeitragVerfasst am: 26. Dez 2006 1:02   Titel:

habe das ganze jetzt nochmal versucht, mit mehrseitigem dokument und nach der anleitung. geht immer noch nicht. verstehe nicht, wieso.

geht denn ein hintergrundbild? ich finde nichts dazu.

für ein paar zeilen code wäre ich dankbar.
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 26. Dez 2006 12:49   Titel:

Das folgende funzt hier:

Code:

\documentclass[a4paper]{article}
\usepackage[pdftex]{hyperref}
\usepackage{german}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{ae}
\usepackage{color}
\begin{document}
\pagecolor{red}
Dies ist ein PDF-Dokument
\end{document}


Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

sesame
Gast





BeitragVerfasst am: 26. Dez 2006 16:13   Titel:

jo. jetzt.

jetzt habe ich den eigentlichen fehler gefunden. danke für die hilfe.
es ging die ganze zeit und lag nicht am code. sondern am anzeigeprogramm.
evince zeigt die hintergrundfarbe nicht an, xpdf und der ghostview schon.

vielen dank.


________________________

wallpaper geht jetzt auch, mit:

\documentclass[a4paper,11pt]{scrartcl}
\usepackage{wallpaper}
\usepackage{color}

\begin{document}
\ThisTileWallPaper{\paperwidth}{\paperheight}{background.png}
\section*{An example of changing the aspect ratio of the tiles on this page}
\newpage
\ClearWallPaper
\section*{The wallpaper removed}
\end{document}
_______________________
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 26. Dez 2006 16:32   Titel:

Ich hab acroread benutzt. Das ist ja die Referenz für PDFs.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

sesame
Gast





BeitragVerfasst am: 26. Dez 2006 18:04   Titel:

seit dem es den acroread 7 gibt, ist acroread bei mir out, obwohl es seit langem wieder eine linuxversion davon gibt.
grund ist die spionagefunktion, die mag ich nunmal nicht.

ganz nebenbei stehe ich auf debiankonformes licencing und bevorzuge daher gv oder xpdf Smile)

____________
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 26. Dez 2006 20:08   Titel:

Die Spionagefunktion? Du meinst, dass der acroread Dokumente externe Referenzen (zum Beispiel Zähler) nachladen lässt? Das kann man doch abschalten.

Die ständige Javascript-Abfrage beim Beenden nervt zwar, man kann es jedoch auch abschalten, wenn man in der Datei ~/.adobe/Acrobat/7.0/Preferences/reader_prefs die in der Zeile
Code:

/EnableJS [/b true]

das true durch false ersetzt. Da es sich bei /usr/X11R6/bin/acroread eh' um ein Shellscript handelt, kann man das auch gleich dort machen.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

sesame
Gast





BeitragVerfasst am: 27. Dez 2006 19:39   Titel:

nein, ich meine dies hier:
http://www.pro-linux.de/news/2005/7974.html

auf sowas habe ich keinen bock und es zerstört m.E. das vertrauen in diese software.
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 27. Dez 2006 20:47   Titel:

Das *ist* doch genau das, was ich meine. Per Javascript werden Webseiten aufgerufen. Hast du dir den Artikel überhaupt durchgelesen?

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

sesame
Gast





BeitragVerfasst am: 28. Dez 2006 14:52   Titel:

jo, DAS ist aber auch das, was ich meine. vielleicht verstehen wir uns nur gegenseitig falsch.
ich will nicht anfangen, irgendwelche funktionen ausschalten zu müssen, um sicherer zu sein, sondern strittige funktionen gar nicht erst haben. ich mag gar nicht erst das unterstützen, was m.E. in die falsche richtung läuft. (denn: es geht ja niemanden etwas an, dass es bei mir nichts zu holen gibt.)
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 28. Dez 2006 22:50   Titel:

Du hast hoffentlich google verboten, Cookies zu setzen. Sonst nützt die Paranoia nämlich nix. Wink

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy