Streamtranscoder unter Suse 10.0

Antworten
Nachricht
Autor
Teddys
Beiträge: 3
Registriert: 10. Jan 2007 23:02

Streamtranscoder unter Suse 10.0

#1 Beitrag von Teddys » 10. Jan 2007 23:11

Hallo ihr,

ich habe einen neuen Server der unter Suse 10.0 läuft. Auf diesen möchte ich einen Streamtranscoder installieren aber er verweigert mir die Installation von libvorbis weil er die libogg nicht findet, wenn ich den Transcoder configurire dann zeigt er das der libogg installiert sei. Habt ihr eine Idee?
checking GCC version... 4.0.2
checking for memory.h... (cached) yes
checking for cos in -lm... yes
checking for pthread_create in -lpthread... yes
checking for pkg-config... no
checking for Ogg... no
*** Could not run Ogg test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding Ogg or finding the wrong
*** version of Ogg. If it is not finding Ogg, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error: must have Ogg installed!
das schreibt der mir aber ich finde keine neuere Version des libogg also die 1.1.3

LG
Teddys

Benutzeravatar
Janka
Beiträge: 3585
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 11. Jan 2007 11:21

Vermutlich benötigst du nicht nur die fertige libogg, sondern auch das devel-Paket dazu -- da sind die Headerdateien drin, die man zum Kompilieren eigener Programme mit der jeweiligen Library benötigt.

Evtl gibt es auch eine Option, ./configure zu sagen, wo genau er die libogg suchen soll. Falls sie unter /usr/local/lib installiert ist, wird sie normalerweise nicht automatisch gefunden. Mehrere installierte Versionen können auch problematisch sein.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Antworten