Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 19. Nov 2018 14:19

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 6 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Linux PDC -> Windows 2003
BeitragVerfasst: 07. Feb 2007 21:56 
Offline

Registriert: 07. Feb 2007 19:08
Beiträge: 14
Servus zusammen, nach ausgibieger nutzung der SuFu des Forums bin ich leider noch nicht fündig geworden was meine Frage anbelangt.

Als aller erstes mal ein Dankeschön für das schoene Howto für die Einrichtung eines Linux Servers als PDC mittels Samba und Heimdal :)

Ich habe einige Freigaben eingerichtet die soweit auch einwandfrei funktionieren, allerdings aber nur wenn sie einer Gruppe oder einem User gehören die auf den DC (Windows Server) angelegt sind. Wenn ich nun eine Freigabe einrichte die explizit nur einem User zugänglich sein soll der auf file ebene (psswd) von Linux angelegt ist und nicht unter windows funktioniert das nicht so ganz...Gibt es eine lösung, ich verwende als simples Beispiel hier einfach mal den user root (auch wenn man das nicht machen sollte ich weis, es dient als Beispiel). Ich habe zusätzlich einige Parameter in der smb.conf hinzugefügt und gleich wieder entfernt weil ich dachte es liegt an diesen, aber selbst wenn ich die standartkonfiguration aus dem Howto von pro-linux verwende stosse ich auf das selbe ergebnis.

[usrlocal]
comment = beispeil
path = /usr/local/
read only = No
browsable = No
writeable = Yes
valid users = root #oder @root funktioniert beides nicht

_________________
h3h3h3


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 08. Feb 2007 10:52 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Das kann so nicht funktionieren. MS-Windows meldet sich immer mit dem Benutzer bei Samba an, den man *dort* angegeben hat. Das muss aber ein Benutzer sein, den Samba auch authentifizieren kann. Dafür gibt es die Samba-Kennwortdatenbanken (/etc/samba/smbpasswd, TDB, LDAP etc.). Gegen /etc/passwd bzw. /etc/shadow kann Samba nicht authentifizieren, da die Kennwortverschlüsselung von Linux und MS-Windows anders ist.

Richte einen Benutzer mit smbpasswd ein, mit dem funktioniert das dann.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 08. Feb 2007 19:12 
Offline

Registriert: 07. Feb 2007 19:08
Beiträge: 14
Hallo Janka...

Dass hatte ich ja ganz vergessen zu erwähnen dass ich natürlich den user root mit smbpasswd bereits angelegt habe...Entschuldigung...

der Befehl hierfür war:

smbpasswd -a root -> dann passwort eingeben und insofern es kein selbst kompeiliertes samba ist speichert er es unter suse in /etc/samba/smbpasswd mit nem generiertem Hash...die datei sieht dann ungefähr so aus wenn nur benutzer root hinterlegt wäre wie im beispiel ->

root:0:GSDAgf23434FASDAASF344234ASDAS312231ASDA::ABA-123ADSASD:

!!! Okey somit müsste er den benutzer root kennen...oder? Leider klappt das aber nicht so ganz wie bereits oben geschrieben :(

_________________
h3h3h3


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 08. Feb 2007 23:07 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Moment, PDC! Ich sehe hier zwei Probleme: Normalerweise sollte (IIRC muss) man bei Benutzung der PDC-Funktionalität zumindest tdbsam als Kennwort-Datenbank verwenden. Je nach Einstellung der Option "passdb backend" in /etc/samba/smb.conf werden Einträge in /etc/smb/smbpasswd sowieso ignoriert. Musst du nachschaun, ob das bei dir auch der Fall ist.

Kennworte werden z.B. bei meinem System per tdbtool statt smbpasswd angelegt. Die Datei dafür ist /etc/samba/secrets.tdb

Zweites mögliches Problem: root wird in /etc/smb/smbusers auf irgendwen gemappt, der dann keinen Zugriff hat.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09. Feb 2007 16:24 
Offline

Registriert: 07. Feb 2007 19:08
Beiträge: 14
interresant, die Info hat mir gefehlt, sorry bin im domäne anbinden mit samba totaler neuling :oops: ich "forsche" mal weiter...

danke, bis zum nächsten post :)

_________________
h3h3h3


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09. Feb 2007 17:46 
Offline

Registriert: 07. Feb 2007 19:08
Beiträge: 14
Okey also ich steig wohl echt noch nicht ganz durch...

Ich vermute das ich meinem Samba zwar beigebracht habe als PDC zu fungieren aber die lokalen linux benutzer ausgeschlossen habe und mir irgendwas in der smb.conf fehlt....

Hier mal ein Auszug der configs:

/etc/samba/smb.conf:
[global]
workgroup = EX2X
netbios name = exserver
realm = EX2X.DE
idmap uid = 10000-15000
idmap gid = 10000-15000
winbind separator = /
winbind use default domain = Yes
security = ADS
encrypt passwords = yes
password server = exserver2.ex2x.de
client use spnego = yes

[usrlocal]
comment = beispeil
path = /usr/local/
read only = No
browsable = No
writeable = Yes
valid users = root
create mask = 0770
directory mask = 0770

/etc/samba/smbusers:
root = administrator
;nobody = guest pcguest smbguest

/etc/nsswitch.conf:
passwd: files winbind
group: files winbind

hosts: files dns
networks: files dns

services: files
protocols: files
rpc: files
ethers: files
netmasks: files
netgroup: files nis
publickey: files

bootparams: files
automount: files nis
aliases: files

_________________
h3h3h3


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 6 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de