Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Dickes Problem mit nvidia graka und SiS Chipsatz .bezüglich 3D

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
OS Freund
Gast





BeitragVerfasst am: 15. Feb 2007 14:24   Titel: Dickes Problem mit nvidia graka und SiS Chipsatz .bezüglich 3D

Also da will ich doch glatt komplett auf Linux umsteigen ,habe aber ein großes Problem . Nach dem installieren der proprietären Nvidia Treiber ,friert X ein ,Habe es mit verschiedenen Distributionen ,und verschiedenen einstellungen in der /xorg.conf versucht ,hilft alles nichts .
Habe schlieslich bei holarse-linuxgaming.de lesen können ,das mein Problem wohl damit zusammenhängt ,das dieser Nvidia treiber sich unter Linux nicht mit meinem SiS Chipsatz versteht ,als Lösung wird die Verwendung des "agpgart"Moduls Vorgeschlagen ,Nur weiss ich nicht WIE? und überhaupt habe ich dann wenigstens noch eine wenn auch vielleicht verlangsamte 3D Hardware Beschleunigung ?

Wäre toll wenn mir jemand weiterhelfen könnte ,bin völlig frustriert !
Danke
 

nvidia
Gast





BeitragVerfasst am: 16. Feb 2007 4:26   Titel:

du musst im kernel den agpgart treiber entfernen. für die sis chipsätze stellt nvidia einen eigenen agp treiber zur verfügung.
in der xorg-config muss man dann
Zitat:
Option NvAGP "1"

einfügen. dann wird der nvidia agp-treiber benutzt.
im kernel ist das irgendwo in device-drivers drin.
bei mir klappt das zwar trotzdem nicht, aber vielleicht bei dir.
und es kommt darauf was du für eine graka hast. ältere laufen nur noch mit den
legacy-drivers.
alles zu lesen auf der nvidia seite.
 

OS Freund
Gast





BeitragVerfasst am: 16. Feb 2007 12:37   Titel: Problem gelöst

also ich habe mir nochmal die Liste der unterstützten Motherboard Chipsätze bei Nvidia angeschaut ,und meiner (SiS 746FX) ist nicht dabei ,also ist es falsch "option NvAGP "1" zu setzen statdessen sollte der Wert 2 oder 3 sein um "agpgart" statt des Nvidia agp zu benutzen (3D Beschleunigung bleibt aktiv).

Das alleine reichte aber nicht, zusätzlich musste ich noch in die /etc/X11/xorg.conf in die Liste "load Modules" den Eintrag "Load GLcore" machen .
Seiddem startet X ohne Probleme mit 3D Hardware Beschleunigung .
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy