Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 12. Nov 2018 23:47

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 5 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 16. Feb 2007 10:43 
Offline

Registriert: 13. Dez 2006 16:16
Beiträge: 35
Hi,

auf meinem alten Kernel läuft das Programm xy. Jetzt musste ich einen neuen Kernel (2.6.12) erstellen, damit ich meine IEEE488 Karte einbinden kann. Das hat auch prima geklappt.

Jetzt hab ich allerdings das Problem: Wenn ich mit dem neuen Kernel boote, kann ich das Programm xy nicht mehr starten.
Wenn ich es aus dem Terminal starten möchte, versucht das System eine neue Konsole zu öffnen, das scheitert aber und das System springt zurück in meinen Terminal.
Dort kommt die Meldung : svgalib allocated virtual console #9

Wenn ich eine neue Konsole öffne und von dort das Programm starten möchte,
kommt die Meldung : svgalib: mmap error

Hab ich beim erstellen das neuen Kernels vielleicht eine Option in der .config falsch gesetzt? und wenn ja welche? Oder muss ich irgendetwas anderes machen?

Hat jemand eine Idee? Hilfe, bitte.

Wie gesagt, mit dem alten 2.6.9-42 Kernel funktioniert es noch, allerdings bekomme ich da meine IEEE-Karte nicht zu laufen.
Danke für euer Hilfe.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 17. Feb 2007 11:08 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Hast du die Konfiguration aus dem funktionsfähigen Kernel übernommen, z.B. mit gunzip -c /proc/config.gz > /usr/src/linux.../.config ?
Oder von Hand nachgeführt?

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 19. Feb 2007 7:25 
Offline

Registriert: 13. Dez 2006 16:16
Beiträge: 35
hi Janka,

ich hab die .config genommen die im Verzeichnis /boot rumlag unter dem Namen config-2.6.9-42.EL

Hernach startete ich "make oldconfig", wobei einige Einstellungen nicht gefunden wurden. Es hat auch erst geklappt, nachdem ich die SCSI Untersützung komplett entfernt hatte
(mit xconfig), da bei "make all" immer Fehler mit den SCSI Treibern entstanden.

Ferner ist mir aufgefallen das die Auto-Mount-Funktion von USB-Geräten nicht mehr funktioniert.

Werde mal deinen Tip ausprobieren.

Gruß m.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 23. Feb 2007 10:56 
Offline

Registriert: 13. Dez 2006 16:16
Beiträge: 35
Hi,

diese Datei gibt es nicht in meinem /proc Verzeichnis.

Habs jetzt noch mal das mit nem Kernel 2.6.9 probiert, da funktioniert es.
Wenn ich dann das gleiche .config benutze um einen Kernel 2.6.19 zu erstellen funktioniert es nicht.

Vielleicht liegt es auch an der Software die einfach nicht zu einem höherem Kernel kompatibel ist. (Ich hab keinen Sourcecode). Scheiße !!


Habs auch schon mit Fedora Core5 versucht -> hat funktioniert. Leider gelang es mir hier nicht das IEEE488 Interface einzubinden/kompilieren.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 23. Feb 2007 11:36 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Zitat:
Hi,
diese Datei gibt es nicht in meinem /proc Verzeichnis.
Dann ist diese (sinnvolle) Option beim Kompilieren des Original-Kernels nicht eingeschaltet gewesen. DOOF!
Zitat:
Habs jetzt noch mal das mit nem Kernel 2.6.9 probiert, da funktioniert es.
Wenn ich dann das gleiche .config benutze um einen Kernel 2.6.19 zu erstellen funktioniert es nicht.

Vielleicht liegt es auch an der Software die einfach nicht zu einem höherem Kernel kompatibel ist. (Ich hab keinen Sourcecode). Scheiße !!
Ja, ohne Quellcode ist Mist. Vielleicht gibt es aber eine neue Version der Software, die mit neuen Kerneln kompatibel ist.

Zitat:
Habs auch schon mit Fedora Core5 versucht -> hat funktioniert. Leider gelang es mir hier nicht das IEEE488 Interface einzubinden/kompilieren.
Doppelmist.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 5 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de